[RELEASE] TCP Connected bulbs work with SmartThings Again!

Still working fine for me too, quite stable.
I’m using DNSMasq on my home linux server to blackhole the auto firmware updates.


1 Like

You have to block access to update not from your pc but from your router. What is the brand of the router do you have?

What do you think? Which image is the best for this setup tcpmod_firmware.img or rootfs_2.0.47.bin?

Does this require you to have a smartthings hub or will it work like it use to without the smart things hub? The whole internet blocking is confusing

I don’t have access to a PC and this python script doesn’t seem to want to work on my macbook. Running the https.py script I get the below error:

Traceback (most recent call last):
File “/Users/Josh/Desktop/TCPFirmwareRestore-master/https.py”, line 2, in
import BaseHTTPServer, SimpleHTTPServer
ModuleNotFoundError: No module named ‘BaseHTTPServer’

Any ideas? I don’t know a whole lot about python but I have all the rest set and ready. Thanks in advance.

Can someone give me some help please?

I have TCp Gateway v 2, I have Smartthing hub running. How do I get the TCP connected hub to talk to Smarthings?

I have blocked greenwave in my local network so it won’t update
I have assigned static IP to the TCP hub.


1.- Fix the ip of tcp hub in the router to avoid ip changes

2.- Block internet of tcp hub

3.- Instal TCP app in your phone

4.- Add all your lights with the original tcp app , avoid to use custom images

5.- Install the Connector and device handler in your ST IDE

6.- Run connect app and add the ip hub

7.- Click next and wait some seconds, if hub is not found , check the ip,

8.- Select the light you want to add to ST.

got it! added over 35 TCP connected lights to Smart things! Thanks!

1 Like

what is the connect app where I would add the ip hub

The connect app is the manager who discover the lights and allows to add them to SmartThings.

Read the first post.

Still working stable, I just have 5 lights working and the response is fast, please tell me your experience with other setups.

@What_the_f What its your experience with 35 bulbs working in long term?

cant seem to get this to work.

I have a Netgear R6700v2 router

my tcp hub ip is

In the router i’ve set block on services for ip tcp/udp for port range 1-65535

I’ve added blocked sites:
greenwavereality. eu
greenwavereality. com
update.greenwavereality. com
update.greenwavereality. eu
(without the space after . )

I’ve blocked access control to ip:

followed the doc to update the firmware (which worked exactly as specified)

however in the smart things app i get “tcp gateway is not responding”

live log just shows “state.loadStatus Loading”

You no need to block ports in the TCP hub ip, you need to block just internet access

If you block the ports, ST can not access to TCP hub

I tried removing the port and still not finding my bulbs :frowning:

Do you need to have a Smarthings Hub/Gateway to use the TCP lights with Alexa?

Is there any step by step guide starting with how to downgrade the TCP hub firmware?

Thank you very much!

Yes, you need the SmartThings hub and TCP hub to use the lights with Alexa.


sorry for the long reply :slight_smile:
virgin hub v3
any help much appreciated :slight_smile:

Hi, i do the donwgrade, but how do I do the rest? device handler and app connect. Some guide or manual? Thanks.

If you dont know how to install the connect and the device code I suggest you to read

Thanks, i read the faq and i have the app in the phone, but hub not donwgrade de firmware. I do the instruccions 3 times and nothing dont work, in the phone tcp app appears 3.0.80.

Please help.