[RELEASE] Official Monoprice Smart Plug/Plugin Receptacle with USB Ports Device Handler

I second this. I bought the Monoprice outlet to control USB devices and while he main outlet turns on and off, the USB stays on. This sounds more like a Monoprice problem but if Rboy can fix it that would be great.

Does the DTH support disabling the on/off functionality of the switch? I’m using the device as a power meter on my washer machine and don’t want to accidentally turn off the switch.

My other option is to create an automation to turn it back on if it’s turned off.


Yes the switch can be turned on/off using the ST mobile app (in addition the the power readings). If you’re using the new ST app, it has the option to set a timer on the device page.

If you’re using the Classic app then you can setup a simple rule in SmartLighting or CoRE

First off, I am a paid customer of the wonderful RBoy smartApps and Device Handlers and am grateful for all the wonderful additions they add to SmartThings.

I have recently moved to the new app (v.3) and I am confused to why the v.2 screens give so much more information and settings then what we get from the new app. The Monoprice Smart Plug (27481) device handler is just one of the RBoys this way.

Why? Is the new app forcing everything to look the same or is it RBoys only wanting to write for the single platform?

I for one like the new app (recent release) and when I migrated I was able to deleted a couple of DH since the devices are now directly supported in ST.


The New App does not support the “legacy/Groovy” method of describing device handler UI tiles in the Metadata section of code.

The New App uses HTML5 based “plug-ins” to permit significantly richer UIs - but I don’t know what the hold-up is on getting developers to use this and SmartThings to publish them.

I bought the 27481 to use as a repeater for my Yale door lock & RLA. You’d think that if I could figure out how to input custom code and publish, I’d be able to figure out how to add the device to my Smartthings app and hub. But I can’t!! The instructions on Rboy’s page state, " 1. Now pair your device with the hub (see the SmartThings manual for pairing instructions). I can’t find pairing instructions, and I don’t understand why they can’t be detailed on the site since everything else is so nicely detailed. So, the repeater is plugged in, and I have no idea how to get it to be recognized by my hub. :frowning:

Just installed the device handler. I can see only the Threadsholds and the report frequency control But I can’t find how to control the LED from UI.

Just found on the Classic app. The middle tile on my phone shows no Icon but 3 dots.

Hi there. It looks like a bug in the new ST app in rendering preference settings. Please report it to ST support and we will also bring it to their attention so they can fix it. Thank you for letting us know.

I have updated to the newest device handler and i cannot switch the device on or off from smartthings classic or from the new smartthings app. Nothing else has changed. This happened for both of my monoprice 15654’s. Any suggestions?

Looks like your device has lost it’s connection to the hub. There was a firmware update to the hub which may have caused the issue. Try to power cycle your hub and do a Z-Wave repair or exclude and re-pair your switch with the hub.

1 Like

I dont think it has lost connection because i can still see the device status change when i plug stuff into it. Its still reading the wattage and if i turn it off by the switch on the top its status will change. I will try re-pairing it and see if that works.

Well, looks like re-pairing the device worked! Thank you for the prompt response!

I’m not able to control the led as well. Wanted to know if this has been fixed


Official Monoprice Smart Plug/Plugin Receptacle Device Handler - Version 02.00.00

  • (New) Support for new SmartThings mobile app with custom controls

NOTE: It may take up to 48 hours after updating the device handler for the platform cache to clear and show the new user interface. In some cases you may need to exclude your device, delete the device handler and set it up again for the changes to take effect.



Long time user of Rboyapps here! Really loving the work you do!

I have a strange voltage reading problem with my Monoprice Smart receptacle with 2 USB and 1 AC. One of my unit is reading correct voltage (120VAC) but other one is reading 240VAC all the time. Not sure if is related or I just have defective unit that I didn’t notice until now, but is there a setting somewhere I can change reading to 120V?

Thank you!

No updates to this thread for 2 years. RBoy, is there a plan to migrate drivers to Edge? Any beta drivers we can try? I’d just like to know so I can look for alternatives if needed. I’m initially interested in an Edge driver for the Monoprice Smart Plug and Repeater (27481).

There is a transition FAQ on Rboy’s site. As you can imagine, they’re very busy over there.

I use the driver for the Zooz ZEN06 smart plug. It works good.

1 Like

Did you ever find an Edge driver for this switch? I have the same one, and no Edge driver I have tried works, including the Zooz ZEN06 posted above. In fact, I get ‘Ineligible device’ when even attempting to look for a driver, so I assume the hub shows nothing compatible.