SmartThings Community

[RELEASE] Fibaro FGBS-001 Universal Binary Sensor (UBS)

dth_sensors

(Steve B) #62

I was pairing with the device and hub about 3 meters apart.I’ve tried it again with them a foot apart but no change.


(Steve B) #63

Does it indicate anything that the parent device doesn’t change the display for input 1 when triggered but the child device does?


(cjcharles) #64

Probably not. I can’t remember how I coded it but think the v3 commands are used for most status updating as they are they only ones sent for most events.

If you can I’d try it on a friends SmartThings and see if is different. Otherwise you’ll have to talk to Fibaro to see what they think and maybe get a replacement if they don’t have any ideas.


(Tony) #65

I also have a similar problem where the second child contact doesn’t trigger and doesn’t show any events. It also has no current state. Sorry, I didn’t have time for any live logging and am away from home at the moment, but just wondered if there were any further thoughts on this? The first child contact works great, but the parent device shows the wrong state for the first child contact.


(Marco) #66

Hello, try to go to settings and set manually all the parameters (the default one will be ok)… then it will start to work :slight_smile:


(Tony) #67

Thanks, but setting the parameters was the first thing I tried, and it made no difference.


(Borristhecat) #68

Did you then send the command to program it?


(Tony) #69

I probably didn’t the first time, but did subsequently with no success. I’m not in a position to test the input to the second contact at the moment. Perhaps I should wait until I can and then go through the whole set up process again.


(mark) #70

Hi, ive had a little trouble today setting up my second UBS. This is inside an alarm motion sensor. All was working well as a contact. But when i change the child devices to motion, the motion switch would work.

So i deleted the child devs and start again. The next time i had to delete again but this time not via the ide but via parent device screen in the classic app. Now the child devices were deleted but the parent seems to be still looking for them (looking at the logs) and as such, crashing the classic app device list (no devices show).

If i go online to the ide and try to delete the parent, i get a 500 internal server error so dont even get to see the delete option.

Anybody have any idea how i can delete the offending device or do you think this is a support ticket?

Thanks


(Daz) #71

Hi. Just wondering if anyone is successfully currently using this product to monitor temperature using an external probe for the purposes of fish tank temp measurement ?

Looks interesting. TIA for any replies, feels like this should be a relatively simple thing to do but I’m not having much luck = )


(Simon) #72

I have had a UBS measuring the temperature in my fish pond (3 external l temp probes) for 4 months now with no issues. I also installed one for a friend to monitor a swimming pool. Again no issues.

You should be able to delete child devices and recreate them from the parent device without issue. All I can think is that the sensors are different to what the UBS is expecting and this is causing the issues. The UBS can be sensitive to changes in attached devices . My advice would be to exclude and then re-incude the device. Then you should be able to create the child devices. I am using the cjcharles DTH. I did try the other one, but found the cjcharles one better for my needs.


#73

Just installed your device handler but wouldn’t show my 4 x temperature probes in the classic app and wouldn’t allow me to edit and save the config in the app. So I edited it to add the defaults through the smartthings console and all works now, very happy indeed! Many thanks for an excellent app.


(Simon) #74

Are you on Android by any chance?


#75

Nope, iPhone 8+.


(Adam Murray) #76

Hey Guys,
I’ve setup a UBS and each port is being used as a motion sensor (attached to a PIR for each).
They are correctly detecting motion when i view the device but when i check them in smart home monitor they are showing up as inactive and aren’t registering motion.
any suggestions on what i could of done wrong? parameters perhaps?



#77

Hi all, was wondering if I could get some assistance please. I have a non-smart GuardLink driveway motion alarm which i want to feed my Fibaro UBS and get it reporting into ST. I bought a Fibaro UBS for this single purpose.

I am using @cjcharles device handler, set the parameters as all defaults and just don’t see any activity when there’s motion. I feel like i’m missing something stupid.

I also tested with PIR sensor I bought ages ago for a project and I don’t see the events in SmartThings for anything.

Fibaro is definitely alive , it’s pairing with ST.

Do I need to set parameters or it won’t work?

Do I need to configure what type of sensor I’m connecting to In1 anywhere?

any help gratefully received!


#78

Hi Charles,

First thank you for sharing the code.
I have a couple of question:

  1. Is there no way to trigger the outputs via Smartthings app? or is it only possible to trigger an output by a physical input? (if it’s not possible, can you recommend a Z Wave device compatible with Smartthings that will allow me to trigger an output via the app? (i.e. a simple short for 2 seconds.) My intention is to switch a PC on/off (by shortening the power pins) on via the app.
  2. Regarding the temp reading, all i require is a BS18B20 temp sensor? That’s it?

Thanks in advance :slight_smile:


(Borristhecat) #79

the data sheet device tells you this won’t work. the outputs are connected directly to the inputs by design. I wanted something similar as well. I can’t recommend anything unfortunately, im sure there are a few volt free switches out there i have seen though.

yep just remember to connect them BEFORE you add the device to a hub.


#80

Thank you so much :slight_smile:
In the end i used the input for my door bell, and triggered the bell via the output. Now my Alexa will notify me in each room that someone is at the door. The second input I will use as a basic switch for lights, etc…
In regards to the second issued, I used a Z-Wave relay/switch connecting to a timed 220V relay, Does the job :slight_smile: