[RELEASE] Fibaro FGBS-001 Universal Binary Sensor (UBS)

Yes you are reading those settings correctly. Bear in mind though that even when a reading is set to SmartThings, WebCore will only see an event if it changes. I had my sensor setup for every 30 seconds and now it is set for every 5 mins. There is no point sending lots of updates with no new information. It just adds to the Z-wave traffic.

First thing is to Check the temp reading is correct. then look at the frequency you want it updated.

The device handler receives it every interval (see screenshot in the logs for temperature1, not temperature2 which is highlighted but actually oscillates a bit), but you cant update the file given no update is needed. You could modify the handler if you wanted with a timestamp and that way see the updates are still coming through.

ah, cheers. sounds like the solution is a modified handler then, but it’s beyond me I’m afraid. Is this something anyone would be interested in doing, or am I the only one who will get any use out of it?

cheers all!

For a quick fix, add this line to about 407 in the device handler - just before this line log.debug "{tempendpoint} has changed to {tempprocessed}"

if (tempprocessed.toString() == device.currentValue("${tempendpoint}")) {tempprocessed = (tempprocessed + 0.1).round(1)}

It will basically lose you a bit of accuracy but will ensure the readings update every interval, by adding 0.1 degrees to the temperature if it exactly matches the previous reading. The next reading it would revert back assuming the temperature had still not changed.

1 Like

thank you very much !

worked ! ta

Any ideas why this happens? The delay’s seem a little unpredictable. 3, 14, 3, 7 min gaps with my current settings. Entirely possible I’m missing something obvious : p

Here’s the settings for the DTH:

P11 is set to 200 (approx 3.5 mins).

I’m not trying to be anal, I’m just trying to understand - sorry about the agitating questions!

Essentially I’m attempting to understand so that I can disable the central heating to certain areas if there’s a fault (for whatever reason) with one of the probes. Cheers!

Can’t see your logs, just the device history which is quite different.

However I also do think this performance is fine, sensors don’t normally just stop responding unless the wires/sensors break - which is very rare, and using this as a failure detection isn’t going to get called on very often.

thanks cjcharles.

Not being ignorant, so thought I’d say “cheers”, but I’ve got nothing interesting to add to this for now = p

I’m currently almost finished testing a potentially messy ‘diagnostic’, involving a periodic timer and some simulated switches. All in webcore…

I meant to look at the device history properly you need to look at live logging to see whether the 200s interval is being properly managed, since I would expect the modification above to totally fix things

I’m stuck prepping for new baby (any day!), so time is limited. Haven’t had a chance to check on this properly, but I’ll have a play at some point and report back.

fix is working brilliantly though, cheers !

Hi @cjcharles

Apologies if this is a stupid question - I am in the process of migrating from Zipato to ST so still getting to grips with things.

I am using the V3 hub and new app and I have a bunch of these universal sensors and not managed to get them to work yet. I pulled the latest code from your github and created a device handler - then added the device as a generic Z-wave device, then swapped to your DTH in the IDE. the app looks like this:

Am I doing something wrong here?

Thanks

You should use the classic app to setup the main device and create the child devices. Then it should show correctly in the new app.

1 Like

Smartthings have only just provided a little bit of guidance on getting things working in the new app, at least I think they have! So I’ll need to look at that at some point!

Thanks Simon!

Just gave that a try - used the new app to add the device, the classic app to add two child devices, then back to the new app, wake the device, and the sensor is reporting. I am not getting anything from the temperature sensor though. I tried clicking Add Temperature Child in the classic app but it did not seem to do anything…

Should I have used the classic app to add the device?

That shouldn’t matter, but you do need to have the temp sensor connected when you pair to Smartthings.

Do you see the temperature in the parent device of the classic app?

The sensor is connected as just moving the device over from my Zipatile.

I dont see a temperature in the classic app. There does not appear to be a child device for temp showing in the IDE either. I will try deleting it and re-adding

You should see it on the temp field on the parent device, if you can’t see it there it won’t create any children devices.

If not then you may need to look at the live logging to see what might be going on…