Re-engage phone presence

Last night my wife’s phone would not register as away. I tried closing/opening the app, restarting, etc and nothing worked. Today it’s back working fine, but now it’s my phones turn. I was away and was not able to get it to register as away. In both cases Android (wife=7.0 me =8.0) was showing ST checking location, just didn’t seem to be connecting to the presence. Is it safe to log out and back in or will that force me to re-add the presence sensor? I have both phones connected to a decent number of routines and what not so it’s a real pain to do that very often if it forces a reset. Was looking for the equivalent of whack the monitor to get it working again. Or maybe even ability to manually set present/away.

Add your presence sensors as favorites in your dashboard and see if your wish is granted :slight_smile:

I just tried that and don’t see a way to set manually. When I click on it, just drills into the detail page.

my bad, if you create virtual presence sensors you can

Thanks for trying.

Just tried logging out and back in with no luck. I also went to add my phone again as a presence sensor but now it recognizes I already added it and won’t re-add. That means next stop is I have to actually remove from all my automation, remove entirely, then re-add. Doh. I usually like to add a device a second time and then swap out with the old one in each thread so I can easily see where it came from.

My new phone (Samsung S8+) isn’t playing well with ST presence sensing. About 10% of the time it doesn’t detect that I came back home after being away even though the phone knows exactly where I am. The only thing that ‘wakes it up’ is to restart the phone. Nothing done to kick start the app (sign-out/in, force stop/restart) seems to matter.

My wife has an iPhone and it’s much worse, it seems to just drop into ‘away’ mode while sitting on the coffee table and it may or may not come back until she actually leaves and comes back.

The problem always seems to be ST showing the phone as away when it’s really here. Going away seems to work well as I haven’t had it show as being ‘home’ when I was away.

I had some luck by making the zone around my home larger.

I have the most problems with the ST sensor not my phone. I have had enough problems that I am using webCore and have set up T/F variables and use them in my rules so that I can quickly change out sensors without having to update all the rules that use them. The sensors control the variable and the variable is used in the different rules.

Accurately detecting presence, in its many forms, seems to be the stumbling point that Smartthings has just not mastered yet.

1 Like

Since Android 8.1 was just released in full, and I have a Nexus 5X, I have enrolled in the beta to see if I can get the update quickly. If that doesn’t work, will try and remove and re-add my phone. It’s odd as my phone has been pretty darn stable for a long time. I did get a security patch over the weekend which I am wondering if might be related. It seems to have reverted my Google Play services again.

There could be a number of things going on that is making this happen. Here’s a few things i did in order to help get it to be as accurate as possible. Make sure Android is set to High Accuracy for location settings. You should be able to find this by doing a search on “Location” in your settings menu. This uses GPS, WIFI, and cell towers to triangulate. Keep WIFI on at all times to help. I’ve also downloaded and use the free version of Life360. I then created a virtual presence sensor and created a CoRE app to check my phones presence and my Life360 presence. When one changes, it changes my virtual presence sensor. The virtual presence sensor is then the one I tie all my routines. Hope this helps and good luck!

1 Like

Thanks. I already had on high accuracy but am wary of installing another app. Not so much for me, but for my wife. She has a relatively low acceptance factor for my HA habit so I only will install an additional app on her phone if it gets bad. That’s what prevents me from going into the webCore presence route yet either.


How Do you create a virtual presence and what is CoRE?



To create a Virtual Presence Sensor

  • Login to the IDE @
  • Click “My Devices”
  • Click the “New Device” Button
  • Enter a “Name” for the device, this can be whatever you want.
  • Enter a “Label” for the device, this is optional and can be whatever you want.
  • Enter a “Device Network Id” This can be anything you want.
  • “Zigbee” Id should be left blank
  • Select a “Type” from the dropdown, this should be Simulated Presence Sensor
  • “Version” should be published
  • “Location” should be your hub location, probably “Home”
  • “Hub” should be your hub name.
  • “Group” is probably empty…
  • Click Create


webCoRE Community forums:

webCoRE installation video:

webCoRE wiki page:


So I created a virtual presence tonight, loaded into all my automations, removed my phone, added back, then put back in all the automations. Fingers crossed.

Well. . . didn’t work :frowning: Tried to update my Google Play Services which seems to have helped in the past, but for some reason it won’t install. BUT WAIT, there is a positive ending! I was resigned to having to reach out to support but realized I never uninstalled the app and reinstalled. Just tried that and my phone is registering as away! Now will have to wait for the end of the day to see if it registers as home.

As an iPhone user who has had nothing but frustration trying to get this feature to work I’m watching thread with great interest.

All of the really cool automation stuff I want to do relies on my phone to tell the system if I’m home or not, would be great if this all worked.

Phone correctly registered as home tonight. Yay!

Was using multiple iPhones for presence with the ST app for months with no issue, recently began not updating. Found out I had been logging into the app on all the iPhones with the same account credentials. Deleted the app from each phone, removed the presence from the ST environment, re-invited the users with their own email addresses/accounts created in my ST app, then reloaded the ST app on their phones and made sure they were accepting the invitation and then logging into the app on their iPhones with their unique credentials. Everything’s working again.

I factory reset my phone yesterday and re-installed SmartThings classic. My phone presence sensor is still there but it doesn’t seem to be working now. Can I reconnect the existing sensor to my phone? Or do I have to create a new presence sensor?

WebCoRE presence didn’t work great for me (Android). Sometimes both recognized coming & going correctly or one of the two would miss.

So I think I may have figured out the issue for those that may be experiencing the same thing. I went into the Smartthings IDE and found that I had two HOME locations. One which had mostly all of my devices and one that had a couple devices. I found that one HOME was for my Smartthings Classic app (which I still use) and one was for the new Smartthings app (which I only use for my PowerBot). For some reason the phone presence was being added to the HOME for the new app. So I found that the HOME for the new app was set as my default location. So I changed my default location to the Classic app HOME and readded my phone as a presence sensor and it successfully added to the classic app devices. So far it has been working properly so fingers crossed!