Raspberry Pi as musicPlayer (speech device with BigTalker)


(Brian S. Lowrance) #1

I’ve created step-by-step instructions of installing a Raspberry Pi as a DLNA mediarenderer which can then be accessed by SmartThings via @ule’s Generic Media Renderer and used by BigTalker.

I documented this while rebuilding my system to use with BigTalker on my Raspberry Pi. That said, it should be able to be used with any SmartApp that makes use of a device with musicPlayer capability. I am looking for willing participants to give these steps a shot and let me know of anything that needs adjustment/improvement.

Instructions ( Link )

Disclaimer: Use at your own risk. I make no warranty or guarantee of accuracy / functionality
These instructions are considered Beta until verified by multiple users.

Please leave feedback in the document, in a PM or in this thread

Doc Ver .03-Beta 2/9/2016


RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)
$65 Home Automation Announcer
[OBSOLETE 1.1.6 5/25/16] Big Talker - Talk when events occur
(Chrisb) #2

I’ll have to look into this at some point… My son is learning Raspberry Pi in school right now and I’m thinking I need to teach myself some about it as well.

Question: Does the the Pi have BT build in? I’m using an old Android tablet right now as my DLNA and BT-connecting it to Echo. It works but the tablet has a habit of losing connection with Echo even though it’s very close.


(Brian S. Lowrance) #3

For Bluetooth, you will need a compatible USB bluetooth adapter. The audio portion of the instructions will likely have to be modified. I use the 3.5mm audio port and have not attempted to add bluetooth audio. If someone does set it up and record the steps involved, we can adjust the instructions with an addendum for others to follow.


(Darin Craven) #4

This is perfect timing. I was just thinking of doing something like this, but the info was spread out all over the place. Thank you VERY much for putting this doc together!

One of the main reasons I wanted to do this is because I suspect I can also use the Raspberry Pi for ST speech, and as a print and file server. Can you confirm, or better yet offer some suggestions for software I would need to do the file and print serving as well as the stuff for music and speech on ST?

I am more of a point and click guy who tries to avoid anything command line. Not scared of it, just try to avoid it:)

Any advice would be welcome.


(Brian S. Lowrance) #5

@darincraven You’re going to get into some command line and config files when you setup services (such as file and print services). That said, you can install Webmin and then do most of your installation and configuration using the Webmin web-based interface which is where you’re going to get the somewhat point and click functionality.

Check this out to install Webmin: http://www.instructables.com/id/Adding-Webmin-to-manage-a-Raspberry-Pi/?ALLSTEPS

After you have Webmin installed, just search up more instructions for installing a file server using Webmin and then a print server using Webmin. There are tons of documentation, videos and forums on this, as well as setting up those services from command line. You will also likely want to look into instructions regarding securing the device and services.

Good luck with your project(s).


(Darin Craven) #6

Awesome, thanks for the suggestions. My new Pi is on the way now. I will start with the ST stuff and provide the feedback you requested.

Thanks again for putting this all in one spot!


(Darin Craven) #7

Thanks to @rayzurbock I am now the proud owner of a talking home automation system that offers endless other possibilities. I want to thank you again for putting this document together and for your help with my weird hub needing an update issue.

My next project is to buy bluetooth for my Pi and hook it up to my Echo. Then I am going to try to add file/print server capabilities, shove the Pi, printer and backup drive in a closet by my TV and enjoy my talking smart house.

So many possibilities and so little time. (dang job:)


(Av8rdude) #8

I am also trying to use bluetooth to connect my pi to echo. In the latest build of raspian (jessie) bluetooth has changed. I have not been able to successfully pair my pi to the echo and produce audio output.
If you figure this out please share your success.
Thanks,
Scott


(Frank) #9

I got this working but I get a error when I go and save the defaults with the store command. Rebooting the setting for Pcm output and playback are not set, I have to run the commands to set them and the it works


#10

Thanks for tutorial. Working good now


(Marty Lavender) #11

I have this up and running now. Pretty awesome.


(Marty Lavender) #12

Any idea why the Raspberry Pi would all of a sudden show up as not present?

EDIT

It’s back


(Marty Lavender) #13

I found this to be kind of a pain when using with a BT speaker. I ended up plugging my BT speaker in via the 3.5mm jack it has to the RP3 and then running raspi-config and forcing output through its headphone jack. Now it works flawless. Its almost amusing to the point that I run around and trigger events just to hear the voice talk.


(JIm) #14

I followed all the instructions to set up the PI. Everything seemed to go ok. The test worked at the end.

I installed the smartapp and device handler. But I can’t seem to get the PI to show up in the smartapp. Is there something I need to do to install the device?


(Brian S. Lowrance) #15

When you installed BigTalker there was an option to choose musicPlayer mode or speechSynthesis mode. VLCThing will only show up in musicPlayer mode. The option can’t be changed after install so you’ll need to click Remove in BigTalker to remove it then add it back from the Marketplace > MyApps


(JIm) #16

What I was talking about, in MediaRenderer it is supposed to discover devices. It never sees my RaspBerry PI.


(JIm) #17

Is there anyway to see in the Raspberry if the media renderer is running? I still can’t see it from MediaRenderer smart app. I have gone thru the instructions again and everything goes just like it should. I just can’t see it from ST.


#18

From the PI command​ line execute “ps -A” that should list all running processes.


(JIm) #19

I see a bunch of stuff, but nothing labeled media renderer. Should I be looking for a different name?

I looked in the file structure to try and find the file that should be running, can’t quite figure out which one it is.

Any help would be appreciated.


#20

to narrow it down a bit you can execute “ps -A | grep gme*” then look for gmediarender