Qubino Flush 1 Relay I2 & I3 Contacts Problem

Hello All, sorry for creating a new topic realted to Qubino Flush 1 Relay, but i have searched the forum like crazy and i wasnt able to find an answer anywere. I am using the device handler from Erocm1231 (unfortunatelly he doesnt use these devices anymore so he is not able to help).
My problem is related to the contacts I2 and I3 from the qubino flush 1 relay. The child devices are created without any problems in the smartthings app, i setup the settings as follows : Input 2 - Normally Closed input ype, Input 3 - same normally closed input type , then parameters enable/disable endpoint I2 / I3 both are set on Sensor Binary, and now comes the problem, if i fizically open I2 contact the smartthings app shows me Child device I2 Open, i close it back it shows Closed, if i fizically open I3 contact, i get open in smartthings app, but again for the child device I2 not for the child device I3 as it supposed to. I tried to reset the qubino several times, repair it to smarthings a lot of times, and the result is the same even if i fizically open I2 or I3 smartthings is reading only I2 open, and never the child device I3. I have t points where i need 2 contact sensors outside so that is why i bought these qubino devices. Think is that until about one month ago i had the same setup in another place it it worked without any problems with this device handler and settings and mentioned above, i deleted the child devices thinking that the new qubino relay was defective and since i deleted also for the working qubino the child devices also that one is not working as it should anymore. I have no ideea in writing device handlers , that is why im posting here, i think its an endpoint problem, but honestly i have no ideea in how to change it.

So if there is somebody willing to help me with this i would verry much appreciate it.

thank you