Qubino Flush 1D Relay

I have been using this since 2019 with no problem. It ran originally with a DTH driver but was converted automatically to an Edge driver. I recently removed the device (by accident) and now when I add the device again the temperature is missing. I’ve tried the mariano driver as well as the ST(beta) driver but they both give the same result. I’ve changed the probe but that didn’t make any difference. Do I need to reconfigure something? As a secondary question - how to a get access to I2?

Looking at the stock driver code, it should work. When connecting the temperature probe and receiving a temperature value greater than -20ºC, the temperature information is activated and it changes to a profile with temperature capability.

To see the new profile in the App you may have to close it, clear the cache if it is Android and reopen the app.

According to the manual, for the temperature probe to work you have to mount it with the device excluded from the zwave network. Once mounted you have to pair the device with the hub again.

If it doesn’t work you should open a report to smartthings so they can try to fix it.

Thanks for the reply Mariano. I did include the device (several times!) with the probe connected but to no avail. I did try Qubino and they pointed me to a yml file on GitHub but I have no idea what to do with it. I am aware that they aren’t very helpful when it comes to drivers though. I’ll try Smarthings.
Are you aware also of anybody who has successfully added access to the I2 sensor connection on this device?

In App can you see temperature capability?

No - just the switch.
I did try SmartThings but their (probably automated) reply was just to carry out lots of fairly pointless tests and I don’t have the time right now