Push notifications not working for me all of a sudden

I seem to have stopped getting any push notifications since Wednesday on my Android phone (and my wife’s as well).

Normally when we arm/disarm, or if a sensor is set off while armed, we get push notifications.

Since Wednesday afternoon, we haven’t received any. I know it’s still Armed, because the status is still shown as AWAY or HOME, and our speaker alarm still goes off when something is triggered while AWAY. We just don’t get any push notifications that something is happening.

I have tried rebooting the hub and my phone with no luck.

Looking in the app itself for the Notification history, it’s been blank since Wednesday afternoon as well.

Does anyone else have this issue??

I guess I didn’t clarify. This is the normal push notifications that ST pushes. Like when you normally ARM/DISARM… you’d get a push notification from ST saying it’s Armed or Disarmed.

I don’t even see it in the Notifications history in the ST App itself.

The last time any default app Notifications came through:
https://i.imgur.com/PV6Kxvm.jpg

Interestingly enough. I shut off the hub. I uninstalled the apps on both our phones. Rebooted both our phones. Turned the hub back on. Re-installed the apps on our phones… and now it’s working!

Whew.

i’m about 99% sure the notifications slider in my app turned itself off a couple weeks ago. Drove me mad for a couple days until i went into settings and saw notifications were turned off for my location.

I just noticed this too. No push notifications from STHM. It could be related to latest version of this app.

No message that STHM is Disarmed.

My old tablet with 1.7.47-22 it’s working fine.
Latest App on Android is not. I have rebooted hub and reinstalled app, and it’s still the same.
Maybe it’s by design or it’s a bug.