Push Notification is not working for SHM

I can see the alarms when I have the app open on my Samsung phone, but no messages are sent.
I went true all possible section of the app, and there is nothing else I see that can be switched on so I get notification, this really sucks.

Does anybody have an idea what else need to be done before I return this product ?

I did search and most topics show a different app then what I have.

Thanks for any input.

why not try the classic/old app?

Wow, that worked. Thanks !

I just uninstalled the app that came with the phone :wink:

I have the new mobile app on an iPhone 7 and the prior gen mobile app on an iPad. The iPad gets the push notifications and the iPhone with the new Smartthings app does not get the notifications. Under Notifications on the phone and tablet the switch settings are the same. I’m using the same Smartthings account for both.
In the new app settings, (under the 3 bar menu / gear / settings) notifications are set to blue (assume that means “on”.)
All devices are in one room.
No scenes are defined.
Only one location is defined
only one v3 hub at firmware 000.024.00022
Only one user
I’ve rebooted the hub
I have a virtual switch and an an automation to notify me whenever the switch is turned off so I can trigger a notification at any time.

One odd thing, in the developer API (graph.api.smartthings.com) under my one location when I select “notifications” the list is blank. There’s a link that says “more” but clicking it does nothing. Same thing under Firefox and Opera (which is Chrome.) I can see events for that location and for the devices including the virtual switch.

I reported this through the prior version of the Smartthings app (can’t find the help problem reporting option in the new one either.) Would be useful if anyone else using the new app would report the problem if they can find a way. Can’t recommend upgrading to the new app right now. No notifications - what’s the point?

There are two versions of SHM. Depending on which app you install them from will determine which version you get. Notifications in the new app do appear to be limited, but push notifications should work. Reach out to support if they are not. There is another thread discussing this same issue I believe the fix was to simply remove and reinstall the new app.

1 Like

Mavrrick58, awesome, removing and adding the app on the iPhone worked, notifications working now. I have a haunted garage door opener (think it’s the neighbor’s amplified CB or 10m radio,) that randomly opens by itself. I suppose I could get it replaced but with home automation & remote control why bother, it still opens and closes with the remotes. =:-/ Also a bunch of water sensors & an automated valve (at least that should work by itself,) and the usual door switches & motion detectors.

Thanks a bunch.

This is still not working on the new Smartthings app. Anyone still with the same problem ? Notifications are not sent when using with the Automation.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.