Push Notifications for Schlage Lock Not Working (April 2019)

Thanks for staying on top of this Kianoosh. Currently I believe there are two devices affected, the Schlage BE369, FE599 which use a different group for controller associations.

1 Like

The Yale T1L and YRD120 are the same device. There’s also a Yale B1L (YRD110). That device should process Association Set with S0 encapsulation.


The Schlage FE369 is affected as well.

Never heard of a FE369. Are you referring to a BE369? PM me the device MSR and I can confirm the model number.

RBoy, thank you. You are correct, my lock is the BE369NXCAM. I had pulled the number from the ST app since I didn’t have my paperwork handy. I noticed that in Post 46 on this thread the app also identified his lock as FE369.

My experience has been identical to what is described above. ST support has been challenging - 8 tickets and counting since July of 2019. Screenshots, logs, details of exact times door was opened with no notification were all submitted numerous times. This was never identified as a “known issue”. Instead I had to keep doing all of the resets, resyncs, reboots that ST said was the problem (even bad internet). I was specifically told by ST to uninstall my Rboy app as the issue (it had always worked fine) or they couldn’t help me troubleshoot.

The end of March I collected all my emails and documentation and submitted it all to Samsung’s “Office of the President” : http://contactus.samsung.com/customer/contactus/formmail/mail/MailQuestionGeneralNew.jsp?PROD_ID=G303850&siteId=591

I got this lock (and hub) for the specific functionality of knowing when and who opens the door and whether it is locked. With no ETA for a fix, I requested a refund (not a product exchange - another delay tactic). Even though I was told by support supervisors that my request was “not possible” after sending that email I did receive a check for the full amount of the hub. In the Covid interim, it’s not a fix but at least I am not doubling up my costs as I look for an alternative. Any suggestions for another system that can get me back to using your App and “seeing” my door again?

You can request support for the workaround (they did respond to my request and after a few modifications to their script I can confirm that it’s working now) or wait until 0.31.x firmware is released. Otherwise try another lock like the YRL216, YRL256 or Kwikset lock. If you need a deadbolt see the BE469, YRD216, YRD256 or Kwikset. There are others also like Samsung, IDLock, KeyWe, Philia etc which are also excellent locks depending on your region. You can see this topic’s first post for a comparison table.

So SmartThings support finally has the script required to fix the notifications until the firmware patch is released. This affects BE369 and FE599 locks.
If you’ve had trouble getting a response from support in the past, you may want to try reaching out to them again (support@smartthings.com) as this workaround was updated today after I made some recommendations. Here is their response:

I did show the whole team here what changes to make to the existing script so that it does what is required for these specific Schlage locks. If you encounter this in the future and send us the Hub ID and the Node ID(s), we can take care of them as soon as possible until the more permanent fix is available in a later Hub Firmware version.

Thanks again for all your time today. Your quick responses and ability to test made a difference, as I was able to send this to other similar cases we have been investigating for awhile with relatively high confidence it will finally resolve their troubles.

Hey RBoy, I contacted them however they gave me this generic response. I did mention reference ticket number 937206. I have just reply to them asking them to refer to these forum post. I include my hub id in my reply. however i don’t know how to find the node id can you enlighten me? is it the network device id?

Sathyendra Nath (SmartThings)

Apr 29, 12:58 PM MST

Hello Rubin,

Thank you for contacting Samsung SmartThings Support.

I apologize for the inconvenience caused to you.

In order to resolve your issue, I request you to please remove and readd the locks to SmartThings application and check the status of the notifications.

After that please make sure that you turn on the notifications option. To do so follow the steps provided below:

  1. Open Settings
  2. Select Apps
  3. Scroll to SmartThings
  4. Then click on Notifications
  5. After clicking on Notifications toggle the ON option. below you are able to see SmartThings notifications should be ON and General notifications should be ON and also App icon badges ON

Once you follow the above troubleshooting steps and check the status.

About Notifications:

The Notifications feed in the SmartThings app shows the push notifications of your Location for the last 7 days.

To view notifications:

  1. From the Home screen, select Menu (Menu icon) and touch History
  2. See the Notifications tab

If you want to know about Activity and Filter Device History Please Click here.

If still, the issue persists please write to us with the below details. So that we will investigate further.

  • What is the status of the locks showing in your SmartThings application send the screenshot
  • Your SmartThings application version
  • Your mobile device OS version and complete model number
  • Logs

To send logs please follow the below steps:

  • Go to SmartThings App
  • Tap the Menu button (3 bars)
  • Tap the (Gear icon)
  • Scroll to the bottom and look for the option “Help” Tap on that option
  • Tap “Report a problem”(Mention this “945157” number)

Thank you for choosing Samsung.

Samsung SmartThings Support

I contacted them as well with a subject line " FE599 Schlage lock notification fix". I provided the Hub ID and the Node ID. Got a similar reply, with less detail. They are acting clueless or perhaps not acting… :frowning:

It looks like there is a disconnect between regional support teams. Thanks to @Brad_ST for looking into it. Hopefully it will be sorted out soon.

1 Like

Mohammad Saad (SmartThings)

Apr 30, 3:00 PM MST

Hi Tom,

We are writing back in regards to your concern with notifications of Schlage lock.

Upon checking we see that you are still using custom device handler for your locks.

In order to provide further support, you will need to delete these customer handlers and then Exclude and re-join these locks using the standard lock handler.

Once the locks are rejoined, then only we will able to look deeper into the issue on whether the issue is with the lock or the Hub.

Kindly perform the requested steps and get back to us,

Mohammed Saad
Samsung SmartThings Support.

Received this today from engineering, if you get a canned response from support ask them to check for update to recent guidelines for this issue and escalate it to Tier-2:

As an update to what I sent earlier, I’ve now worked with a few people internally to send information to have our Tier 1 representatives get trained to spot and then escalate cases like this more directly. This should greatly reduce time spent troubleshooting, get the cases to our Team quicker, and then fixed in a much shorter order.

This might take some time to disseminate, but hopefully it will continue to get smoother until ultimately a change in Hub Firmware helps resolve this permanently.

Let me know if you have any questions or concerns about this. Thanks again for keeping in touch about this and I hope you have a great weekend.

@RBoy Can you tell me what is the Node_ID and how to find it just in case they do contact me with someone who can run the script. Hub ID is straight forward. But I don’t see the Node_ID on the IDE site.

It’s the device network ID of the lock. Open the IDE, Click on My Devices, scroll through the list to find your lock. Look at the column which says Device network id

1 Like

This is not going anywhere with this support person… Is there no way to contact someone more directly that can fix this issue? @Kianoosh_Karami Can you help me directly?

Hey Rubin,

Thank you for writing us back.

I apologize for the delay in response.

I kindly request you to send the below details so that we can assist you accordingly.

  • Screenshot of the error
  • Phone model
  • Mobile OS version *SmartThings App version ( Classic/ New)

Awaiting your response.

Kind regards,
Samsung SmartThings Support

@RBoy THANK YOU SO MUCH!!! I can not express how happy I am right now. I am literally shaking in happiness. This issue has bugged me for a better part of a year. It was 1 year ago around this time that it stopped working. I am sorry for any mean thing i might have said to you after trying your other methods(repeater). It is working flawlessly right now. You have made the lock the crown jewel of all smartlocks again(for childcare setting since you can’t have a deadbolt). Also thanks to Sathyendra Nath at Smartthings support. I know I had not been very patient with you and i am sorry. You at long last pulled through for me. THANK YOU ALL!!


Hey all,
So today I got notification that they had applied the fix to my other lock (they fixed one of them two days ago). I can now say that both my locks are sending notifications now. Super excited to have this fixed finally.

Is this a patch for the Hub or for the lock. How would I apply a patch for the lock?

It’s a script that only ST support can run from their side that will send some commands to your lock which will re-enable lock → hub communications that were causing your lock to not send the notifications to your hub. This script cannot be run by you due to a bug in the hub firmware and can only be run by ST support manually (until the new hub firmware 0.31.x is released, after which it be automatically run when the lock pairs itself with the hub)

In the classic app, I am able to manage the lock just fine. status and create/delete codes. In the new app, I get status of the lock but I am not able to see or create/delete codes. Is this part of the problem that you are describing above? Thx. Just trying to get my head wrapped around the issue.