Notification not coming (March 2019)

I’m new to ST and have 2 locations and hubs, i am not receiving any push notifications from either hub when set to away and intrusion occurs, any help with where to look would be appreciated i’m A former iris user

Check if you’ve enabled push notification in SHM and if you ST app has push notifications enabled on your phone.

Are you using the latest Smartthings app and an iPhone? Ever since I upgraded to the latest mobile app I’ve stopped receiving push notifications. If you are able to revert to the prior mobile app (which had a problem notification mechanism under help, something else that seems to have been dropped from the most recent app,) you can report the problem.
Here’s what I’ve posted in other threads. So far no solution.

Common Smartthings/Samsung - get it fixed.

I have the new mobile app on an iPhone 7 and the prior gen mobile app on an iPad. The iPad gets the push notifications and the iPhone with the new Smartthings app does not get the notifications. Under Notifications on the phone and tablet the switch settings are the same. I’m using the same Smartthings account for both.
In the new app settings, (under the 3 bar menu / gear / settings) notifications are set to blue (assume that means “on”.)
All devices are in one room.
No scenes are defined.
Only one location is defined
only one v3 hub at firmware 000.024.00022
Only one user
I’ve rebooted the hub
I have a virtual switch and an an automation to notify me whenever the switch is turned off so I can trigger a notification at any time.

One odd thing, in the developer API ( under my one location when I select “notifications” the list is blank. There’s a link that says “more” but clicking it does nothing. Same thing under Firefox and Opera (which is Chrome.) I can see events for that location and for the devices including the virtual switch.

I’m new here What is SHM , I’m using ver 1.6.28-225 on iPhone X iOS 12.2 in app notification is blue

If you aren’t using SHM (Smart Home Monitor), then ignore that. Check the other points. Would be helpful to have more details about what you’re trying to do and your setup.

I have the same problem - SmartThings App Notifications not being received any more on iOS App 1.6.33-268 - I think they stopped working around 2+ weeks ago?

Ive raised the issue through Samsung SmartThings support and will see what they say…

Ever hear back from Samsung, I also have the same problem.

Same issue here. No notifications in the new app.

Same issue here. Frustrating. Especially for people who use this for security purposes.

I’m having the exact same issue with my iPhone XR

I had the same issue. I removed the ST app and reinstalled and it started working again.

Yep, I tried everything, finally removed the app and reinstalled it. I’m not sure that it was working immediately after restarting, but turning notifications off and on again inside the app definitely made it appear under “Notifications”. (This is iPhone with latest software.) Thanks for suggesting this! :slight_smile:

That worked for me too. As a note to others, this will retain all your home config, devices, automations etc. As soon as the app was reinstalled and the config downloaded from the cloud I started getting notifications again