Problems with Neo Coolcam Zwave Sensor reports

Thank you although it does not work for 0258-0003-0083 like DTH did, where changes in ambient light were shown immediately in illuminance on device weboage.
When I tried change settings, there is some message about device associations and that i have to delete device afterwards, In DTH I was able make changes.

@JDRoberts
Still DTH was more intuitive, I did not have to read any FAQ as I recall, I just logged in to ide.smartthings.com

@csstup might be able to add support to his Z-Wave Sensor CS driver. I found this documentation for the device that documents which command classes and configuration settings are supported.

2 Likes

well settings do not work, create device config association leads to some garbled text <table style = font-size bla blah
no way to read fingerprint, change parameter

What is the actual model number from the device itself? There appear to be several versions of this sensor under different brands and models - they all may have different firmware. NAS-PD01 and NAS-PD02 both seem to be similar, but not exactly the same unit. NAS-PD01 appears to be motion only. NAS-PD02 seems to support motion and lux. The Coolcam version NAS-PD02Z-Temp seems to be motion, lux and temp. However, the NAS-PD02 flavours do not appear to be official versions as they aren’t filed with the Zwave Alliance.

This document doesn’t match the device exactly. It doesn’t mention temperature at all, while the device as described from Neo Coolcam site says that it does. Theres also this: NAS-PD02Z Motion Sensor(PIR) User Manual NAS-PD02Z_ SHENZHEN NEO ELECTRONICS

Lastly, if the device doesn’t appear to report motion with one of the existing default drivers, it may be sending a non standard message that the default framework handlers aren’t designed to handle. At this point they are pretty good at handling 500 series and later messages although there have been some oddities (monoprice devices for instance). Without having the device here for development, it may not be worth the time needed to add support for it.

You can try Zwave Sensor CS. It won’t have a specific profile for that device (so it will show attributes for motion, temp, humidity, tamper, etc) but it at least has default handlers for those data points. If it still doesn’t report motion then its likely custom logic would need to be written to support it.

Edit:
Also also, @Mariano_Colmenarejo already went around and around with this device, and another one labeled NAS-PD02ZT. Z-wave Motion sensor NEO Coolam I’m going to guess these issues have already been solved via his driver set.

3 Likes

no model number, only fingerprint:

i tried also wink motion sensor WNK-MOT1P as someone in other thread and got similar garbled text in settings

either i did sth wrong but what?

both sensors use “z-wave sensor and child thermostat mc”
both fingerprints are listed in fingerprints.yml on Mariano’s github.

both report motion correctly, both do NOT report illuminanace correctly,
when i power cycle sensor illuminanace readings initially react to ambient light changes (tried test with flashlight) then illuminance gets stuck at 0% and no reaction to flashlight

Is there no model number on a physical sticker on the back of the unit? Any identifying information on the unit itself?

This sounds like it reports this data using some non standard method. Without a device in hand to develop with I won’t be of much other help. My suggestion is to purchase newer generation (700/800 series) sensors from a vendor that is supported on ST.

1 Like

Does not sound right to replace as both fingerprints are in database and others do not report errors. Everything worked perfectly with DTH from forum.
Neo does not print model number, Wink prints on battery cover
Same issue on two different brands: Neo coolcam 0258-0003-0083 and Wink WNK-MOT1P yet other people do not complain.

Errors I get:



You can thank the ST dev team for those errors. There are a few posts about it, starting at the source:

Also, see here:

[edit: removed] :crazy_face:

2 Likes

The HTML display issue is one problem, but I believe the OP is primarily concerned about not getting all the sensor values:

I would note that it is very common for inexpensive batterypowered lux sensors to only sample the light value once every 15 minutes or so, so you generally can’t test them just by using a flashlight and briefly altering the light level. You have to turn on an overhead light and then wait for the next reporting period or put them in a dark closet and again wait for a while. They aren’t intended for instant response because that would use up too much battery life.

1 Like

Oops, my bad! That’s what I get for rushing through the thread. I saw the screenshot and jumped to a partially-correct conclusion.

3 Likes

The defaults listed on the spec PDFs attached above set the lux reporting frequency parameter at 180 seconds, and the delta at 100lux. I would figure the neo coolcam model implementation to be similar.

Hopefully @samsungproblems tested outside of that range, I would assume they did.

The html issue on the Mc drivers would need to be addressed by @Mariano_Colmenarejo and doesn’t have anything to do with the lux reporting issue.

3 Likes

how would i test if i cant get to settings because of html errors.
please enlighten

and how come others do not have html errors?

eventually i googled others with same problems:

same happens with wink (illuminance or temperature does not matter LOL pun intended) so please JDRoberts tell me how much you want me to spend illuminanace sensor that works like Kevin’s DTH worked with cheap one (aka for worse of us i presume you meant), which one?

So thank you Mariano for your kindness and genorosity but it is not sensor that gives problems.

Why everybody gets likes for not helping me?
Is this some bot?
Gee what a mess, I feel like talking to kids

If you are using Mariano’s Z-Wave Device Config Mc to try and change the settings, it will not work because of the ST HTML issues.

@JDRoberts @csstup and I have all suggested you try Mariano’s Z-Wave Sensor Mc driver for your sensor. It has the fingerprint for your device which identifies it as a sensor with motion and illuminance sensors and is battery powered.

 - id: "NEOCoolcam/0083"
    deviceLabel: NEO Coolcam Motion/Light Sensor
    manufacturerId: 0x0258
    productType: 0x0003
    productId: 0x0083
    deviceProfileName: motion-battery-illuminance

That profile also appears to allow for changing the illuminance value:

name: motion-battery-illuminance
components:
- id: main
  capabilities:
  - id: motionSensor
    version: 1
  - id: battery
    version: 1
  - id: illuminanceMeasurement
    version: 1
    config:
      values:
        - key: "illuminance.value"
          range: [0, 32000]
  - id: refresh
    version: 1
  categories:
  - name: MotionSensor

It’s not clear to me that you have tried that driver from your previous posts. If you have and it’s not working, then we will need some additional info about what specifically is not working and will probably want driver logging from your hub to help diagnose any issue.

I can assure you that the individuals that have been attempting to help you are not kids or bots and are some of the most skilled ST users and developers. The people “liking” their posts are confirming that the advice supplied can point you in the right direction. You continue to refer to the old architecture and whining about the new architecture. Follow the directions that these individuals are providing and post any requested data that might be needed to figure out how to get your device working correctly. Frankly, if you continue your combative tone, I expect everyone will simply ignore your future posts.

3 Likes

I’m already getting there.

A few things.

  1. To test lux/temperature, you shouldn’t need access to any settings (I assume you mean zwave parameter settings). The defaults set when paired should work well enough to test (no changes are required to report lux, for instance.)
  2. Other drivers that will at least do something with your device won’t have HTML errors in the presentation. Zwave Switch CS does not use any components with HTML in it. Now it doesn’t have the specific device fingerprint if your sensor, but it should support it generically (by category). And yes it will have extra capabilities displayed that your device doesn’t have, but its a data point to compare against.

The “feel like i’m talking to kids” comment is not appreciated. We’re just enthusiasts trying to help with zero visibility into your specific setup. I didn’t sell you oddball devices that aren’t “Made for SmartThings” certified. Perhaps switching home automation platforms might be a good option. Hubitat has the NAS-PD01 listed as supported although it doesn’t mention a NAS-PD02.

4 Likes

no such, there is Z-Wave Sensor and Child Thermostat Mc which I tried but cant get to settings, so I guess can say: does not work almost exactly as Samsung’s built-in Z-Wave Sensor does not.

Mariano wrote me to use some api+ browser, which brought me even more headaches.
I will go take some rest.
Thank you anyway

changes are required.
with defaults it works only for a while, i placed earlier 2 quotes from other person who confirmed problem, so you did not read.

so there should be two more drivers , one which changes defaults so illuminance is reported every 10 seconds (parameter 7) and another to turn off led - parameter 10

Cool. Good luck with your issue.

2 Likes

Thank you and likewise

Ok, I’m throwing you a bone here and have added the fingerprint you posted earlier for your device into a version of the stock driver. I’ve mapped it to the profile motion-battery-illuminance-temperature-interval which supports a device with motion, illuminance, and temperature sensors as well as setting the reporting interval as well as reporting battery level. It does not provide you the ability to set all the other various parameters that the device supports. Someone would have to do the development to make that happen (like the original author of the custom DTH did). See if it at least provides you the basic functions that the sensor provides.

You can subscribe to my test channel here where you will find the modified version of the Z-Wave Sensor. Please provide constructive feedback on what is working/not working and we can proceed from there. If the basic functionality seems to be working, I might have time to see about adding some of the configuration parameters.

2 Likes