Problems connecting from IFTTT (February 2017)

Different smartthings accounts are on different “shards.” ( you can think of those as database servers.)

The “graph.” Shard Was the original. Then when they added UK accounts, there was a UK Shard. Towards the end of 2015, the original North American shard became overcrowded, and they added a second North American shard, NA02. There was also a beta Asian shard at one point. So different customers are on different shards.

When they first introduced the UK hub in the fall of 2015, it didn’t work with IFTTT because the connection URL was incorrect. But they eventually fixed that, and, as mentioned, added an additional North American shard, and all three worked fine with IFTTT throughout 2016.

The current problem that people are seeing is something new. But it sounds like it isn’t affecting everyone, which is why engineering would like anyone who does have the problem to report it to support so they can see if they can isolate the issue.

1 Like

Same here.

9 days now since this was first reported…I wonder if they’re close to a fix yet. IFTTT integration is one of the things that lead me to go with ST. Pity it’s still not fixed.

Her Aaron, any chance for an update on this?

I just bought SmartThings this weekend for use with IFTTT and I still can’t connect them. I’ve already contacted support with my information at the link you gave

Just got off the phone with ST “Support” with this same problem. First call I was told everything connects fine and that they do not assist with anything more than that. I tried to explain that although it should up in ST Smart Apps, that it was not working. I read this thread and see a Smartthings Staff member telling me I should call customer support so that they know about it. Kind of confusing. So I called a second time. Next CSR tells me they have problems all the time and that they are not fully integrated with IFTTT. So some things may work and others may not.

I am just getting started into home automation and first had a wink hub which wouldn’t allow me to control my locks through alexa, so I switched to the ST which should have allowed this to happen with IFTTT. Now I’m told that Maybe it will…Maybe it won’t.

Maybe its time to find another Hub.

Add me to the list… basically switched from Vera for the reason of IFTTT integration. Between this not working and the nightmare that alarm integration is on this platform (took 5 mins on Vera) I’m about ready to put it back in the box.

I also cannot connect my hub to ifttt. Exact same issue.

Same… I hope they fix it soon… Just purchased this hub today solely to take advantage of IFTTT. Disappointing indeed.

I’m new here, just bought my ST hub a few days ago. I’ve yet to get it to work with IFTTT and like so many others am frustrated. The problem I’m having is identical to the one others are having with authentication. I’m trying to control my Kwikset 916 through Alexa.

Hoping for a resolution soon! About to take everything back to the store and forget about ST.

Just put in request over at IFTTT to look into it as well… Maybe they already know, but I figured it wouldn’t hurt to submit a ticket. Did it online, got the typical automated response.

Hello,
I am also having same issue with connecting and using ifttt with smartthings. interesting thing is that when i check in smartthings webpage under installed smartapps IFTTT shows up. i dont know if its the same for the rest of you guys or not.

Yup Same… Made me think for a second that error is with IFTTT

adding to the list. already contacted support through their webform. broken on the webpages as well as the latest ios app for ifttt. https://imgur.com/a/qDraX

Just received my Smartthings hub last weekend, come to find out IFTTT is broken for now. I made an account here just to post in this thread. Not a good time to switch over to a Smarthtings controlled house, I guess. I’m glad I’m still in the window to return the hub to Amazon, if it is not corrected by then I will need to do so. I hope they get this fixed soon as I am eager to unlock the full potential of the hub.

1 Like

Ya, same exact situation here…

All I’ve been able to get out of smarttings is “We have added you to the list of customers seeing this.”

I just bought the “hub” (the home monitoring kit) and I am having the same issue.

I’ll give it a few more days before I return all of it. It is of no use to me without this ability.

This has been an issue since at least August 2016. See this post: IFTTT Devices not showing up

I also have this issue. I have been retrying periodically for a week or two. A colleague of mine set it up about 3 weeks ago and it worked. So it looks like its either new/resurfaced recently or there are some factors we are unaware of that causes only certain users to have the issue.

It hasn’t been a continuous issue for that length of time. It was working fine for all three shards in November, December, and January.

Beginning in February, people Setting up the integration for the first time started reporting having this problem.

http://thingsthataresmart.wiki/index.php?title=Bug:_First_Reports

I know it’s very frustrating. SmartThings makes platform changes all the time, and you never know what’s going to work and what’s going to break. :disappointed_relieved:

Here’s an update from my end… Tried it today after continuously trying for about 4 days and it worked! Make sure you guys report.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.