IFTTT couldn't connect to Smartthings

ifttt

#1

I just switched to ST from years of being a Wink person. I was hoping to take advantage of the open platform being a software developer myself. My excitement rapidly faded when I was unable to integrate my ST hub with IFTT (deal breaker for me if it doesn’t work).
I tried from the IFTT app, the IFTT browser version, nothing works.
As soon as you try to “add” the ST service to IFTTT, it pulls the ST auth page. I login successfully, select my hub, my devices then click Authorize.
I get then redirected back to the IFTTT app, that still displays the “Connect” button.
Same behavior with the desktop IFTTT web site. The only difference is that when you get redirected back to the IFTTT website, you get an error that reads “Could not connect to Smartthings”.
In the ST app, when you go to to Automation"-> “SmartApps”, you can see IFTTT with the proper access you selected earlier from the devices drop down when you connect IFTTT to ST.
Any ideas?


#2

This is a bug that turned up just a few days ago. :disappointed_relieved: There are a couple of existing discussion threads on it.

It’s also listed in the first bug reports in the community – created wiki. That’s a good place to check if you encounter a problem that’s not listed on the official status page.

http://thingsthataresmart.wiki/index.php?title=Bug:_First_Reports


#3

Thanks! Yes I found out many other people are experiencing the same issue. IFTTT is a real pillar of any decent home automation solution. It’s a real bummer. It takes away all the excitement to contribute to the community and build some apps. Hopefully they’ll fix the bug soon. I’m keeping the ST hub packaging just in case I get fed up and decide to return it.


#4

I understand. Having the IFTTT channel/service has always been a big plus for SmartThings, so I’m sure it’s very frustrating not to have it working. :scream:

The problem still isn’t listed on the official status page, so definitely report it to support if you haven’t already. That’s how they track trending problems, support doesn’t read the forums.

http://status.smartthings.com

https://support.smartthings.com/hc/en-us


#5

I did report it Friday evening. I don’t know if they work during the weekend, but I’ll try the live chat tomorrow. Thank you for your help! I started coding some apps. Already got my gate opener and garage door to work on ST so I can open it and close it from the iphone widget. Next I’m going to add a sensor to find out the state of the gate at any particular time, then I’ll setup some notifications to send me emails or texts when the gate has been open for more than 10 minutes. The end goal is to have IFTTT notify my ST hub when I get close to home so that it can open the gate, turn on the lights, open the garage, and when my automatic detects that I turned off the engine, it will notify IFTTT to turn off the lights and close the gate. Hopefully the IFTTT channel will get fixed because otherwise none of this could happen!


#6

You might need IFTTT for the automatic integration, but other than that you should be able to do everything without it.

Since you have a technical background, I would definitely take a look at Core. It’s sort of like a scripting language for SmartThings. I think you’ll find that it saves you from having to write a lot of individual Smartapps from scratch. :sunglasses:


(Brian Diehl) #7

There is an Automatic integration for ST, but it does cost a (small, reasonable) fee.

I just bought an Automatic Pro this week and integrated it.
If you set up the RT (Real Time) events for it, you can have the vehicle added as a presence sensor. This means you could then setup automations based on it being present and the engine being turned off (I have not tried this yet, but it should work).


(Wesley Ls) #8

super upsetting!!! IFTTT should work with no problems. seems like problem is the different versions of the hub 1 and hub 2. fix this problem!!!


#9

Definitely upsetting, but why do you think it’s a hub version issue? Both versions have been working fine with IFTTT up until about a week ago.


(Wesley Ls) #10

hey dave, I don’t know much but when I’m sent to smartthings from ifttt it sends me to https://graph.api.smartthings.com/login/auth. where i have no devices. it should be sending me i think to https://graph-na02-useast1.api.smartthings.com/login/auth where all my stuff are at. for hub 2. I just felt like that had something to do with it. however i just got my hub and was unaware that it was working a few weeks back.


(Yves Racine) #11

Hi @diehllane, I’ve tried to send you the latest version of MyAutomatic device (v2.4.4) but it seems that the email address I have on file (msn) is not working. Could you email me
at services@maisonsecomatiq.com?

Regards.


#12

It just setup my new hub and I am having the same problem with IFTTT. As far as I can tell it is just happening with IFTTT because I connected my hub to Stringify and it works there. It looks like this problem is known back in January and is still not fixed. What are they doing over there. I would not have purchased this hub and sensors if I knew these bugs were still here. Looks like I may return them in the next day or so if this is not fixed.


#13

Thanks for the info. I tried this and got the same results. Someone at Smartthings need to know this because this seems like an easy fix and should not take two months to fix. Stringify is pointing to the correct URL.


(Patrick McNeil) #14

It may be an issue on IFTTT’s side, because if I check the “Live Logging” section of the SmartThings API console online while connecting the two, it shows IFTTT’s request to connect and it looks like Smartthings authorizes it successfully. It also shows some of my devices “in use by” IFTTT, so they look authorized properly on the Smartthings end… Just collecting more clues here.


#15

I talked to their tech support today and they acknowledged the bug. They stated that somebody was working on a fix, and they think they know what’s going on, but they do not have an estimated ETA. They will get back to me once it’s resolved, and I’ll update this feed. It’s very annoying indeed.


(Jimi) #16

Just to update here, I contacted support about this issue today and they told me the same exact thing. They stated it is high priority but they have no ETA on a fix. I just installed my hub last weekend so I have yet to see what is possible with IFTTT, I really hope they get this fixed while I am in the window for a refund.


#17

Update: I just successfully connected my ST hub to IFTTT. Hopefully they fixed it for good.


(Jimi) #18

Indeed, I was able to connect just now. Thank you for reporting back to this thread and thank you to the devs for getting this fixed. I am excited to see what is possible now with my brand new hub. :slight_smile: