Problems (again) with 'Things quiet down' routine?


(Stephen Hill) #1

Anyone else having problems with the ‘Things quiet down’ routine?

I have a routine which powers on a light when I get up in the middle of the night, thanks to my motion sensor, then when there is no movement for 10 minutes it powers itself off.

The first routine fires perfectly but the second routine just leaves the light on. I’m sure it’s worked in the past so what’s changed?

Edit: Its worth saying that when I run the routine manually by pressing the routine with the app that the light goes out.


(Stephen Hill) #2

Found out that it seems to be because I have the delay set to 10 minutes. Reduce that to 8 minutes and it magically works.

Another funny issue with SmartThings!


(Vishal Chaturvedi) #3

I have the similar issue but other han 0 minute delay nothing else seems to work. Really bothersome


(Chris Hanson) #4

I found the bug and contacted support with it.

This set of parameters works:
Start time: 3:00 AM
End time: 2:55 AM
Delay: 5 minutes

This set of parameters fails:
Start time: 3:00 AM
End time: 2:55 AM
Delay: 6 minutes

I’ve tried other combinations and the pattern seems clear: if the End Time + Delay is greater than the Start Time the routine fails with this log message:

debug The current time of day (Fri Aug 26 18:40:34 UTC 2016), is not in the correct time window (Fri Aug 26 09:54:00 UTC 2016): doing nothing

This explains why the 0 minute delay always works.

This doesn’t fix the problem, but it gives us a work-around. It also gives support a good clue for finding the bug.


(David Steele) #5

This solved my problem.


(John Walker) #6

This fixes it for me as well cheers. Or lets me work around it at least.

Thanks