Turning light on with motion - problem with delayed off


(Alec Howson) #1

Hi All

I’ve tried using the Bright When Dark… and Smart Lights apps to turn an outlet for a light on and off with movement. All very straightforward and effective

However as soon as I add a value to the delay turn of with no movement the light just stays on

what am I doing wrong?

thanks

Alec


(Alec Howson) #2

here are the settings


(Bruce) #3

That’s odd. Try removing (uninstall) that automation and re-doing it. See if that fixes it.


(Alec Howson) #4

Hi Bruce

I’d tried that before but did as you suggested and removed the automation then reinstated

still the same problem. changed the value back to 0 and turns off fine

The motion senor is also linked to my SHM security. Could this cause conflicts


(Joe Jones) #5

Exact same issue here. Automatic off after 0 works fine. As soon as you enter a value above 0 (which is no good unless you’re having a dance party!) it no longer works.

Clash with SHM is not the issue - I’ve tried removing the motion detector from that setup.


(Alec Howson) #6

has anyone got this working in the UK? maybe the unit of time is set to hours in the code, not mins

I just have a starter kit with no prior experience. excuse newbie problems

thanks

Alec


(Joe Jones) #7

I don’t think it’s newbie problems - there is lots of functionality not working in V2.


(Steve) #8

Hi,

Similar issue I think.

I have the ST2 hub and the Motion sensor that came in the starter, I setup a routine so that when motion in the garage is detected the light comes on (Philips Lux light with Bridge) and this works really well, I then setup another routine for to turn it off after 10 min of inactivity, i activate the turning on and then leave the garage, after 10 min I see the light is still on, i look at the notifications and the 10 min inactivity is logged but the light does not go off. multple run throughs and it the same but if i press the routine it actions straight away and the light goes off, i can even see the status of the light in things so know its reachable.

Hope this is a simple bug!


(Alec Howson) #9

response from support. It’s a known issue, apparently awaiting implementation

Alec


(Alec Howson) #10

bug fixed. now working

the smartthings elves are doing their thing, even if they don’t tell us about it


(Joe Jones) #11

They would fix it the day my broadband decides to break wouldn’t they!


(Steve) #12

Tested last night and it still did not work, do we have to delete the routine and recreate?


(Alec Howson) #13

I’m not using a routine. try deleting your routine and use the ‘smart lighting’ app.

I have used this app twice.

1/ to turn on the dining room light with movement, then delayed off with no movement
2/ turn on the dining room light when the front door opens after 6.30pm. off after 5 mins


(Steve) #14

Ahhh, the penny drops! Weird how the routine to turn on works but the routine to turn off does not!

All sorted the smart app under one action now turns on the light and then turns it off after 10 min of no motion. I like the concept of routines, I could use them to manually trigger in only a few clicks rather than go to things and checking easily they still work which is not so easy in the smartapp. Well still working my way through what’s best and learning all the time.

Thanks Alec!