Possible bug in Routine with Lights triggered with motion

I think there are a couple of bugs in routines (or maybe I am doing something wrong). Here is the routine.

First, the second Precondition does not seem to have any effect. The event will happen irrespective of this precondition.

Second, when the event does trigger and the dining room light turns on, as long as motion turns off and on within the time out period (2 minutes), the light will stay on. However, if there is continuous motion detected, then the light will turn off 2 minutes after motion was last detected (going active), even though motion is continuous and is still active. It’s as if the timeout period is reset whenever motion is triggered, so if motion is continuous, then the timeout period is not reset and the light turns off. The expected behavior is that the light will turn off 2 minutes after no motion is detected. This worked fine in Smart Lighting.

I use two Routines…

One to turn on the light when motion is detected
Second to turn off when no motion is detected for 2 minutes

I am sure others have better methods

1 Like

@jkp, I do that too with some of my other routines. But I wanted to point it out for others to know and for Smartthings to fix it.

Then you will need 2 separate routines.

That seems odd. It is reasonable to expect both to be required. What happens if only the second precondition is true, or if you reverse the position of the preconditions?

It may be what you would like, but the Routine can’t possibly assume that. You have requested the light the turned off automatically after two minutes and that is what it does. I’m actually surprised that the timer is being reset by a new motion event.

Smart Lighting was written with the logic to handle common lighting and switching requirements and is simply prompting you for configuration information. When you tell it to turn the light off automatically when motion stops it is effectively creating a second stage of automation internally. With Routines you have to specify the logic explicitly and you need two, one for motion on and one for motion off.

I’ve noticed a similar thing running smart lighting. The light will not turn off after the specified time. When I walk back into the room - Smartthings will detect motion and turn the light off.

This has worked perfectly for several years and now suddenly it is turning the light off when there is motion.

If the light is off and I walk into the room the light turns on as expected. Since this has worked perfectly for years - I suspect a new bug has been introduced.

a fix should is getting released to resolve your issue and not related to this thread which is about Routines :slight_smile: