Problem with Z Wave Plus not updating status?

Yeah, unfortunately that particular article is both inaccurate and misleading. For one thing there were two patents involved, for another they only applied to dimmers, and for a third, the new switches they are talking about as now having “instant status” are actually using “central scene command” not the old instant status which was done with the hail Command set. So their availability doesn’t actually have anything to do with the patents one way or the other, but rather with the introduction of the new central scene command sets.

All of which is a lot of technical detail you’re probably not interested in. There’s been a lot of discussion in the forums about all of these issues, but the critical thing is that none of them have anything to do with the Leviton problems. Those are just problems that came in with the new model and they seem to have done something wrong. Which hopefully they will fix eventually.

You can read more about the new kinds of switches in the following thread:

You are correct, I really don’t care the about technical detail. All I want is a master switch NOT dimmer to update the hub in any means it chooses when the status is on or off. Only when that on or off action is performed from a slave.

According the, "ST compatibility list, I have this master (VRS15-1LZ):

Which is listed as ST compatible via the link in the thread you provided. I can assure you that in a 2-way situation it works just fine. In a 3-way or 4-way it surely does not.

Seeing the compatibility list is not accurate, or at a minimum should have an * that in a 3-way/4-way situation they are NOT compatible or won’t update the hub, where can I go for accurate information?

I know it’s very frustrating, I wish I had a good answer for you. The fact is, the devices should work differently than they are working. You should be able to press the auxiliary switch and get that status reported from the master. So it’s a Leviton issue. :rage:

As far as knowing whether a device does work to spec, about the only thing you can do is ask in the forums, being very specific about Brand and model, or try it yourself.

I suggest you start a new thread and title it “Any three way switches where using the auxiliary updates master status in the app?”

Then ask people to list the specific brand and models that they are using.

That way people can post current reports on switches that they are using and hopefully you can find one that you like.

So looking through the manual for the DZ15S, here are the supported classes:


From this information, is there something with the DH that could be causing this issue? I have to assume one of these classes could actually update the hub properly.

It’s not the command sets. Those are fine. That’s why this is so frustrating and why it looks so much like Leviton just broke something.

There is one other possibility that occurs to me, but it’s super technical and unfortunately I haven’t been feeling well I haven’t had time to research it. And why I wish Leviton support was involved. I think there may be a possibility that the state change is being reported in a different Association group than the smartthings hub expects because of some supertechnical changes that occurred with Zwave plus. But I’m not feeling up to researching this right now.

I’m going to tag couple of people who might be interested, but no guarantees that they’ll have time to look into it either.

The main point here is that some people who are buying the newest Leviton zwave plus wall switches and the newest GE zwave plus Wall switches are reporting either significant delays in status changes being updated in the smart things mobile app, or that the status never gets updated at all.

In your case, if you turn on the associated auxiliary switch, the master does turn on the lights, but the SmartThings mobile app does not update. (I’ve forgotten, have you reported it to support? Because that is an officially supported device, so they should look into it as well.)

Other people are reporting that the statuses do update, but can take several minutes to do so.

You could add some polling to solve both of these issues, but as a network engineer, I hate unnecessary polling, so I’m hoping there’s a different solution.

OK, here’s a link to a thread with an example of the GE switch problem. That won’t matter to you, but I’m just including it for research.

And another thread on the Leviton issue:

And now I’m going to tag some individuals. I don’t necessarily expect responses from all of them, but these are the people who may have heard something one way or the other. There have now been at least a half a dozen reports on this issue in the forums, so we know something is going on. :disappointed_relieved: (And again the Leviton model that you have is on the official compatibility list, but I don’t know if they actually tested it in a three-way set up.)

@Tyler @duncan @zcapr17 @TheSmartestHouse @mlebaugh @Nhaley

I do appreciate the effort and yes I logged a support ticket with Leviton (they are fully aware of the issue and said they are working on a firmware upgrade). When I asked how the firmware would be sent OTA to the switch, they said ST would handle that.

I also logged a support issue with ST and they say their hands are tied until the firmware is released. My gut says there is little to no chance that Leviton and ST groups will fully work together to resolve this, i.e. Leviton releases the firmware update and then ST actually pushes it out the switches. In my conversation I stated to STs that this switch in its current state is NOT ST compatible in 3 and 4-way configurations.

I do like your idea that those aux updates that go to the master are there, but maybe they are using a different class to send those messages that the hub doesn’t recognize.

As far as the polling, yes, it is a poor band aid for this, but I know it would work. When I turn the aux on or off and the, “master”, is out of sync, I can press the refresh on the ST app and it now reflects the correct status. Essentially a manual polling request.

1 Like

I just received an email from Leviton technical support indicating that this issue (as well as the issue where dimmer remotes in 3+ way applications keep the dimming indicator on all the time) has been resolved in a firmware update. I asked what the eta for distribution is and am waiting to hear back. I’ll share whatever I hear.

1 Like

I appreciate it. I actually called tech support again yesterday about the issue since I have seen posts as old as Feb this year stating there is an issue. Supposedly, the person gave my name and email address to the product owner. I doubt anything will come of it, but we will see. I firmly believe that this product should be taken off the ST compatibility list as it is NOT compatible in 3 or 4-way configurations.

I just installed Leviton 3 way Dimmer DZ6HD & matching 3 way remote DD00R. Both Switches work Correctly on / off & Dimming however In smart things it will say the Lights On when they are Not
Anyone know the Remedy to this ?

Any update on that firmware OTA push from Leviton support?
I just got a nice deal on a bunch of DZ6HD dimmers, went through the agony of installing 10 of them just to find that some don’t turn off completely (yea, that low load issue) and all do not report status to SmartThings so i can’t really tell what’s going on around the house, have to click “OFF” just to make sure they are.

Any pointers will help, i hate dealing with support and would really like to skip going through what you had…


I’m in the same boat, let us know if you find out anything please?

Mine actually straightened out, long as you have the Correct remote with the correct master & wired they’ll work.
Kill the power at the breaker for a few minutes & try.
Should fix it.
Or reprogram the Zwave exclude it then reinstall, you shouldn’t need to with leviton switches their pretty solid

It’s’ been radio silence from Leviton tech support, unfortunately, which has been really disappointing. I’ve tried all of the workarounds mentioned here, including cutting power off at the breaker, trying multiple exclusions, etc. All of my DZ6HD dimmers get out of synch, and those in 3+ way configs seem to get out of whack even sooner. Interestingly, the 1k watt versions seem to work fine, but I don’t have any of those in 3-way config.

1 Like

same exact problem here. I reached out multiple times to Leviton & Smartthings customer support.
They are “unable” to replicate the problem… It is frustrating when so many of us have them (I still have to meet one DZ6HD owner that does not have this issue)

Add me to this list of people having this issue. Any update on this?

Add me too. Have both Leviton switches and dimmers

I fixed it.

Go into device exclude through the hub zwave utilities. hold up on the switch for 7-8 seconds, tap once. It will exclude. Then hold up for 15 seconds or so on the switch to do a reset. Continue holding until the flashing red led on the switch goes away and starts flashing green. Then do a new device add (do not manually add a leviton switch, let it automatically add it as a zwave switch) and it should work.

As an aside, mine added as a zwave relay first. I went into and changed the device handler to zwave switch from zwave relay. Continues to work.

IUh are you sure you weren’t just mistakenly thinking your three way is now working?

I have two 4
way switches and they all have the same issue. I also experienced the same issue with HomeAssistant and had to enable polling.

I’m betting we can enable polling in a custom device handler, I’m using the community one but that’s a hack really. It’s as if the 3-way doesn’t trigger hail when the other switches trigger it.