SmartThings Community

Problem with v2 hub: can't add zigbee devices

(Chris C) #1

I’m helping a friend set up their new v2 hub. Having some interesting problems with it.
Zwave devices register and work fine, but the hub wont register any zigbee devices.
Have tried resetting the devices many times. The devices will pair fine to my v2 hub, but not to his.
Devices in question are smartthings water sensors.

Live logging shows the hub going into detect mode, but doesn’t show anything detected.

One thing I’ve noticed looking at the hubs side by side in the IDE, they both have the same firmware version, but mine shows zigbee version 2.7.9, and his shows 2.1.6. I also have a utilities tab for the hub, and he doesn’t.

Can a firmware update be botched? Is there a way to force a new firmware update?

Any suggestions/ideas?

0 Likes

Cannot add any zigbee devices
(jkp) #2

Check for interference…

  1. is the ST hub too close to the wireless router. Ensure it is at least 10 feet away from it
  2. what is the 2.4 network channel, what is the st hub zigbee channel? Make sure they are not overlapping.
0 Likes

(Chris C) #3

Will try. Still doesn’t explain why the hub has a different zigbee version, and why utilities isn’t an option though.

0 Likes

(jkp) #4

What is th firmware version on their hub? 24.20 is the latest version.

0 Likes

(Chris C) #5

Firmware is 000.024.00020

0 Likes

(Broderick Carlin) #6

Hey Chris, just shot you a PM to get some information so we can take a quick look at this for you and your friend

3 Likes

(Todd Lawton) #7

Broderick,
My hub seems to be having the same issue with the zigbee radio not functioning and showing zigbee version 2.1.6. I also do not have any utilities associated with zigbee in my IDE, but I do have them for z-wave. Can you fix this issue?

0 Likes

(Broderick Carlin) #8

Hey @Todd_Lawton, sorry for the late response!

Can you shoot me the email associated with your account in a PM?

0 Likes

(Todd Lawton) #9

Just a followup that Broderick was able to resolve my issue. It was much appreciated!

2 Likes

(Mathias Becker) #10

Hi guys,

I ran into similar issues - i just ordered a V2 Hub to replace my V1 Hub(one of the first via Kickstarter). It seems like, the new hub is not able to connect to any zigbee devices.
The hub recently updated to FW 000.024.00020
Zigbee is "Functional and running on Version 2.0.31.
Devices are simply not recognized during pairing. ZWave seems to be doing fine…

Any Ideas? help!

0 Likes

(Kevin) #11

Broderick,

Looks like I am having the same issue with my SmartThings V2 hub. I would send you a PM but unfortunately I am too new to the community to reach out to you directly. I am able to connect z-wave devices but have never been able to connect a ZigBee to my hub.

0 Likes

(Tony Fleisher) #12

@BroderickCarlin

0 Likes

(Broderick Carlin) #13

Hey @kdquinn
(and thanks @TonyFleisher for the ping :smiley:)

I’ll shoot you a quick PM to get your email and take a look at this for you

1 Like

(Broderick Carlin) #14

I wanted to sort of close-the-loop with everybody here and lay out what is going on with these hubs and the solution we have.

What we are seeing is a small percentage of older V2 hubs failing to update the Zigbee NCP FW if the NCP FW is on v2.1.6. Luckily, there is a simple fix that has so far been able to recover everyone’s hub that has shown this issue.

If you find yourself facing this issue you can follow the factory reset steps on the below page for your V2 hub but you will want to make sure that you release the button as soon as you see the yellow LED STARTING to blink. You do NOT want to wait for the yellow LED to go solid!

The 25.x release will contain a fix for this issue when that ends up being released so this work around should only be a temporary solution :smiley:

1 Like

#15

I have the same problem after 24.20.
Wait, a factory reset? Isn’t that going to unpair all devices?

0 Likes

(Broderick Carlin) #16

The directions I outlined above will perform what we often refer to as a “soft” factory reset. This will not unpair any devices or cause you to notice any change in the hub. There is however a lot that goes on during a soft factory reset, and one of the things is the hub will attempt a couple self-diagnostic tests on the radios and perform corrective actions.

Just want to reiterate, there are not any destructive actions taken during a soft factory reset but it is critical that you follow the modified instructions as I have outlined above to avoid doing a hard factory reset which would unpair all devices.

1 Like

#17

Thank you for responding, now I know what I’ll be doing after work tonight

0 Likes

(Brad) #18

If you only have Zigbee devices, a soft factory reset should be fine. For users with Z-Wave devices which are securely included, please avoid a soft factory reset at this time. They will likely need to be re-included if you perform a soft reset.

2 Likes