Cannot add any zigbee devices

I got my mom a brand new v2 smartthings hub for christmas. It is the Samsung SmartThings F-MN US-2 Home Monitoring Kit that comes with some sensors and a smart plug. I hooked it up about 3 weeks ago and went to add the devices that came in the box and could not add any of them. I tried rebooting the hub (i even pulled the power plug and the batteries and kept it off for about 20-30 min then plugged it all back in). I have reset the devices to make sure they are unpaired and tried to pair them. They never show up. I had a zwave switch that i added, this worked perfectly. I was able to log into the smartthings ide to see if anything looked out of place. i noticed that the zigbee version is different than my smartthings version that i have at home. Mine is 2.7.9 and her hub is 2.1.6. We both have the same firmware version 000.024.00020. When i click View Utilites on the hub page i have a bunch of items under ZigBee Utilities whereas on hers there is nothing next to zigbee utilities. I took one of the devices home with me (the samsung smartplug it comes with) and was able to find it with my hub right away like normal. I have called support and done some troubleshooting. They ran me through the normal troubleshooting i have already done including rebooting the hub, resetting the devices, etc. They bumped me to the next level of support after about an hour of troubleshooting. I was told i would be contacted in 2-3 business days. It has been a week and i have not heard back from them so i called them again today and was told they are still looking into it. Any ideas on any other troubleshooting steps? Zwave works perfectly so its like the zigbee radio is broken or not working correctly.

is the hub at least 5 ft away from any wifi access points? is the green light on the hub flashing when you’re trying to pair?

There has been a couple of users reporting similar issues caused by having the older zigbee firmware. Support can update it for you. Hold on while I find one of those threads.

Here is one of the posts…

There was also another where one of the ST members spoke about updating the zigbee firmware. Still looking for that one.

Tagging @BroderickCarlin


The hub is wired. Green light is blinking when trying to pair. The device i am attempting to pair is about 5 ft from the hub as well.

oh wow. that is the exact issue. Thank you for tagging @BroderickCarlin

Hey, thanks for the ping! Can you shoot me the email address associated your account in an PM so I can take a look at this for you?

PM sent. Thank you.

Thanks to all who replied. It turned out to be an old zigbee firmware that support was unable to get to take an update. Device was returned (bought it on everyone’s favorite auction site), and will buy another (new this time!).


Hopefully mine can be fixed. @BroderickCarlin is going to be checking mine. Mine was brand new.

@BroderickCarlin was able to assist me in fixing the issue. zigbee version has been updated and everything is now working. I am not sure if the fix was specific to me so i will let @BroderickCarlin respond with the fix. Thank you for everyones help.

1 Like