Problem with Inovelli RED Series Switch/Dimmer Scene capability in NEW ST App

Also including @Brad_ST for visibility on the app crash issue.

Eric, looks like there’s a pretty substantial issue with the scene capability in the Red Series DTHs v. the new ST application.

The Red Series DTH is not exposing the button capability to be used either in Automation (You just see on/Off) or in SmartLighting.

In Automations, no button capability is exposed so you cannot trigger off a multi press for scene (I think we all knew that)

In SmartLighting, when you create a new lighting automation, and select trigger on: Button:
Expected behavior is a list of all the ‘buttons’ representing the up and down press 1-6 and the config button.
Actual Behavior - Blank list and no way out except hitting the ‘back’ button

If you try to re-enter the unsuccessful automation, you get the dreaded “Network Error” message and ST app crashes out. This incomplete lighting automation is also unable to be edited on Classic - your only recourse is to delete the ‘bad / incomplete’ automation on the IDE.

Always happens in New App on Inovelli Red Dimmer using current DTH and device firmware as of 8/13

Current workaround use SmartLighting in classic - which we know won’t be an option in a couple months…

Help please.

Hey @nathancu – interesting, I wonder if this just happened recently as I’ve been using ST and the SmartLighting app for a while now and never experienced this. I still have multi-taps setup with SmartLighting and they appear to still work.

However, you’re right, when I just tried setting up another one, I got a blank screen like you.

Mine is slightly different than yours, but same result.

When I click on Button, I’m able to select the switch, but when I click, “Next”, it loads a blank screen and only gives me the option to select, 'Next" again. When I click, “Next”, the app goes back to all my current SmartLighting setups.

Tagging @erocm1231 for visibility as I don’t know if this is a DTH issue or something with the App.

Thanks for brining this to our attention!

1 Like

Yeah someone brought it up on the Facebook page, new information since then.

I can reproduce it with a new lighting automation in Smartlighting, BUT someone else says thiers works fine. The difference is Im on Android, hes on iPhone.

My old automations I set in Classic are still trucking but new ones cause the issue.

Have no clue ifnits relevant but.

that’s me :slight_smile: Works fine on iOS in the new app with Smart Lightins.

Yeah, I’m on Android too – so this would mean it’s likely something with the App? I don’t have any other scene capable brands to try right now (HomeSeer, Zooz, newer GE), so I can’t rule out if it’s something on our DTH side or not.

I just tried it in Bluestacks Android emulator and it’s working fine there too :man_shrugging:

Hmmm… so weird. I just updated the app and still experience the same thing (doesn’t work). Really strange.

Are you using an Inovelli switch?

yup, the red series dimmer LZW31-SN

1 Like

I’m using iOS and having the problem after going through the migration about an hour ago. What’s strange for me is that my existing SmartLighting automations that we’re setup in the classic app months ago aren’t working now. It was working this morning though. This is on both the Red Series Dimmer and Switch.

Every day there is a new problem with this grand “new” updated Smarthings app. Same issue here. Tried on my Android, Iphone, and also an Android Bluestacks simulator and am unable to access any of the buttons to create a new automation for my LZW31 red series dimmer switch through the Smart Lighting app. When I click “button” the switch shows, but then I click the switch to select the button I get a blank screen. My existing automations created previously in the classic smart lighting app still work, but I can’t edit them. I don’t think this is just an Inovelli switch issue either, since I can’t acess buttons on my GE/Jasco switches anymore either. I think this is an issue with the actual Smart Lighting App itself not working on the New Smartthings app, probably with any custom DTH. Fortunately, i’m still able to setup new automations and access all Buttons through webcore, but given what’s happened over the past week who knows how long that will work.

1 Like

I made the mistake of hitting migrate from classic app, and now stuck. Can’t use any of my 4+ red dimmers’ multi click capabilities :frowning:

Just to add more info. I am on iPhone (11 pro max) and my migration failed to bring the red dimmer with the multi press configured. In new app, I can’t seem to add this capability using either scenes or smart apps. Same issue as OP reported here.

Hi everyone, there is an updated device handler that should fix this issue. After you install and publish it the device needs to receive a report in order for this fix to work. Take note of the change log:

2020-08-14: Fix for SmartLighting app not working with recent change in new SmartThings app.
** Device needs to receive a report after the device handler is updated for this to start working.**
** User can force a report by turning the device on or off, refreshing, etc.**


Confirmed solution Eric, at least in my case. Thank you!

  • Updated DTH through GitHub Sync
  • Published updated DTH
  • Toggled light

Smartlighting now operates as expected in both New and Classic apps.

Any info on what was the actual issue in case others have similar cases?

1 Like

Can confirm, I’m having the same issue with a HomeSeer switch.

Looks like they added the supportedBUttonValues as a Json array. I believe before it wasn’t Json. (Eric M correct me if I’m wrong, i’m sure my terminology is off)

1 Like

Makes sense. Now if they could just stabilize the custom presentations so Eric could add in the custom UI, this thing would be rocking!

1 Like

Thanks @erocm1231 for the quick fix! Updated the DTH and all is well. You guys at Inovelli rock. Looks like I’ll be replacing some more GE switches with Inovelli switches now :slight_smile:

How do I update the device handler?

You can copy and paste it on top of the current one and publish it.

You can find all of our device handlers here:

@nathancu the SmartLighting app is now looking for the “supportedButtonValues” attribute. If it doesn’t find it then it causes an error. So the value needs to be populated. For example:

sendEvent(name: “supportedButtonValues”, value:JsonOutput.toJson([“pushed”,“held”]), displayed:false)


@row - point the author of the Homeseer 's DTH to Eric’s post: Problem with Inovelli RED Series Switch/Dimmer Scene capability in NEW ST App. They should be able to fix you up.