Problem pairing: Micro In-Wall Appliance Switch Aeon Labs


(Anders Heie) #1

Hi Guys and Gals,

Just installed my first Micro In-Wall Appliance Switch from Aeon Labs. It lights up as expected, flashes it’s red dashing eye at me just like the manual expects it to, yet… it just can’t be found when looking for new devices. I’ve flipped the switch, switched it’s mode on the built-in button, pressed it for 5 seconds, flipped it on and off 10 times to ‘forget’ the hub, then tried connecting again. Nothing. It behaves well physically speaking, but no connection.

Does anyone have any tricks to get this on a Smartthings hub?

Model: Micro Switch (2nd edition), In-Wall Z-Wave Applicance Module w/optional Energy Monitor (the official name in manual)


(Steve S) #2

I have two of these installed - both were able to be joined - here’s what I did:

  1. applied power to the Aeon Labs micro switch
  2. In the ST app, pressed the “+” button to add new device
  3. Pressed the button on the Aeon labs micro-switch

At this point, the app just recognized it and it joined.

Note: I do not have a manual switch hooked to either one of the micro-switches.


(Anders Heie) #3

Ah yes, I wish it were that easy. It’s just not showing up when I do that.


(Chrisb) #4

How far away is the device from your hub? This can make a big difference when first pairing. I just put in an outlet two nights ago. It was upstairs on the other side of the house. My hub wouldn’t see it at all. I finally put a long network cable on my hub so I could move it from my router (in the den) into the kitchen area which was about 15 feet close, and one fewer wall to get through. After I did that the device showed up.

It’s generally recommended that you get within 15 feet of your hub with few, if any, walls in between when first pairing. Once paired then communication can happen through the Mesh network, but pairing can’t (at least that’s my understanding).


(Anders Heie) #5

So, I figured it out with a few hints from support.

  1. Opened my iPhone app, Settings > Hubs > ‘hub name’ > Z-Wave utilities > General Device Exclusion > Turn it on
  2. While in general exclusion mode, which I think lasts about 15 seconds, toggle the microswitch 10 times quickly to have the switch send the dis-associate event
  3. Microswitch is now really off the hub, whereas before it must have been listed as ‘don’t use this switch’, which is why I couldn’t see it. I imagine the hub has a list of ‘things’ it won’t show if they are force-excluded earlier.
  4. Toggle switch as normal and have the hub scan for it: Found it immediately, all is well…

Hope that helps someone :slight_smile:


(Ashley) #6

Have the same issue on two if these but with the energy monitoring, LED light shows that it has joined a z-wave network but noting comes up on Smartthings APP. Yet I have some that joined and showed up right away.


(Zack Stark) #7

How do you view the energy consumption on these?


(Ashley) #8

Managed to get the two in-wall switch joined to the hub last night. Think was just very slow to showup.


(Ashley) #9

There is an kw tile within the main tile but noting shows up as of yet in regards to energy consumption.


(Zack Stark) #10

Is there a way to monitor it somewhere else?


(Tony - SmartThings Unpublished Contributor ) #11

I have two of these. I’ve never gotten the kw tile to report anything.


(Zack Stark) #12

This series of steps will fix that:

  1. Select Things page on your dashboard
  2. Choose the Gear icon on your device
  3. Select Configure then Refresh

(Tony - SmartThings Unpublished Contributor ) #13

You all might be interested in GG’s new custom device type for the Aeon Micro:


(Nowhere Man) #14

Thanks for sharing. This saved me a lot of hair pulling. :smile:


#15

Many Thanks you saved my time. smartthings items was so easy no need to exclusion my case but the Aeotec took time to manage.