Aeon Labs Smart Switch pairing issues


(TG) #1

I cannot get an Aeon Labs Smart Switch (2nd Edition) to pair. Any suggestions?


(Mike Maxwell) #2

I’m having the exact same issue right at this moment…


(TG) #3

I got frustrated last night, unplugged my SmartThings hub and put it back in its box to take it back. About an hour later I decided to give it one more try. When I plugged it back in it took a few minuted to become available, but then everything has worked flawlessly ever since. My Smart Switch, door lock, open/close sensors, and siren all connected easily after the restart.

No idea what happened, but maybe just try a hard reboot?


(Dave N) #4

I have 30 devices and have had a few native ST devices that refused to pair no matter how many times you remove the power or choose the correct device to start pairing. Last week I went batty trying to re-pair a device I had removed from ST and decided to use again. The solution I stumbled upon was to just reboot the hub. The pair worked the first time after a reboot.
Maybe the hub has a bit of a bug when going into pair mode after many attempts and goes dumb.


(Mike Maxwell) #5

I got mine working finally, after getting it removed correctly first.
Bit of a PEBCAK issue on my end… Dohhh…