Problem Getting LINEAR FS20Z-1 Z-Wave to connect


(Jess Coburn) #1

Hello, I purchased two of these Linear FS20Z-1’s to hook up my garage doors and I was able to get the first one to connect to the hub (it was about 5 feet from the hub) but I’m not able to get the second to connect. I’ve unplugged, plugged it, pushed the button, even done a dance around it but it’s simply not connecting.

Instructions say to power it on and hit the button to get it to link. So I powered it on, went into the iphone app and told it to add a new device and then hit the button on the relay but it’s not linking. Any ideas? I have it wired to a three prong power cord and plugged in 5 feet from the hub but it’s just not linking up.

Jess


Intergrating A Tv Bed Lift Mechanism
(Jess Coburn) #2

I managed to resolve this issue today. I couldn’t get the device to link with my hub no matter what I tried. So I rebooted the hub, plugged the device in, pressed the button and in the phone told it to look for new devices and it found my device.


(Duffer) #3

I purchased one of these also. Was having issues with it connecting. So I unplugged it thinking it might reset. When I plugged in back in the garage door opened. I would not recommend this device for a garage door. I repeated the unplug replug several times to confirm when power is removed and restored it will trigger the door. I removed it from my door.


(Huntb) #4

@duffer you have to go into the IDE and change the device type to a Z-wave virtual momentary contact switch to get it to work the way you would like with your garage door


(Jess Coburn) #5

@huntb I think @duffer’s issue is that if his home has a power outage and power to the relay is lost it may automatically open his garage door on him when power comes back on. I’m going to test that myself when I get home this evening by killing power at the breaker to see if this happens.


(Huntb) #6

@jesscoburn that shouldn’t be an issue if it is set up as a virtual momentary contact switch. I have lost power once or twice since I’ve had mine installed and have not had any issues. I believe that this device retains its state in the event of a power outage, so if @duffer had pressed the button on the device, unplugged it and plugged it in, it would create an on-off-on condition which could have triggered his garage door. My garage door opens on button press, not button release (I think this is the case for most).


(Jess Coburn) #7

AWESOME! Thanks @huntb


(Duffer) #8

are there instructions somewhere for going into IDE?


(Duffer) #9

I do not recall pushing the button before unplugging the device and pluging it back in. I did unplug several times to ensure it was not a fluke. I contacted linear tech support and they say, “there is no way the device could trigger and event after power restored”. Well I proved that wrong several times. So if your’s is not doing it, then mine must be defective. In either case, I am removed it from the garage door and am trying (so far unsuccesful). to get a memolite to tell me when the door is open or closed. It works great as opener, I just cannot get the contact switch to tell me it is open.


(Ha World) #10

Have you tried resetting the FS20? You have to exclude the device with 3 taps and a hold, try that and then re-include - if it still doesn’t include, try it again 2-3 times. You will need to reset the device to get a new try to lock onto your controllers home node. That should do it, if this is an inclusion issue.


(Jess Coburn) #11

So I didn’t get a chance to go home and test mine but we’ve had a handful of power faults actually and my garage door has yet to open on it’s own (unless you count the android app telling it to mysteriously open at 11pm! when I’ve been home for hours…). I think Duff your situation was unique.

Jess


#12

Well I realize this issue is solved, but I’d like to post my experience with this device anyway because it was a huge headache for me.

So the instructions for the FS20Z-1 are wrong. The instructions for the identical Evolve LFM20 module seem to be accurate for this device. Linear also wanted to charge me $30/15min for tech support (the device costs $30!).

This may be a general Z-Wave thing or it may be just a quirk of this device, but even if the device is not joined to the network, I still found that I had to perform a General Device Exclusion when resetting this device. In order to reset, it doesn’t use the 3-tap,hold method as detailed in the manual. It uses a 2-tap method where the taps have to be within 20ms of each other. That’s fast. After that, a single tap will put it into inclusion mode and the SmartHub will pick it up.

So just to recap, in order to reset, the SmartHub must be in General Device Exclusion mode and the module must be tapped twice in quick succession. The SmartHub should then register the exclusion. Then put the hub into inclusion mode and press the button once on the module to pair.

Hopefully that helps someone else. I feel like this is going to be obvious for some, but it was a pain point for me especially given the horrible instructions in the FS20Z package.


#13

Glad you got it to work!

Zwave and zigbee devices are often tested at the factory and then for whatever reasons the device is not unpaired before shipping.

So whenever you run into a pairing problem, it’s usually a good idea to start with a factory reset for zigbee and a factory reset plus general exclude for Zwave.


(HousePanel Author) #14

Thanks … I was trying the three tap method and it wasn’t working. Need to do this to implement my new Hub v2 so I appreciate the information very much. Update: just tried it… worked perfectly!!!


(steve) #15

So don’t know if you will look at this message duffer, I have a version 2 hub and using same relay. Today comes “upgraded” our meter to a smart meter, power out 5 min. My wife noticed the garage was open hours later and she hadn’t touched the button. The log just says that the door was opening, not that we triggered it from the app. so I agree with you, this relay is not secure, if power outages open my door, and I had no connection to the internet since Comcast didn’t reconnect automatically, I had no idea about it moving while at work. So to reopen this topic, has anyone solved this? Yes I use it as a momentary switch, and I use the app lgk virtual garage door. I know my bulbs auto turn on after power outage, I wonder if this does too?


#16

I’ve tested my FS20Z-1 and it does not activate the garage door after a power failure.


(Duffer) #17

I contacted the manufacture and they told me it was impossible for the device to act that way. They would not consider that it might be defective. So I had to remove it. I have done away with smartthings. It is just not ready for prime time.


#18

You could have saved yourself the grief by connecting a smart plug before the garage opener. It would turn off when your garage is not supposed to operate. I have done that and have not had any unintentional problems. Other than myself and my family pressing the minimote on the wall.


(Drew Clauson) #19

Just to help any others out who come across this issue, I had to put the hub into exclusion mode, then power cycle the FS20Z-1 and then I tapped the button twice very very fast and it worked every time (I had three of these relays to deal with!)


(Arun Jain) #20

I too was having a lot of problems getting my FS20Z-1 to connect to the controller. Sometimes it would work, sometimes not. Realized it was the location of my Samsung hub - I had hidden it in a corner and the signal was weak. I relocated the hub and everything is working fine. So if you are having problems, then start with the Samsung hub as close to the relay as possible. Then start moving it away and see if it goes out of range. One indication if range is the problem is that when you pair the device, it will show up as ACTIVE and after a few minutes or hours it will become INACTIVE.