Preview | SmartThings-managed Edge Device Drivers

I added the driver for the vent (Keen) but when I paired them they did not pair with the driver.

Does your device’s manudacturer and model corresponds to the ones of this fingerprint?

- id: "keen/sv01-610-mp-1.1"
    deviceLabel: Keen Home Vent
    manufacturer: Keen Home Inc
    model: SV01-610-MP-1.1
    deviceProfileName: vent-profile-1

Nope. Didn’t think to check that. Here is what I have.


Yeah there’s a whole host of IDs the Keen vents show up as - depending on which version the vent is. AFAIK they’re all functionally identical. How do we get multiple fingerprints added?

Wonder what they’re going to do about Peanut plugs. Half the time they don’t properly respond with an ID when queried.

Edit - just checked mine - they’re all ‘SV01-612-MP-1.1’ units. I’ve also seen ‘611’ variants in the wild as well. Also, from what I’ve seen in researching the issue (had to do this research to make mine work with Homeassistant - Zigbee2MQTT didn’t recognize mine either.) when you see 1.x it is a fair assumption that you also need all ids that include integers between .0 and .x

So while they have: SV01-610-MP-1.1
THey also need:

I have not seen any difference in functionality. The newer versions will indicate when the signal is weak, or if it is disconnected, with a double flashing yellow light.

A post was split to a new topic: [ST Edge] Ïssue with the Zigbee Power Meter driver

@fido Have you tried the ST Z-Wave Bulb Edge driver?

id: Fibaro_RGBW_Controller/EU
deviceLabel: Fibaro Light
manufacturerId: 0x010F
productType: 0x0900
deviceProfileName: fibaro-rgbw-controller

If it is a direct copy of the groovy version it wont work, the colour rendition was way off to start with, the Fibaro hardware driver itself has special options for various scenes, without access to these in built scenes through the app a generic driver wont do

Appreciate the pointer and if someone says it works and presents all available options and settings (which are extensive ) im more than happy to reset the device and try it but as it is installed in a difficult to get at position i need someone to report back first

Hey guys! Long time no speak. I am having a small problem with smartthings and home assistant as i cant get my hands on an aeotec zwave stick 7.
Since the new edge drivers, i have seen that they finally added the fibaro double switch 2 which i had lying around so i bit the bullet and installed one using edge drivers. The only thing is when the device gets added to HA i only see one switch. No secondary switch no nothing. Anyone have any thoughts on this?

1 Like

I suggest you start a new topic on this and then hopefully others who are using home assistant will be able to comment. You can put it in the following section of the forum:

I do know that at the present time many third-party integrations, including the voice assistants, do not see multiple endpoints on a device that is communicating through an edge Driver. So it’s the same symptom, I just don’t know if it’s the same cause. :thinking:

Hi. I’m having issues with the device tile display.

On March 8, I added a Leviton z-wave 4-speed fan switch (ZW4SF-1BW) using the stock edge driver z-wave fan controller. It works prefectly, app tile shows fan rotating and changes color when active.
Yesterday, March 12, I added 2 more of the same switches. They both function normally but the app device tile doesn’t show the fan rotating or change color when active like the first. I’ve removed and readded both several times with the same reults. The first switch continues to display properly.
Any suggestions?

I received a Third Reality Contact Sensor the other day.
Unlike most contact sensors, this one uses a pair of AAA batteries for power.

The battery level being reported by the ST Edge driver is showing as 45%.
When I connected the same device to Hubitat, it was reporting the battery level as 100%.
Edit: Seeing the same result with the Third Reality motion sensor, although it is using the Zigbee Motion Sensor Mc by @Mariano_Colmenarejo
I’m assuming all Edge drivers inherit from a base standard driver and add features, etc.

This device is using the default edge libraries for the calculation of battery %.
The sensor directly sends the remaining battery % and the driver with those libraries divides it by 2 and displays it.

I don’t know if Hubitat will use the battery voltage attribute instead of the remaining %.

1 Like

A post was split to a new topic: [SmartThings Edge] Issue with channel invitation

can someone from smartthings tech help. Opening the link just gives me a spining circle and the smartthings logo after i tap accept. Can you check it out.
cant download drivers.

Welcome to the SmartThings Community, @dollar65!
Did you accept the invitation a while ago?

no. it’s anew invitation.

When I try to follow the link provided in the initial post, I only get the following error message:

“no healthy upstream”

Hi! I sent you a DM to get more info, please, check your inbox. As I need more personal information, we’ll continue our conversation there.

Is there any way to confirm you have successfully loaded a particular edge driver?

Yesterday, I enrolled in the beta for the first time and “installed” my first driver. Today I tried to install the corresponding new device, but it was not found by the scan. So I don’t know if there was a problem or it just hasn’t downloaded to my hub yet (I read somewhere it could take up to 24hrs to complete).