Powerbot via Smart Home (Connect)


(Nathan H) #1

I’ve done some searching and saw there were issues with the Smart Home connect integration with SmartThings a few months ago. Has this been fixed? I just got a Powerbot and was finally able to get it connected to my IOT network (stupid thing wouldn’t connect using normal procedure). When I try to add the Powerbot to SmartThings, it just sits there and searches without success. My hub and the Powerbot are on the same network, but it never finds it.


(Ron Talley) #2

Mines is connected to smart home and smart things but the smart home-smart things integration is broke.

In other words, I have full control of the PowerBot via smart home but only basic controls via routines or CoRE in smart things. I can view recent activity, start/stop the vacuum, use Alexa to start/stop. I can not control it in ST nor tell it to return to home unless I do it with a pre-programmed trigger.

However, I have it programmed to run once a day and don’t really pay it any attention now-a-days…


(Ben Lebson) #3

I have my PowerBot connected to both the Smart Home app and the SmartThings app. Initially I only had it setup in SmartThings because the Smart Home app didn’t want to see the vacuum. I currently use CoRE to trigger my PowerBot on a schedule contingent on no one being home at the time.


(Eric) #4

I have two of these vacuums. I had the same issue for a couple weeks with adding my 2nd one to SmartThings. I decided to do a bunch of logging and submit a support ticket. As I was making my last attempt, it just worked and I could see in the logs it was connected. No idea why, so I can’t be helpful, but if I was you I’d watch the live logging when trying to pair and then submit a ticket to SmartThings.

I can tell you that I’ve learned a few things when configuring this with CoRE.

The best way to turn it on through CoRE is to call the start(...) method for the capability switch.

You can monitor the state of the vacuum using the operatingState(...) method. “ready” means it is ready to clean, “cleaning” means it is currently cleaning.


(Derrek Krasnicki ) #5

Anyone else’s now show disconnected? Both my bots are showing disconnected in SmartThings not in the native smart home app. But when I try in SmartThings the smart home app doesn’t work either


(Eric) #6

Mine seem to be working using both ST and Smart Home app.


(Nathan H) #7

Support was useless. Looked at the logs in the API and saw it was trying to discover and that was all. As soon as they found out I had a firewall they blamed it, even though everything was permitted through, the two devices communicate just fine individually, and I could prove everything was working fine on the firewall. First I was told they communicate via the APIs and that the firewall must be blocking something. Then when I pointed out they work just fine individually, I was told they communicate directly on the network and not through the APIs. When I pointed out that that proves the firewall isn’t the problem, I was told that even though they communicate directly that the firewall could still be the problem. I can prove traffic traverses the firewall just fine and that traffic from either device is not being dropped. During my troubleshooting, a single packet was dropped, but only after the Powerbot had closed the connection, thus it was out of state.

After proving all of this I was told they couldn’t do anything for be because they aren’t equipped to troubleshoot it. They didn’t even try.


(Eric) #8

You learned a hard lesson. Never tell support you have a firewall.

The issue I was having is that the setup process would show that I have two devices, but it would not complete the next step of adding the second vacuum. Then one day it just magically did. Is that the issue you having?


(Nathan H) #9

Trust me, I didn’t do so willingly. They started asking me what kind of router I used. That is my router so I didn’t have much else to say. I went off on them for immediately blaming my firewall without doing any actual troubleshooting because basically the next response was “Well, that’s not a standard setup so we can’t help you.” That’s when I started pointing out the mistakes in their excuse. If the Hub and Powerbot communicate directly (as is implied by the use of SSDP) then the firewall isn’t in play.


(Nathan H) #10

Apparently SmartThings is only compatible with the SR2AK9350U model and, despite ordering that model, I have the SR2AK9350WK. That is supposedly the reason it doesn’t work. Samsung’s site doesn’t even show a 9350U model, but it does show the 9350WK model.

Does anybody else who has one of these 9350WK models have issues getting it to connect?


(Eric) #11

I have 2 of the 9350WK connected to SmartThings.


(Nick Bartosch) #12

How did you get two working. We just got one of the 9350WK for Christmas. The device can be seen and found by SmartThings but we cannot drill down into the controls of it from SmartThings. We keep receiving the Connection Failed error message. Through the SmartHome app we are able to connect and fully control the PowerBot 9350WK with no issues.


(Nick Bartosch) #13

(Nick Bartosch) #14

I have the same issues you do. Still waiting to see if this gets resolved somehow.


(Nathan H) #15

I never did and support has not replied to me. I can’t even get SmartThings to find mine.


(Eric) #16

I don’t have a good answer. My first one paired right away. The second one did not. I tried about 50 times over a couple weeks. Then one day it just worked.


(Joe Cribbs) #17

@Nick_Bartosch @carmp3fan

When I initially set up my powerbot, I could not get the SmartHome application to connect properly. After a frustrating 2 hours, I found out that the Samsung SmartHome app is broken on Android 7.1 (maybe also 7) devices; in my case, I was using a Nexus 5x, which was on 7.1… >.<

To get the Powerbot to connect and gain controls, I had to turn on my old cell phone (the app isn’t compatible with tablets… >.<) that is running Android 4, install the SmartHome app, and then I was able to connect. Once properly connected, I had all of the controls in SmartHome, which opened the controls in SmartThings (it looks like SmartThings just opens the UI from SmartHome).


(Nathan H) #18

That’s odd because I spent about 6 hours working on mine. I’d go through the setup, put in the network config and key, it would go to connect and my phone wouldn’t connect back to it. I could ping the robot, so it on the wireless just fine. I’d go through the process again, but connect it through an AT&T hotspot and it would work fine. Try again with my main wireless, nope. I finally had to do something to connect it to the hotspot to get it working, add a second robot to go through the setup process again, do the wireless config, and let the phone fail. Samsung Home recognized it as the original one that was on the hotspot and removed the failed one. Everything has been fine since except with integrating it to SmartThings.


(Nathan H) #19

Support has basically refused to be of any help unless I tear down my systems and create what they consider to be a “standard” network. They ignore the fact that, as they have stated, the communication is layer 2 and that brings the in-scope devices to the minimal number (a switch, an AP, the vacuum, and the hub). They also ignore that changing this would likely cause a full day or more to put it back into its current state.

I keep pointing them here to the community because others say they have had the exact same model as me and their vacuums work…eventually. They are asking for anybody with problems to contact support. Doing so will likely be useless given their responses to me, but that’s what they ask.


#20

If you have Google Home, once you added it to ST you can then turn the vacuum on just like any other switches. However you can only start, or pause. It cannot make it return home.