Samsung Vacuum not connecting

I Just purchased a Samsung robot vacuum. I have a V2. It was interesting to get it to connect to the Smart Home app. Getting it to connect to smartthings has been trying. About 20% of the time it will actually find the vacuum, only once it has seen the acknowledgement of paring to the vacuum. But the device is not saved in smartthings. The wifi connection is solid to the vacuum.

I have reset, power cycled.

Any advice would be appreciated

1 Like

Have you had a chance to look at this?

It looks like there are some specific sequencing issues.

Yeah thanks JD, Those steps do not actually work, they seem a little confusing, but it it very structured. The issue is they don’t actually work as intended, I can see the hub trying to communicate with the vacuum and i can see responses periodically. I know the Vacuum is communicating because it works perfectly in Smart home. I can send someone logs.

I’m sure that’s very frustrating. :scream: This forum is a community forum and while there are SmartThings employees who read all the messages eventually, it’s not used for individual support cases.

So at this point the best thing would be to open a support ticket.

If you’re in the US:

Or the UK:

Let us know what you find out! Maybe there’s an authorization step that they left out of the instructions. :disappointed_relieved:

We just pushed a fix out to the platform. Can you try again, and if you’re seeing continued issues, please contact support so we can dig in to see if something is going on.

1 Like

Hey Aaron, No change on the connection. still the same problem, it doesn’t het past step 2, the vacuum says allowed on its display after holding the charge button for 3 seconds. but smartthings doesn’t see the acknowledgment.

@ikaminski @Aaron

I was seeing this issue last week. During the pairing process I’d get as far as needing to press the charge button for 3 seconds but nothing would happen. I tried to pair this thing on both iOS and Android, probably 25 times with no luck.

I then submitted an official ticket and tried to pair again with live logging open so I could add to the support case. What do you know it paired.

I unfortunately don’t have a reason why. But can confirm this was an issue for me.

1 Like

I am having this problem right now. I bought a new phone and had to reinstall the Smart Home software. I have tried to add the device and have gone through several attempts with no success. I can see the device when I scan for it but it does not get past the authentication. If I try again by adding the AP it still hangs at the authentication piece. Any help would be appreciated.

Did anyone every find a solution to this issue? I’m having the the same problem where the Powerbot shows ‘allowed’ during Device Authentication but the Smart Home app will not proceed any further and allow me to add the device.

Same here. WOrks in Samsung Home, but Smartthings crashes on step 2 of 3 trying to connect it.

I suggest that we all create tickets with SmartThings. Email

Truthfully, I found that I hardly “play” with the Vacuum anymore. I have it set to run, through SH, at a specific time of the day and from there, let it do its thing.

I can tell you that the vacuum does work in ST even though the SH integration is jacked up. I can control it with Alexa, CoRE or just from the Things page in the Mobile App. In CoRE, I went all crazy setting up Pistons and what not but to be honest with myself…I have no idea why?:joy:

No go with SH

Can start and stop in ST:

ST does log events:

1 Like

@rontalley - I can do the same. I see the same thing as you. It is sloppy by both Samsung and ST that the DH they built doesn’t work. If they published the information required to make it work, I’m sure the community would create a better DH.


You are right. Samsung stuff not working with Samsung stuff is kinda embarrassing. :rage:


Having the issue with Robot Vacuum where it works in Smart Home but integration is broken in Smart Things on IOS. Very disappointing, I left a bad review in the app store and this was their reply.

“Hi, Ellen with SmartThings support here. I’m so sorry for the bad experience and that you didn’t have a good time working with our support team as well. I’ll look into this case specifically to make sure that our teams get your feedback. You’re correct that this is a known issue occurring on iOS devices, and I’m really sorry it’s affected your home set up this way. This isn’t at all the experience we want for you and I’m so sorry we’ve given the impression that support for iOS is even possibly prioritized below other clients. We prioritize fixes based on how much the issue impedes your usage of SmartThings, so this issue is very high priority for us to solve quickly. While I don’t know an exact ETA on the fix for this bug, I do know that we have our mobile teams actively working on it already. I completely realize that this affects some of our most loyal customers and I’ll make sure we have a note made so we can reach out to you as soon as our teams have tested and deployed a fix.”

This issue has been going on a year now, so I have zero confidence they are serious about actually resolving it. If I could I would take everything back and totally ditch Samsung. The vacuum is great by itself don’t get me wrong, but all I want to do is program my vacuum to run automatically when I leave the house.

@Robot - Unfortunately I don’t believe this is ever going to be fixed. Just about 11 months ago (YES 11 MONTHS) @Aaron told me through PM that he was working on this issue. However, nothing came of it. This all started when ST had their major yearly meltdown.

Will @Aaron or anyone else at ST ever respond to this issue? I suspect not.

The vacuum is connected to ST, that is the funny part. I’ve asked that they open source the DH and I would fix it for them, no response on that either.

Yeah same exact issue. ST is connected to the Robot Vacuum, you can turn it on and off but the dashboard controls / integration with Smart Home is broken. On the Right Now screen it shows the message saying attempting to connect. If you thumb swipe that screen up you can actually see the controls.

Also cannot get the vacuum to come on when ST set to Goodbye/Away.

Never could get the connect app to work but I have been very successful at setting room for the vac to start (or not to start) at specific times or rules designated in CoRE. Haven’t move these rules to webCoRE.

Any updates? Anyone know if they are releasing a Smart Things update soon?

I originally bought the Samsung PowerBot in January 2016 and was able to integrate with SmartThings hub just fine. Things worked until March 2016 when the vacuuum had a wheel issue… so I bought another one in about June. From then until now, still no ability to integrate with SmartThings, although it does integrate with the clunky Samsung home app. So I’m thinking this never gets addressed, and Samsung stuff just isn’t going to work with Samsung stuff in this case… which you’d think would be pretty embarrassing, but clearly no one cares.

1 Like