SmartThings Community

Please help, I'm losing my mind - Alexa, SmartThings and GE dimmers = "I'm not quite sure what went wrong"

Hi all. Hopefully someone can help. I have had an ongoing problem that cropped up for the past few months or so. I have GE Zwave (Jasco) dimmers throughout the house. On/Off through Alexa is fine. However, in asking Alexa to dim a light in any room to a certain percentage, it does dim to that percentage, but I get the message “I’m not quite sure what went wrong”. It’s completely driving me nuts. I don’t know how to trouble shoot at this point.

I did notice a couple of things:

  1. in the Alexa app itself, when I click on any of these devices that are having an issue, it just says “Waiting for SmartThings”. There is one dimmer that shows up in the app that doesn’t have this and it also doesn’t give me the message with Alexa. All other non dimming devices show up and work fine.
  2. the one working dimmer above has a different handler. I tried it as my trouble shooting a little while ago. But, I also worked with support at Amazon on this specific switch.
  3. All switches and dimmers work in the smartthings app itself and from the wall.
  4. the fans work fine (GE fan dimmers)

I don’t know if this is Alexa, SmartThings, GE, handlers, code, etc. Any help is very much appreciated.

Did you try removing the Dimmers in the Alexa App in ST then deleting them in the actual Alexa App and then add them again?

If so, then the next step would be to uninstall Alexa/ST integration and redoing it.

I had this issue before and step 1 solved it.

Litttle confused on “removing the Dimmers in the Alexa App in ST” as the first step. Did you just mean remove from SmartThings first?

I’m having the same issue but with the ceiling fans. It works when I tell Alexa to change the fan speed but she says she doesn’t know what went wrong even though it worked fine. Not sure how to fix