Alexa (Echo) doesn't recognize the GE Smart Dimmer

Alexa is able to control all of the smart bulbs, but doesn’t recognize the GE Smart Dimmer (in wall) which is used to control conventional LED bulbs. Anyone had this problem? Found a solution?

@transco, I have the GE Z-Wave Wireless Lighting Control Dimmer Switch (in wall) and Alexa controls it. Is that the same switch?

Did you add this new switch after you already had Alexa set up? Did you remember to go into the “Amazon Echo” SmartApp settings under “Convenience” on your phone and enable the new switch? Then run the discovery process on the Echo again?

Thank you! I had forgotten that I had to go into the Alexa app to register the device. Once done, it worked perfectly. Well… still trying to find unique names for everything that Alexa can easily understand and that I can remember.


Alexa seems to like two word names for my devices. If I make it longer, she makes me repeat myself (but the Alexa logs show she is hearing exactly what I’m saying…weird).

Thanks. This helped. I was pulling my hair out thinking that all I had to do was add it to my smart things and it would be discoverable.

1 Like

What the heck is the “Convenience” setting? I can’t find that in the Alexa app anywhere (latest version).

I also can’t get Echo to recognize the devices – during Discovery it finds the wall dimmer but not the GE plug in dimmers. What am I missing?

I should note that it works fine with Smartthings App – just not discoverable with the Alexa app.

Ah… nevermind. I found I needed to run the Echo app within Smarthings (I have to say that even as a former IT person of 30 years the app is one of the most bizarrely constructed things I’ve ever seen).


I think I’m having the same problem, but what do you mean run the Echo App within Smartthings? I have the Alexa app and I don’t see and Echo app. Even then I’m unclear ast to what it means to open an app within an app?

I had a problem getting Alexa to recognize one of the two GE z-wave dimmers I recently installed. One for the Bedroom Light and the other one for the Dinning Light.

Both were recognized by the Smart Things App and discovered by the Alexa App. But my Echo and Dot consistently said that it could not find the Dinning Light.

After two days of frustration, forgetting and re-discovering, etc. the problem was resolved when I renamed the device from “Dinning” to “Dinner”. Alexa is blind to the word Dinning!

I share this in case someone may encounter other words that Alexa won’t recognize/operate in a named device.

1 Like

Thank you for your post! I had the same problem and was driving me nuts, Thanks to you, I solved my problem! THANK YOU!

Great! Glad you benefited from my learning experience.

Was your issue with the same word (Dinning), or did you find a different word that isn’t in Alexa’s vocabulary?

1 Like

Is “dinning” a British spelling for “dining” ? Alexa here in the US understands “dining” without any issue.

1 Like

Dinning was my issue. Now I see the post from ogiewon… “Dining” WORKS! LOL Thanks to both of you! I’ve learned what to look out for!

Is a gateway/hub needed for this? When I try to create an account with smart things it says I need a code?
I just bought the EZ switch and that’s it.

Did you ever get this answered? I have the same question.

nope i ended up sending this switch back and got a TP-Link Smary wifi
switch off amazon. No Hub required and it works flawlessly

If you’re using a Z-Wave or Zigbee switch, you’ll need a hub to act as a central controller. One of the newer Amazon ECHO devices actually has a Z-Wave/Zigbee hub inside it allowing it to control these devices directly. But, if you go that route, you won’t be able to use those devices with anything other than the Amazon ECHO.

Thanks for the post save me hours of trouble shooting

1 Like