Z-Wave Switches not Dimming through Alexa

Voice commands through Alexa have been wonky lately, so I went to check out the skill. I didn’t even realize there was a new SmartThings skill (I was still on SmartThings Classic).

I removed the SmartThings Classic and enabled the new SmartThings skill. I then removed all devices in the Alexa app and had it re-scan for devices. All good so far.

I didn’t realize it would remove all my groups, but it did (not a huge deal though annoying). I started creating a few groups and everything seemed fine. Lights are turning on and off without issue. Then I started to try to set the brightness of a group of lights. All my Philips Hue lights dim and brighten without issue, but and ZWave switches do no react. The odd thing is if I call out the Zwave switch individual through Alexa is dims and brightens appropriately.

Ex1. “Alexa set ‘Office Light Group’ to 80%.” This results in only Hue lights reacting. Zwave switch does nothing.
Ex2. “Alexa set ‘Overhead Office Light Zwave Switch’ to 40%.” This results in the Zwave switch reacting properly despite it not reacting when in a group like in Ex1.

Anyone know what I need to do here? It feels like an Alexa issue somehow. I can also select the individual Zwave device and adjust the brightness in the Alexa app using the slider.

1 Like

I’m sure that’s very frustrating. :rage: what’s the Brand and model of the dimmer? (First rule of home automation: “the model number matters.“) Also, what DTH are you using?

People have not reported this issue with most zwave dimmer models, but there have been reports from people who have homeseer zwave dimmers that Alexa is no longer dimming them under the new skill.

It looks like some DTHs are reporting “power level“ to Alexa rather than “dim level“ And that is causing the same symptom that you are seeing.

I had to look up the model. Looks like it is:

The weird thing is I can still control is by calling its individual name in Alexa, but it won’t work in a group.

1 Like

OK, the good news is that almost all of the Leviton Z wave devices are officially supported, so you can contact support and have them look at it. (The homeseerswitches use custom code, so support won’t help with those.)

You can also try Amazon support. You never know, they might have an answer and they are usually very nice. You have to get past the bot first, so try saying “my smart home groups aren’t working in Alexa.“

https://www.amazon.com/gp/help/customer/contact-us/

Okay. So do you think this is an issue with the SmartThings skill? Anything else I can try before going through support which I assume will be a task?

I think it is an issue with any of the many changes smartthings has made recently, which includes changes to the DTHs, changes to the app, changes to the backend platform, and changes to the smartthings Alexa skill. I don’t think it’s an Amazon problem, I would expect the exact same switch would work fine via a different hub.

You can try Amazon support first, though, and see what they say.

Thanks for the helpful answers. One last question since in the earlier days I remember seeing your name around the forums. If I moved away from ST what hub would you recommend? I’m a network engineer, so don’t mind a bit of challenge setting up, but I don’t want it to be a life commitment.

1 Like

I was also a network engineer! :sunglasses:

Given your background, you won’t be surprised that that’s a question that will have different answers for different people. It depends on how much tinkering you’re willing to do, how much you’re willing to spend, how important stability is to you, what type of phone you use, whether you are just looking for Z wave or also want Zigbee support, a bunch of other things.

You can start with this section of the forum and see what people are talking about:

https://community.smartthings.com/c/general-smartthings/other-hubs/105

are you ready for the solution?

check this out… delete the switch from alexa. then change the name of the switch in smartthings to include the word “light” or “lights”. Alexa should populate the switch again automatically. if not, discover devices in alexa.

switch the type to “light” in the alexa device settings.

add to your group and enjoy. i spent the past two days fighting the exact same issue.

someone at samsung or amazon owes me a sticker.

here’s my ordeal LOL

check my post… above… it’s the FREAKING NAME IN SMARTTHINGS that changes how it’s imported by alexa or sent by smartthings… i can’t figure out which, but IT IS FIXED!! it fixes the power level vs brightness labeling as well.

anyone know a software engineer with smartthings i could talk to? i too am a software engineer and would love to see this get fixed and am willing to help

1 Like

What is the name of the newest smarthing app

Lars is one, and I saw you’d already tagged him. :sunglasses:

ST staff will have an indicator by their forum name. There are a few Who post from time to time in the forums, but Lars is the one who has been monitoring the Alexa issues.

1 Like

@fredd0

Thank you for this. It solved my issue with the switch not dimming.

2 Likes

I don’t know how you figured this out, but it worked beautifully. Thank you!