Ge dimmers not working

I have a number of GE dimmers installed in my house. over the last couple of months I have noticed that one by one they are starting to not work. I have about 4 this has happened to. The light on the front is not lit and they do not turn on both manually or through my app. I know they were installed correctly because they worked fine for a long time.

Has anyone had this issue? Are they dead, stuck, or something else? I was thinking if these is a hard reset that might work but I am not sure.


Some people have reported this in the past with the older GE devices, particularly the ones without a neutral. Seems to require turning off at the breaker box and back on. No idea why it happens. Search the forums and you should find some discussion. It’s not a SmartThings issue, btw, Vera users report the same thing. Sometimes strengthening the mesh by adding more devices helps, which would make sense if it had always been unreliable, but why should that occur long after initial installation? Weird.

See the following topic:

I would report it to as well.

JK2 i’d add the model of the dimmers as well, it makes it easier to track which devices rock and which ones suck. Secondly if they have stopped working there should be tab at there bottom near the LED. Pull it out for all off your dimmer switches, then slide it back in for 1 switch and see if it works manually and then through smartthings. repeat the process on the next dimmer and verify the previous switch still works till they all work or you find a bad dimmer. I’ve have had 1 bad switch cause a few others to stop working in the past that’s the process that work for me the find the culprit. Its a pain in the butt, but still cheaper than replacing all of them :wink:

I have one acting up now as well. Shows in ST, swicth works but not zwave control. I have tried a zwave repair and and restarted hub and wifi but no luck. I will try the breaker trick. Mine dimmers are almost all GE 45612 (Jasco zw3003). I know they are not the newest version but they are definitely not the old one either.

Unfortunately, that model is not known for its build quality and Jasco support recommends only using old school incandescent bulbs with this dimmer. Halogen and LED bulbs can apparently damage them, which kinda explains the high failure rate. I posted this to someone yesterday also having issues with the same model dimmer, its not a happy read.

Thanks sidjohn1.

I have not had this for more than 6 months

It is odd too the dimmer switch itself still work at the wall but I just have no zwave control. The hub thinks its always on at same level even when it is not. Seems like a zwave communication issue.

I guess i go on a hunter for better quality switches and dimmers.

Grrr… I have the same issue right now. I sent an email to support. I’m irritated because it was a 40 dollar switch that just up and magically stopped working. The blue LED will not turn on at all and I do not see it responding in the event viewer when I push the button. I’ve disconnected it and reconnected it and still no change. I’m about to see if I can return it to Lowes (come on… a switch that doesn’t last more than a year?? not sure what the warranty is but I guess the right thing would be to check with GE… that or just save the aggrivation and cut my loses) I guess I can try and put one of the GE Bulbs in there with a standard switch.

Oddly enough just in the past week all of my in wall devices have been wonky. This one however won’t come back to life.

If it’s a GE/Jasco switch, the warranty is probably one year. That’s typical, the same is true of zwave switches from Linear and Evolve.

It’s one reason I personally prefer Cooper. Although more expensive, their standard warranty is 5 years, which I think does reflect a higher engineering standard.

ok now I’m incredibly stumped and I’m about to start a thread on this one. I removed my dining room dimmer and put in a 2 dollar switch yesterday because I couldn’t wait any longer for support. Now my dimmer in my living room is not working. The icon is no longer on my dashboard either. I can go into the API and I see it… BUT… it shows up now as a GE Zigbee dimmer. I could be losing my mind (which is how I feel due to my house falling apart with all of these hiccups) but I swear that switch was setup as a ZWave dimmer. I can’t find ZWave as a device type. What’s going on??? This is not how I planned on spending my holiday weekend. Anyone have any insight?
I felt like a loser last night… I had folks over at my house and someone notice my Nest. That opened the door to home automation conversations. Sadly I was once again having issues with my hub and I had to unplug it to regain functionality to the remainder of my working devices. One of the guys there said “I have a Wink and I’ve had zero issues with it what so ever”. I had to bow out of the conversation because I felt like I didn’t have a leg to stand on as I was stumbling around with my system just trying to get a light to turn on. It’s only been in the past few months that I’ve had issues like this. Praying things get better… I’ve invested way too much money into this “hobby”

GE does make both a zigbee and zwave version of their dimmers. They look identical on the outside, but have different internal antennas.

There’s no way one could be discovered by SmartThings as the other by mistake, but I suppose one could have been misboxed. Or perhaps you bought the zigbee versions to begin with?

Both work with SmartThings, so it’s actually not that big a deal if the mesh is strong.

Do you have the one you took out? Look on the back and see what the exact model number is.

(The other possibility is if you’ve been working in the IDE and selected the wrong one by mistake. Then SMARTthings would be transmitting on the wrong frequency and it would show up on the THINGS page but wouldn’t respond to any commands.)

There’s no longer a zwave dimmer option. I was going to change it because I know it was a zwave… But the device type no longer exists. 45639 is the item.

Okay, that device was officially supported, and I know you’ve already contacted support, so they should be able to help. By the way there is also a chat window option for support if you click on the support link in the top right of this page, then click on Troubleshooting, you’ll see a tiny chat window at the bottom right of the page. I’m not sure what hours chat operates, but you can get an instant response if you do use it during operating hours.

Zigbee device types often include the manufacturer’s name, because there are many different proprietary uses of zigbee.

Z wave is much more standardized, and therefore you usually only need the generic device type for your device class. In this case, just the plain “dimmer switch” device type should work for the GE zwave dimmer, as well as for Z wave dimmers from many other brands.

The reason there is a device type for “GE Zigbee dimmer” is because, just as an example, the device handler for the centralite zigbee dimmer is different than the one for the GE zigbee dimmer.

You will also see device types that include brand names when it’s a specialty device with its own proprietary parameters, like Sonos.

And then it’s fairly common that coders who are new to writing device types and create a custom type for a specific device that they own will put the brand and model name in, even though it really shouldn’t be necessary for a zwave device. If there’s a specific command set that they needed to add, they should be identifying the device handler by device class and Command Set. But smartthings does not enforce naming conventions for custom code so you see a lot of variations.

Anyway, if you want to fix the device type before you hear from support, just try assigning the device to the standard “Dimmer Switch” device type in the IDE.

I’ve been having problems with the new style GE toggle dimmer (GE12729). I installed it and it worked fine for a few weeks, then started acting flaky: It works via SmartThings (can turn on, off and dim). It works manually (by flipping the toggle - on/off/dim). The problem is that when I operate it manually, the state does not change on SmartThings - i.e. when I manually (physically) turn the dimmer on, SmartThings doesn;t see that and change state UNTIL I push the Refresh button on the dimmer’s tile in ST. Once I do that, ST updates and shows the correct state of the dimmer. Talked to ST support. They suggested pulling airgap (which I did) and strengthening the mesh - I think it is pretty strong there - I have 4 ST devices within a foot of this one and they all work fine.

Ok now I am almost ready to give up. I just redid construction upstairs and had new switches installed. Everything worked perfect for about a month then one switch stopped working about 2 weeks ago. I just looked in another bedroom and two others are now not working. Does anyone know why these switches are failing and are they junk or is it a reset. I find it hard to believe that these switches, give how expensive, just die. It is also strange how one dies then two others follow?

Thought and assistance is appreciated

Chuck how did you add them to smarthings mine isn’t finding them?!

I’ve slept since then, but think I did a normal type of install: Add new device, Connect Now, then clicked on the switch a few times. Might have taken a few tries on some (especially ones more distant from hub).

They do seem to be more finicky than the normal paddle-style switch. For some of the toggles I needed to add repeater to get them to work (although they were right next to paddle-style switches that work fine - one still only works if conditions are perfect). Seems strange that changing the front of the switch would alter the reception that much - maybe they also changes antenna configuration? Will have to wait for one to break to tear it apart and compare.

Try this first

I had a few act up and was able to get them back up by deleting them from ST and powering down hub for 15+ minutes and them powering back up and re-adding them. Before that the worked at the wall but no zwave controls. Now all have been back up for a month plus. I thought the switched and dimmers went bad but it was a connection issue of some sort.