Platform issue preventing new hub setup (invalid code)

So the other day I decide to install/configure the smartthings hub and devices that I have after looking at them sitting on my desk for a couple week.

Plugin the hub, download/configure the applications and presented with the lovely “Your code is not valid” error message…

After the typical internal troubleshooting and research with no success, reach out to support.

After talking with a very nice individual who confirmed that the hub is available and waiting on the system and that the welcome code is indeed correct, they determined that the client is receiving this message due to the current system issues. The unfortunate advice was “try again in 24 hours and monitor the status pages for updates”… Not a big deal I guess, I waited 2-3 weeks already, I guess a few more days won’t hurt.

Going to sign up for email alerts, I notice that this “issue” was identified on 11/2 (this is the issue they are associating the problems to: https://status.smartthings.com/incidents/q41sjdll3ff9)

So what’s going through my mind at this point is, am I one of the “choice” few being effected by this? I find it really hard to believe that no new hubs or recently reset hubs have been able to be setup for the past week and that forums/community posts aren’t blowing up as a result.

The next thing going through my head looking at these types of posts in the past is, is this a fairly common issue? Not sure I want to invest much time and money into a system that I can’t setup/use for weeks at a time if I have to reset them for any reason.

I’m also somewhat surprised that if this is a major issue that it’s been almost a week and there’s still no resolution or at least a workaround or way for support (at the least) to manage the setup.

In the end, not a rant post but I guess two main questions are coming to mind:
For the Community: Does this thing happen frequently with this long of an outage?
For the Admins/Developers: Knowing that asking for an ETA is pointless (if there was an ETA, it be posted or fixed), is there any workaround for the association issues so I can actually begin using my devices?

  1. which hub did you get? 2015 (v2) or 2018 (v3) or other?
  2. you installed both the SmartThings Classic app and the new SmartThings app? If you installed the Classic app, did you login by choosing New to SmartThings and using your Samsung account?
  3. have you tried resetting the hub?
  1. what region are you in?
1 Like
  1. It’s a 2015 (v2) hub

  2. Both classic and new app were tried on both an iOS device and Android device. First support had me try classic app - remove, reinstall the app, login, attempt to add. Then we tried the new app.
    Yes, “New to Smartthings” and entered my samsung account. I even tried creating a new account in case there was any issues w/ my existing Samsung account.

  3. Many, many times…

When talking with support on the phone, they could see that the hub is not associated to a location, that the Welcome Code I’m using is correct, and that technically there is nothing wrong with the hub.

The versions of the apps (Classic and New) were verified as the most recent. After seeing that the issue spawned with the “latest” version, I tried an older version on the Android device as well.

The end result with support was that there was nothing visibly wrong with the hub, nor the way I was attempting to add it and it was more than likely “something” to do with the current issues on the network. Their advice was to sign up for alerts on the issues, and in the mean time try to setup the hub every 24hrs or so and hope it worked. If after the issue alert went out saying it’s been resolved, and I still have issues to call back and reference the ticket number.

As I mentioned while I’m technically in no rush, I just find it odd that this is a wide spread problem preventing the addition of any hubs for about a week with no ETA on a fix.

Tagging @Brad_ST

1 Like

Try claiming the hub now.

It looks like when the hub was reset by the previous owner, not all of the records tying the hub to the previous owner were cleared out. I removed the remaining record and it should be good to go. This happens occasionally but isn’t something I would classify as wide-spread.

Have a good weekend!

4 Likes

That did the trick.

Thank you much for the assistance

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.