Android app forgot hub, invalid code?

Hi all,

I set up smart things hub a week ago. I had some initial trouble getting the code to work and had to call tech support to have it reset. I set up some devices and went along my merry way.

Today, on launching the smart things app I am greeted as if it is my first time logging in. It has no hubs saved to my account and is asking for the code. When I put in the code I get “invalid” again.

This is very frustrating. I’m curious if anyone else has dealt with the issue described.


Looks like you’ll have to ring support again :frowning:
Or try logging into your SmartThings IDE with your details see if that remembers you.

If anyone runs into this issue the solution is stupid…

When launching the app click “new to smart things” instead of existing user. It logged me in right away and everything worked as expected.

This didn’t work, tried adding my wife as a user, in order to use her phone as a presence sensor and it just creates a new empty location not tied to my existing hub.