Plantlink announcement direct integration with ST


(Ed Meredith) #1

I saw two days ago that Plantlink tweeted official integration with ST. I did not find it anywhere in ST or in the ST blog. So I emailed Plantlink. Apparently their app has been approved by ST and is to be released by ST in the next release. I have been using the plantlink direct monitor but this direct integration according to Plantlink will provide the same data as the plantlink app but now it will be in ST. Any news from ST on when this app will be released?


(sidjohn1) #2

“In a matter of weeks” :smile:


(Chrisb) #3

I see there’s an official device type called Plant Link, so it might be that this is direct connection to the hub rather than cloud-to-cloud.

If that’s the case I might decided to pull my links out of storage and use 'em again next summer.


(Jon Graft) #4

SmartThings just announced official support for PlantLink. I’m curious if you still need the PlantLink hub or if the Links will communicate directly with SmartThings.


(Peter Major) #5

This says that you don’t need the hub…


(Jon Graft) #6

Awesome! Thank you for linking me to the support page for PlantLink. I’m still learning how to navigate the SmartThings database of devices. I’ll keep this in mind next time I have a device question. Thanks again.


(Peter Major) #7

I’d really like a few of these, but I don’t think they have a UK distributor.

All my plants oscillate between being underwatered / overwatered :wink:


(Chrisb) #8

Looks like they are sold on Target and Home Depot’s website… not sure if they’d ship to UK or what the price would be of course. I did see one ebay auction for 7 links and a hub that says it’ll ship world wide. THIS IS NOT MY AUCTION… I’m not endorsing this seller at all, so buyer beware:


(Chrisb) #9

Just looked at the support page and there is a minor error on the page.

The links use AAAA batteries like the SmartSense MultiSensors, not AAA.


#10

Anyone else able to install the SmartApp and get it to launch? I keep getting a Java error according to IDE…


(Chrisb) #11

I can install the smart app in SmartThings, but I get an error when trying to log into my account, so it doesn’t seem to be working right.


(Tony - SmartThings Unpublished Contributor ) #12

I’ve been able to install my sensors without the PL hub.

I get the “‘None Type’ has no attribute ‘name’” error when attempting to install the PlantLink Connector SmartApp.


(Mike Maxwell) #13

Same here, none type error…


#14

After chatting in Support (thanks team!) they mentioned holding off until tomorrow to install the SmartApp. Something needs to be changed on the backend tonight before the app will be ready for prime time.


(Mike Maxwell) #15

Did they mention which device type we’re supposed to use?
There’s two in the IDE now, PlantLink and Plant Link…


(Chrisb) #16

Pretty sure it’s the PlantLink (no space). I tried 'em both and the Plant Lank (with a space) didn’t seem to work right.


(Chrisb) #17

Just to clarify seeing as we’re across many time zones now with people in the British Isles now… what do you mean by tomorrow?

Should we install on Friday or Saturday?

Also… while it’s a relatively minor think if we just have to wait a day, it’s still yet another black eye for SmartThings if they announce it’s ready but it isn’t. These are the sort of things that make it hard to argue with the people who think ST isn’t ready for prime time.


(Kristopher Kubicki) #18

Getting the same error


(Mark B) #19

FYI from the folks over @PlantLink on a recent inquiry re: user experience …

Oso Admin (Oso Technologies)
Dec 18, 08:14

Mark,

Thank you for reaching out. You will still be able to use the PlantLink dashboard (iOS) to setup and monitor your plants. With ST now you have the opportunity to have one less hub, and one quick place where you can quickly check the status of your plants.

We will continue to work with ST to improve the interface and the interaction with other devices inside the ST app.

Mark
Mark
Dec 17, 13:13

Message Body:
Now that Smartthings came out as officially supporting PlantLink, if I move my links over to my ST hub what, if anything will I lose in the user experience after shutting off my PlantLink hub? Would I still be able to log in & view data presented in My Dashboard as well as via my iOS app I have loaded on my iPhone & iPad?


(Chrisb) #20

Well, now I get the PlantLink login screen. But after logging in I get a box that I need to tap to authorize SmartThings. After doing this I get the following error:

An unknown error occured
oauth_credentials