Plantlink announcement direct integration with ST

Okay, so now the app is allowing the login and the authorization button appears to be working okay. BUT… still two problems:

1.) My link seems to be stuck on ‘Calibrating.’ Been that way for hours now.
2.) My link is not showing up in ‘My Dashboard’ on PlantLinks website.

My guess is there’s still a few bugs being worked out, which is fine. I’m not urgently in need of this working right now. I’ll contact support in a few days if it still isn’t working, but just wanted to share what I’ve discovered if others come here with problems.

First you need to switch the sensors over to the plantLink device in the IDE, not the Plant Link one…
Select them in the app…
Waiting… Waiting…
Eventually they will show up in the plant link portal.
Do not open the app again, the devices will be added a second time.
Do not change the name in the portal, it won’t stick, and it will orphan the plant in the portal, and will bring the plant name in again, prepend the plant name with "Smart Things - ", which annoyingly fills up 80% of the plant title bar.
And now you’re back to where you started dinking with the names, so you could figure WTF plants needed water in the portal…

But other than that it’s awesome.

Yep, certainly some growing pains here… but at least my links are showing up in the portal now… so that’s something I guess.

Now I need to figure out if there’s any way, in SmartThings, to react to thinks like “need water.”

I mean if the only benefit to using it in ST is that I have one less hub… that’s not really that big of a deal. And if the associated problems you bring up here aren’t corrected then it really doesn’t help matter.

I’m sure there is, once I get my Plantlinks converted over I’ll look into updating my plantlink monitor app.

In fact, changing any parameters for the plant tiles in the plant link portal orphans that plant/sensor.
So you can’t change the name of the plant, the soil type and the plant type.

Well, then it’s pretty much useless, right? I mean the whole point of the plantlinks is to be able to put in basic information and get customized watering info. If you can’t do that, what’s the point?

When you say “orphans” what do you mean exactly? I’m going to go ahead and try modifying one of my sensors in PlantLink and see if it creates the same problem with me.

When I do this, it sets the plant in the portal to re-calibrate where it stays forever, like it breaks the link back to the ST sensor.

1 Like

I’m not able to reproduce this, Ive ben able to change the plant type and soil type w/o issue or calibration via the web page. I have not deleted the dup sensors yet though, that so far has not worked well and i had to wipe and reset all the seniors to get them working afterwards.

@chrisb Yes, smartthings can react to needs water. All my plants are indoor so i have no need for valve control so i won’t be writing an app for that. If you want ST to notify you, i have a new smartapp for that. I left the old app live for those who prefer to use Kristopher Kubicki’s devicetype. :slight_smile: Choice is good.

I am able to change the plant type and soil info, but the name keeps reverting back.

I just ordered the hub and sensor (picked it up brand new from a friend for $20), so it was cheaper to go that route than buy just the sensor off of Amazon. That said, I have a couple questions:

  1. How do I pair the sensor with the ST hub?

  2. What is the upside to using the ST hub instead of the PL hub (besides having one less hub on the office table)?

  3. Are there any ST apps that work well with PL and ST?


Anyone know how to get plant link to work with Spruce Irrigation? I just got two of the plantlink devices and they are not showing up as moisture sensor :frowning:

UPDATE: I ended up using @Kristopher’s DH and not bother with the plantlink integration at all. I justs needed a moisture sensor for my spruce irrigation system.

[quote=“dignifiedb, post:31, topic:32277, full:true”]

  1. How do I pair the sensor with the ST hub?[/quote]

Pretty much follow the same steps as you would setting up any other ST device. Make sure the device is unpaired, then starting ST looking for new devices, and press the little button inside the sensor.

Last time I tried this (which was a number of weeks/months ago), no… no real advantages and some pretty significant disadvantages.

Disadvantages: Naming is really screwy. You can’t really rename the devices in ST and the devices always shows up in PlantLink as “SmartThings Plant” and no real easy way to rename it there either. This may be fixed now, I don’t know… have looked into it again recently.

Advantages: One less hub.

I thought someone made an app to try and do some ST integration, monitoring, alerting, but again I haven’t really looked at that recently.

Apologies ahead of time for a rather long post.

I’m so confused about how to properly integrate PlantLink with SmartThings. I just got two links. I have not ever had them hooked up to the PL hub. I paired them with SmartThings following the instructions they delineated on a post. I then installed the “PlantLink Connector SmartApp.” It then takes quite a while and just displays “calibrating.”

However, after it’s calibrated, the following is displayed:

I’m not sure whey it’s still telling me to “install the SmartApp” again, as it’s already installed.

Also, once this is done and calibrated, I get some strange errors with the actual PlantLink app itself. In the PlantLink app, when I select a plant type and assign the plant a name it seems to trigger the creation of a duplicate plant in the PlantLink app (one that does not have a plant type or the name I selected assigned to it. Instead, it begins with “SmartThings-”). Part of the attraction of PlantLink app is being able to specify the type of plant and soil so the proper watering amounts and times can be tracked. Once the duplicate plant is created, it seems like the type and name are erased and I"m back to where I started.

If I pair the PlantLink with the ST hub, do I just forget the PlantLink app altogether? If so, doesn’t that defeat the purpose of having PlantLink, as I don’t see where I can select plant type and soil type in the ST app itself.

All good questions, for which I have no answers. I also have the dup plant problem in PlantLinks website.
My plants however show “connected to”, don’t know what’s up with yours.

I got same exact issue and opened case with support. its a known issue and they are working on getting it done.