Phone Presence Sensor quit working

Four days ago my phone a OnePlus 7T quit working as a presence sensor to activate my garage door. I have rebooted the phone and the hub several times. Still not working. I have checked and validated the name of the phone both on the phone and in graphAPIsmarthings. Graph also shows last activity as four days ago.

My wife’s phone is working fine as a presence sensor activating the routines,

What should I do/check next to make it work again? Suggestions?

Just to take care of the obvious, have you gone thru all the Android settings that block an app from accessing location and that can put an app to sleep? They vary between Android releases…

Hal, Thanks for responding. I did just get a new major android upgrade. But I’m ignorant on what to look for and where. Could you point me in the correct direction?


This is for Android 13, as set on my Pixel 4a-5g. Each recent release of Android has tightened default access for location data.

I’m not sure if OnePlus overlay changes how you access settings, I know Samsung does. Basically you’re looking for anything that blocks the app from accessing Location data or puts the app to sleep.

  1. Touch and hold the icon on your home screen, tap App Info
  2. Scroll down and ensure that Pause all activity if unused is off
  3. Scroll back up and tap Permissions, then Location
  4. Ensure it’s set for Allow all the time and Use precise location is on
1 Like

I would recommend that you go into the mobile app settings ( Menu > Settings Cog) and then ‘Get your location from this phone.’ Even if everything looks OK I would recommend disabling and reenabling the location access for each Location shown. The app has got pretty good at detecting if it has the required location access and exemption from being put to sleep.

Unfortunately you may need to recreate or edit any automations based on the presence sensor as it is likely to change its ID as a result of the above.

I have to do this just about every time the SmartThings app updates on one phone.



That worked! And yes I had to add my phone back to all the routines involved. I also had to re add and delete the old tile in Action Tiles.

Now I just hope I remember to do this 13 months from now when I get a new app download or version upgrade on a phone!



Hello! I have a OnePlus Open and I am having the same issue. I was able to get it going again by removing the app from the routines and reinstalling the app, but a few days later it quit working again.

My wife’s iPhonepresemce is working thing that I find peculiar is that I can audit which apps are pinging for location and smartthings does, but nothing happens in the app.

In the past with other phones if I opened the smartthings app the presence would refresh and the routines would run, but this is not happening with my oneplus open.

Anybody have other ideas?

I have occasional location glitches with my Google Pixel 4a-5g phone. In my case the problem has been with the phone, not SmartThings.

When the location is being incorrectly reported I also see that it’s wrong in the Nest app and that it shows up in Google maps. I’ve seen it report that I was “moving” somewhere in the middle of the night by checking my timeline in Google Maps.

One possible way to refresh your location that has worked well for me is to open Google Maps on the phone. Sometimes it is necessary to tap on the dot that represents your location, sometimes it updates without that.

For what it’s worth I feel like my issues have been fewer since the phone updated to Android 14.

I think it’s the OnePlus phones. My wife and I bought have the same OnePlus phones, 7T’s. I have to reset hers at least once a week. Mine will last sometimes two weeks before I have to manually reset the location fined and then update the routines. Pain in the butt, yet I have few choices short of buying a new phone. Maybe it’s Samsungs way of forcing me to get their brand of phone?

Well… saying that I don’t have issues very often of course meant that geolocation failed for me almost right after I posted.

This time it’s only the SmartThings app, Nest knows where I am, Google Maps knows where I am. SmartThings doesn’t.

1 Like

I have the same problem…happened to both my wife and my phone. We both noticed it stopped working right around the Android 14 upgrade. My 2 kids on iphones have no problems whatsoever.

I was able to fix it by making the radius circle bigger around my house, I will probably tweak it to the smallest circle possible, but I think most are right that the phone is just not reporting the exact location.

In the smartthings settings > click "get your location from this phone > click your home address > Increase radius incrementally until you show up as present.

1 Like

I have noticed that every time I reboot my phone (OnePlus 7T). I have to manually reset my phone as a presence sensor and then re-enable all the routines that use it. I’m not sure if that is a phone issue or a Smartthings issue. It is what it is for now.

There are other threads about presence Problem with location from phone for presence and Pixel 8 pro and Presense Detection

The easiest way to fix it when it stops working is to toggle “get your location from this phone” off and on it the app and re-enabling any routines, and perhaps also refresh the geo location at the same time.

Restarting the phone - such as after an update - does seem to be one cause of it stepping working,

1 Like

It’s pretty clear to me that Samsung simply just doesn’t have the Android version at par with the iOS version, because the iOS version works without any issue for presence detection. There’s clearly a bug in the Android version. Toggling location in smartthings works for a day or two and then basically stops working again. It’s almost like a device/location ID is changing that smartthings loses track of. I can see the app polling for location but not updating the presence state.

But I have good news.

I noticed some people were suggesting to use Alexa for presence awareness and a virtual switch in smartthings. That works well, but I’m not an Alexa user. Since I have Google home and Google Assistant, I decided to use that instead. All you have to do is create a routine in Google home for presence detection and then toggle your smartthings presence switch from that. Works like a charm and extremely accurate!

1 Like

My GF’s iOS device is dreadfully unreliable for geo-tracking in the ST app.

Glad it’s working for you. We’ve been using Alexa for geo-tracking for nearly a year since Life360 was decomm’d and it’s been pretty solid. Also, glad to hear that someone can confirm that it works well for Google Home in addition to other solutions like IFTTT.

1 Like

I didn’t want to resort to this, but I should just suck it up and put this solution in place. I will report back!

1 Like

I have a Pixel 7a running Android 14. I have to reset the presence feature after a ST app update or phone OS update. When either of these things happen, presence detection stops working. Some settings are lost, while others are ignored. Once I reset things, presence detection works fine - until the next app or OS update.

The steps I take to reset things are:

  • Home / (“hamburger”) Menu / Gear / Get your location from this phone - turn off; exit the app; close the app; go back and turn on “Get your location from this phone”, then add the phone back into all the routines that use it (which will have red flags).
  • Favorites / Home Monitor > Gear / Security / Useful features / Manage members and select my phone (which became unselected).

The one other resident in my household has an iPhone 14. She has to log into the ST app after an ST app update or OS update, but ST configuration does not need to be touched.

It is as if the Android app stores some configuration information in volatile storage, or doesn’t properly load certain saved flags. Any fixes in the pipeline? There are many reports of this problem in this forum and also on Reddit.

UPDATE: I posted this on Reddit and learned of an easier way to reset this: remove all location permissions for the SmartThings app. Close the app. When you next restart the app, it will ask for location permission which you should grant, then go to Settings and allow full-time access. This is a little more convenient… but the feature does have reliability issues…

started working last week for 3 days, then quit again. i don't like this treatment

After fussing with this for several years now I can safely state that this is a Smartthings issue for at least Android phones. I don’t have a iPhone so I can’t comment on iPhones.

Simple test if you also have a Amazon Alexa running in your house (I do). It also supports a presence sensor capability. I set up a routine using Alexa to turn on the living room lights whenever I return. It has NEVER failed unlike the Smartthings capability for opening my garage door.

I routinely have to reset Smartthings whenever I reboot the phone or sometimes an update from Smartthings.

1 Like