Phone as a presence sensor has stopped working

My phone use to work great most of the time as a sensor to open/close my garage door. About three weeks ago it flat stopped. In the past with the old app I could log off on the phone app and then log back on and it would work. Now when I try to log off I get a warning that the app will be removed from the phone and a loss of data.

Any idea how to get my phone to work again as a sensor?

What’s the operating system on the phone? iOS? Android? What level?

Also, what level is the smartthings app on that phone?

Android.

Not sure what “level” ST means.

Version level of the SmartThings app.

1.7.67.29 even that took a while to find.

1 Like

Does anyone have any idea oh how to reset this? My wife’s phone is working as a presence sensor. So I guess ST has lost the ability to update from my phone. I have rebooted the phone multiple times. I have rebooted the hub multiple times. The only thing I can figure that use to work is logging out of ST on my phone, but now when I try that it states it will remove ST entirely from the phone!!

First thing to check… login to IDE, go to the Devices section and see if the device type for your phone presence is placeholder or mobile presence. It should be placeholder at this point. If it is showing as mobile presence… skip to possible solution at bottom of this post.

If it does show as placeholder… check one more spot also in IDE > Locations > devices and look for any presence sensors and ensure they are listed as placeholder. Same situation… skip below for possible solution.

Possible solution:
If device type shows as mobile presence there are a few extra steps to jump through and it will not be a fun process to go through. Take screenshots,i if needed, of any automations you have that are using presence sensors. Delete any automations using presence on your phone. Turn off get location from your non-working phone in menu > settings in the ST app… no need to do this on your wife’s phone which is working. Logout of the ST app. Login to IDE and check that any presence sensors for your phone have been removed in both the devices section and in Locations > devices. Sign back in to the ST app, enable get location for this phone in menu > settings. Recreate your automations and test.

If device type shows as placeholder… basically the same steps except there is probably no need to check IDE for any lingering presence sensors.

Not a fun process and no guarantee that is will resolve the presence not working on your phone but worth a shot. I saw a post where someone went through a few extra steps but not sure if those were needed but you never know.

1 Like

Thanks! I’ll give this a shot.

Revert back to the previous version of ST app

I did… Presence works fine.
Just turn off auto update on your app

So I was able to get my phone to show as placeholder, but it does not show as a device in SmartThings and I didn’t really find a way to add it. I notice in the ID that it’s not assigned to my hub and I can’t add it because Device Network ID is blank and I don’t know if I can add something random there.

The reason I want the device to show is that I use WebCore and I have Pistons using presence, but I can’t add my phone there if it’s not showing up as a device. Any ideas?

Thanks, I had missed these Capability Group categories. Found it there and added. Let’s now see if Pistons work or not. Thanks for the heads up on WebCore. Thankfully my stuff is not super elaborate, I can probably recreate pretty easily elsewhere. I even probably should check out the new automation stuff in Smartthings to see if it suits my needs. You have any recommendation for an alternative to webcore?

All of my presence sensors, 3 of them, stopped working yesterday, November 15th, 2021. Came home and security alerts went off because Smartthings did not know we were home. Frustrating.

1 Like

I struggled with a similar issue to the original question on this thread. In the end the following realizations lead me to understand that SmartThings was operating normally despite being different than the way it historically worked.

  • When “Get your location from this phone” is enabled, the SmartThings device that is created is named the same as the phone and has a device type of “placeholder”, not “Mobile Presence”.
  • Within webCoRE, the phone device appears under “Select devices by capability” → “Capability group 2” → “presence sensors”.
    • If one looks only under “Select devices by type” within webCoRE, it will appear as if all devices have been added to webCoRE.
  • The original phone with presence sensing that I setup continues to work, despite having a device type of “Mobile Presence”

Here’s the instructions I followed for adding an additional user with presence sensing:

  • If not already done, create a Samsung account for the new user.
  • On the second user’s phone
    • Install SmartThings app on their phone.
    • Login as the new user in the SmartThings app on the phone.
    • Note that a default empty location is created for the new user.
    • Navigate to the “Devices” tab, click the top left icon, scroll down the list if needed, click “Manage locations”.
    • Click the “+” icon in the top right of the screen, click “Accept QR code invitation”
  • On the Owner’s phone, navigate to “Manage locations” just like on the first phone.
    • Click the location for which the new user will be added
    • Click Invite Member
    • Click “Use a QR code”
  • On the second user’s phone scan the QR Code
    • Now that the location is added to the second user’s phone, delete the default location that was created for the second user.
    • Now navigate to “Menu” tab, click the gear icon in the top right of the screen, click “Get your location from this phone”
    • Turn ON the location and navigate back out of settings
  • On the Owner’s phone…
    • Navigate to Automations, webCoRE, Settings, “Available Devices”, “Available Devices”, “Capability group 2”
    • Find “Which presence sensors”, select the name of the new phone
    • Despite the fact that the new device has a device type of “placeholder”, it will display in this list
    • Navigate back out of webCoRE Settings, this may involve clicking Discard Settings a couple times.
1 Like