SmartThings Community

Phone as presence sensor worked fine for six months, but now fails (April 2019)

Hi,
I am facing challenges with using mobile phone as the presence sensor to trigger change my mode from home to away and vice versa.

It was working picture perfectly for more than 6 months and then suddenly it stopped working. I tried recreating the automation. Changed my geo location range etc. It did not help. Finally after 1.5 months it started working by itself last week.

Today I see that the automations that I use for changing my modes have been deleted and am unable to create new automations with 2 users. I am about tired and fed up of this. Any clue what’s happening or suggestions.

which app are you using to set your phone as presences sensor?

ive used smartthings and webcore and found that webcore has been the most stable of the two.

I am using smartthings app. I am trying my level best to avoid using anything other than smarttthings app thanks to stringify :frowning:

Edit: I think I should elaborate a bit, I was using stringify for all my routines and they used to work fine(except presence sensor) but I did not need it then, so around 9- 10 months ago, I decided to move everything from stringify to smartthings classic and it was not good, but I got hooked on to using the presence sensor for changing modes. Then when I got migrated to the new smartthings app(I believe in dec/Jan). I decided that I want to move totally out of stringify and onto a single app for everything. That is where I setup all my rules in the new app and things actually worked fine till i think around Feb end when presence sensor broke and finally started working again by itself last week, and today the disaster stuck again.

My presence sensor rule were pretty basic, If both me and my wife left home change mode to away. If either one of us comes back change mode to home. That’s all the automations were doing.

I have had lots of good experience using a Routine in the Amazon Alexa app. I have set a routine to run a smartthings scene to detect location. works excellent so far.

I looked at Alexa routines but it allows only for one person, my need is for 2 people(me and my wife) to be able to participate in the automation.

Ok looks like I just resolved this. I am not sure why my old automations were cancelled. But I now have figured out why i wasn’t able to create a new automation with 2 people.

There seems to be a bug in the screen for below path.

create automation–>if–> member location --> Who

Clicking on the check box next to another member’s device makes it grey but does not select it and hence the When options dont change. To select multiple members click on the white space after the members name. This makes the checkbox blue and enables the other options in When.

I will upload screenshots later once I can get in front of the laptop.

1 Like

Seems the Amazon Alexa app works very good so far. Much better than anything else iv used.

same - have had the same issue… can add myself to the automation but my wife is grayed out - I can’t select her and therefore never get to see the “everyone” or “anyone” prompts - just myself… this has been going on for a good month now… so far I’ve called 3 times, opened 2 email tickets… the last support call rep told me they had “removed mobile presence automation for security purposes” - I’m getting nowwhere… please someone fix this!! the whole point (for me) is to be able to discover when “nobody is home” or “someone comes home” - i.e. turn off the thermostats, or if it’s dark, turn on an outside light when I arrive, etc-…

Has anyone solved this? I am having the exact same issue… I cannot create an automation that uses member location for anyone but myself - which means that I no longer can do anything useful when “everyone leaves” or “someone arrives” - these options are only available in the automation wizard when you have selected more than one person - but unfortunately - the second user is “grayed out”… I have tried everything, and have called/opened-tickets… but no luck. Last night a support rep told me that “mobile presence is no longer supported due to security reasons” - which I don’t actually believe… please help!

@mikesteadman I was able to solve it by clicking on the white space after my wife’s phone. That selected her device and gave me the everyone anyone option.

@v.prabhu.home is correct - this worked for me also. The checkbox itself (to the left of the member’s name) leads to the gray (grey) out situation mentioned previously… and when you only have a single member selected in the automation, you cannot use “everyone” or “noone” or “anyone” - the options only refer to a single user…

Solution: as @v.prabhu.home says - click to the RIGHT of the member’s name - in the whitespace area just after the last letter of the name… this ‘selects’ the member, turns the checkbox blue - and thus the automation begins to acknowledge more than one member…

nice work @v.prabhu.home - thank you.