SmartThings Community

Phantom Color Ghosts - Hue Just Went Bat Crazy


(Garrette Grouwstra) #37

Looking better now


(Tim) #38

Working correctly again here. Thank you.


Hue Lights all turned green white selecting "Soft White"
#39

Seems good here as well. I’ve been using it about an hour and no green lights yet. I think you got it. Thanks for the prompt fix!


#40

It fixed the issue in time for all my sunset lighting routines this evening. Thanks!


(Toliver182) #41

Thanks for the hot fix. what was the issue?


(YankeeJohnboy) #42

Just added one of the new Gen 3 Color Hue bulbs last week and this “greenish” problem cropped up for me when trying to set soft white. Other color generations seem to be working just fine using same triggering mechanisms (smart lighting turn on and set color). Anyone else having the same issue?


(Tim) #43

I’m having color mapping issues as well. Warm white is no longer very warm. Started affecting my lights today (Feb 7). I’m using Smart Lighting app to control my lighting automations. Usually warm white was much warmer than soft white. Now warm white is much brighter and cooler. Something must have changed to affect color mapping. Other colors seem to be unchanged.

@Lars @slagle Was there a change recently to Smart Lighting or the Hue integration that could be causing this issue?


(Guy) #44

Just noticed my warm white is totally off on the hue bulbs (can tell because the Lightstrip is set to turn on and set level - as the colour mapping is off - and it’s a much warmer colour than the hue bulbs)


(Guy) #45

Looks like this is a “fix” to the colour mapping (from another thread)


#46

Do you still see the greenish issue after yesterdays update?


#47

Is this the original Lightstrip or Lightstrip Plus that supports color temperature?


#48

Hi everyone, I just wanted to explain exactly what changes were made so there is no confusion:

Previously, the four white colors were set using hue and saturation. This created a problem since colors ended up being different on different devices/brands due to hardware limitations, color conversions etc. For example, OSRAMs sometimes exhibited a greenish tint, some bulbs were almost cyan and some bulbs were ok.

In order to solve this and create a good experience for all different bulbs and versions, we changed the white colors to be set using color temperature instead. This means that if you put a LIFX bulb, an OSRAM bulb and a Hue bulb in the same room, their final shade should be close to identical.

Now if a light that does not support color temperature is used, it default to a hue/saturation value that is as close to the temperature as possible (calibrated against 2nd gen color Hue bulb). Again, since hue/sat is used this might not be perfect for all different devices out there.

The color temperatures used are:

Soft white (Default) - 2700k
White (Concentrate) - 4500k
Daylight (Energize) - 6500k
Warm White (Relax) - 3000k

For example, soft white at 2700k is very common when you by LED lights with a fixed color temperature.

Please provide feedback on devices that are way of what you expect, or if you believe the color temperature are not correct.


Smart Lighting - Turn on and set white level (color temperature)
(Jonathan Eastburn) #49

The temperature of the Warm white (relax) setting doesn’t seem right to me. Hue uses a standard of 2300K for ‘Relax’ which is great in the evening. 3000K is hotter even than ‘Soft white’ (the difference only just being noticeable) so does not really fit the bill.
Frustratingly, as this warm setting was something I used a lot, as it stands the update has made my experience of the app worse overall.
Another setting for a ‘warmer’ (lower temperature) white, or a customisable setting would be most welcome.


#50

3000K is what Phillips calls “bright white.” It is noticeably different from the Hue relax setting

Their default for Relax was 2300k for the previous generation, I’d be surprised if it’s changed much.


(Tim) #51

I agree. @Lars while admittedly a very first world problem… I really don’t care for the color changes. I, like Jonathan had intentionally selected a warmer color scheme for my lights. The prior color produced by Warm White in Smart Lighting was much closer to Hue’s relax preset. That was comfortable up until this change. Now it’s way to stark and appears, to my eyes, to be slightly green/yellow rather than warm and incandescent feeling. Perhaps we could have a “warmer” white option added to match the 2300K/Relax setting that we had before. Or even better, as @JonathanE points out, perhaps the ability to choose our own color temp. Since the change, non of the colors of white are very relaxing on my Hue lights.

I have mostly Hue Gen2 and some Gen1 bulbs.

Sincerely, Tim


(YankeeJohnboy) #52

I checked when I got home tonight. It seems to be functioning as expected now, thanks for the fix!


-John Dalton ​


(Mikkel Winther) #53

Yeah, the latest change has made my home look like a sterile environment with that bright white light.

A option for a warmer light that’s closer to the previous option would be nice


#54

Thank you all for your feedback sofar.

We are planning to add the option for turn on and set color temperature as well.

2300k is below the supported color temperature of several brands, hence it was changed to 2700k


Smart Lighting - Turn on and set white level (color temperature)
(Alex Christensen) #55

I’d also prefer to be able to set my Hues to 2300k. Perhaps a slider, and if a device can’t go that low set it as low as it can?


(hyeung) #56

Hi Lars

I sent you some feedback on a seperate post a few days ago, but never received any response to this?

I believe there’s still an issue with the set colour for energise daylight on the older generation of hue bulbs (see me post below)

Look forward to hearing from you…
Regards,
Hung