Hue Lights inconsistent color behavior with smartlighting


(Adam) #1

Use case: Use hue light to act as a smart alarm clock for my 4 year old. Very simple desired behavior. Kid stays in bed until 730 on weekends, and 7 during week. Wait that is desired behavior of the kid. For ST, I want hue light in her room to change to green at aforementioned time.

Implementation Details: I setup 2 smart lighting automations, selected the proper light, and set it to turn color at specific time. Selected green from the ST dialog. I also setup another automation that turns her light on in the early evening but sets it to soft white. Hue is Philips 456186 Hue White and Color Ambiance Extension A19 Bulbs, 2nd Generation. HUB is v1 for both hue and st.

Observed Behavior: Erratic! Everything worked perfect for a day. I was a huge hero with the wife and the kid loves her new color changing lamp. Now I have seen really strange behavior. The good news is the light is actually turning on at the time scheduled. The bad news is the colors are not what I programmed. The early evening schedule mostly turns soft white but one time it just reverted to whatever color I had previously selected. The alarm in the morning turns softwhite or yellow, cant really tell. I can manually select colors. All other hue bulbs and their automations functioning as expecting.

Anyone seen this behavior before? Is this a ST cloud thing or something specific to my setup.


(Kraeg) #2

Hi @ADamL

Not sure if its the same issue as:

Some of the colours have been mixed up for a while - might be worth putting a ticket into SmartThings

Kraeg


(Adam) #3

Thank you. I will look into this and open a ticket. I have a camera in my kids room and I watched her this morning for 5 mins before the color changed go “GREEN GREEN GREEN as she stood next to her lamp.” When it turned yellow she was confused. Then she told my mother in law I screwed up the light. WAF is one thing but MAF is not to be messed with.


(Kraeg) #4

Haha, WAF/MAF both arent anything to be messed with - you only get so much room before it ends.

The quickest workaround is to not select Warm White (or any of the top “White” options) as some of the colours are fine.

Kraeg