Pebble SmartThings Remote App


(Geko) #1

I got Pebble Steel smart watch for Xmas and installed SmartThings Remote app from the Pebble app store. The app allows controlling SmartThings switches and locks. This is a new app, it was published just a few days ago, on Dec 21. I’m surprised there’s no announced of any kind on this board. It doesn’t seem to be an “official” SmartThings app and it’s not the same app that was discussed here:

When the Pebble app is activated, it installs “Pebble Smartwatch” smart app into SmartThings, but I cannot find such an app in the Shared Apps. Does anyone have more info on this app or knows who the developer is?


Smartthings: I'm sick of this sh*t! Shape up!
(Royce Bryan) #2

I just found and downloaded from the Pebble app store as well. I really hope whoever developed this app will continue to improve on it. I would love to be able to dim my lights rather than just turning them on and off. Ability to perform hello home phrases would be great as well.


(Royce Bryan) #3

I don’t know why I didn’t think of this before this morning but after adding the app last night I realized I could create a Virtual On/Off Button to change Modes. Now I have the ability to send smartthings into Night mode from my watch when going to bed.

On a side note it would be great to have the ability to re-arrange the order in which the switches are displayed on the watch. The one I will be using the most is 3 locations down the list, it would be great if I could place it on top.


(Aaron) #4

Thanks for posting about this app, @geko. I had no idea a final version had come out. I’ve been tinkering with the other dev app for a while but didn’t like how it worked most of the time. This seems much more stable and finally lets me have some ST control from my watch once more. Let’s hope there’s improvements made again.


(Adam) #5

Can you actually toggle switches / locks from the Pebble app on the watch? Doesn’t seem to be working at all for me if so.


(Geko) #6

Yes, switches work for me. I have not tried locks though.


(Adam) #7

Hmm ok. I’ll have to play around a bit. I tried my front & garage doors with no luck, I’ll fire up some switches and see what happens.


(Eric Sims) #8

I am stuck on the pebble setup screen in the app. I can’t Authorize Pebble to access SmartThings. The Select One box is empty and the Authorize button isn’t active.


#9

Same here, but it might be an issue with ST because I was just notified of a system issue.

Update: I was able to access the once blank settings menu after ST resolved their problem, but the app crashes with each attempt to use it.


(JF) #10

I’ve got to say, I have had my pebble steel for 3 months and just dawned on me to search for a smartthings app, wow! love the simplicity and convenience…


#11

Have you been able to get your pebble working? I have ST running on BB10 devices, and it works well with 30+ devices. I haven’t been able to get the ST pebble app to work though…


(John Coman) #12

I have installed the app on my pebble an all I get is MODE, SWITCHES, LOCKS. when I select any of these option I get a blank screen. Do I meed something else?


(AC) #13

Same thing here. The app worked great until the recent update. When will this get fixed?


#14

@Aaron_Corbett @geko I just checked pebble app store and new and imporved smarthings app has been updated on store for download… Happy Hunting :grin:


(Geko) #15

Thanks for the update, but I’ve sold my Pebble watch and if SmartThings continues on its path of self-destruction, I’ll be out of it pretty soon too. :-1:


#17

I’m getting the same issue. Were you able to find a solution? Thanks!


(Mike Coscia) #18

Only thing that works is modes. Nothing else even shows up in the menus. Is anyone else having this problem?


(David Smith) #19

Same issue here, though I can select home from the dropdown. Then it just says no smart apps are installed in this location.


(Mike Coscia) #20

Stopped working for me. I deleted and tried reinstalling but it keeps giving me an error…“client is not associated with a smartapp in the location home”.


(Jonathan Dolan) #21

Stopped working for me as well, but curious if it is due to the new watch firmware.