One ornery device: ghost in Alexa?

I migrated successfully to the new Smartthings skill once I realized that local changes had to propagate across a network, and that this could take a non-trivial period of time. However, one device will not migrate properly. Its name on Smartthings is “dresser”. In the past, I had a device on the network named “dresser lamp” using the same switch, a Leviton DZPD3.

It was deleted long ago in both Smartthings and Alexa, but Alexa continues to see the newly discovered device as “dresser lamp”. After letting Alexa search, she says “I found dresser. To control dresser try giving commands…” etc. When I do so, she says “Dresser doesn’t support that.” However, I can control the device by using “dresser lamp” instead!

Clearly, a buffer somewhere is not emptied properly, but in whose code?

Has anyone seen similar persistence in a device name, and solved the problem?

login to to find and remove the device


I tried that, obviously, and if it had succeeded, I would not have posted here.

1 Like

I am having the same issue. Also Alexa is finding 2 or 3 of the same items.

Exp: Bedroom Lamp (Philips color bulb) show in my Alexa devices 3 times. Every time I delete 2 of them they always show back up in the device list. Please tell me how to stop this redundancy!