Echo/Alexa new issue

amazon'alexa'echo
hubv2

(Bill Seymour) #1

I added two more devices to my SmartThings v2 hub, both Cree bulbs and I’m now having a problem that didn’t appear before.

I previously had two Cree bulbs, a Honeywell thermostat and a leak detector. With my previous setup I was only able to control the bulbs from the Echo, they apparently only allow on/off devices currently. I also found earlier that if I wanted to add a device, I had to unlink from the ST hub and relink before the Echo would see new devices.

I linked the two new bulbs to the ST hub and created a room for them. I then tried to discover them from the Alexa app to see if they had that fixed yet, no joy. So I unlinked and relinked Alexa. When the relink was complete I was asked if I wanted to control four devices, but all four were displayed as [object Object]. I selected all four just in case it was a glitch in timing and clicked Authorize. Although the result was “Alexa has been successfully linked with SmartThings”, she doesn’t find any of the four bulbs when set to discovery. :slight_smile:

Were there changes with the recent firmware upgrade that would affect interaction with Alexa? Is there an issues with more than two Cree bulbs? How about with device names (Living Room 1, Living Room 2, Kitchen 1, Kitchen 2)? What else could it be?

Bill


{Object Object} issue with Harmony Hub
(Dan) #2

I am having the same problem…


#3

unfortunately, this is a current known issue with no solution yet. It’s being tracked in the community-created wiki. There is a possible workaround linked to from the wiki, but it’s not working for all people:

http://thingsthataresmart.wiki/index.php?title=Bug:_object,_object_instead_of_device_name

Definitely report it to support@SmartThings.com as well.


#4

I have about 10 cree connected bulbs all seem to be operational. Once you have each device level item selected in the smartapp (Echo). Be sure to go through the done ect. prompts to complete sharing with Echo. Perform Echo device discovery (understand this is where you are having your issue). I bring them in as devices and then group them in Echo app. Kitchen light bulb 1 and 2 become kitchen light ect. I have for individual bulbs set on a range from 0 - 10 just for kicks through echo. I have not attempted to dim light which have been grouped. I did read somewhere that the cree did not like to operate other than 100%. Good luck these have been the most reliable items in my network.


(RH) #5

I don’t seem to be having the problem. Echo, ST and Hue working swimmingly apart and in unison. Good thing I don’t believe in jinxing myself, otherwise I would think I just did.


#6

The problem only occurs when you unlink your account and then link it again.


(RH) #7

Ahhhh…I see. Well I’ll keep my eye on things. Thanks for that info. I hate when Alexa gets a cold!


(Bill Seymour) #8

I’ve tried the suggested procedure in the wiki, but it seems to be pretty much the same as I’ve already tried. I could try adding them one at a time, but since my experience is that you can only add during the initial linking I’d have to try linking with one enabled, unlinking then linking with two enabled, etc…

If I hadn’t of unlinked I could at least have continued to control the first two, but it seemed like such a waste to leave the other two disconnected… Hopefully they’ll get it figured out soon and I’ll be able to go back to functionality…


(James) #9

For future reference (this won’t help you right now :confused: ) you should use the built in convenience smartapp for Echo on your mobile device to add things you want to be able to control, then run Alexa’s discovery, rather than unlink and relink your account.

This same problem is affecting all Windows Phone users, basically it looks like the database entry where the device names reside isn’t being retrieved properly. On WP we’re just seeing GUID and it’s keeping our groups (rooms) from being populated. It is also preventing us from adding new things via the app.


(Dan) #10

Doesn’t seem to just be Alexa and ST related now.
Used my Harmony remote to turn off a light, figures, ST doesn’t work. So I through the Logitech app and I had to relink my Logitech and ST again?
Ok, so I as I connect it, I select my Home hub and get a list of Object, Object, Object, etc.
I select them always but then it says it can not find any ST devices…

Getting super tired of all the hassle, still within my 30 day window to return… Debating…


(Larry) #11

why are you unlinking your account…
to add devices to echo you got the amazon echo smart app… add the new devices

then tell echo to “alexa discover devices”


#12

You should be able to do it both ways, and if you’re also going to add/change echo groups, it’s easier for some people to just open the Alexa app and do it there then to have to use two separate apps.


(Bill Seymour) #13

Because that functionality is broken either in the Alexa app or in the SmartThings app. Once you have devices shared with Echo, if you then add more devices to the ST hub, Echo can not see them. The only way I could get the new ones shared with Echo was to unlink, relink and then choose both the old and new for sharing.


(RH) #14

I added a motion sensor within the past couple of days and some lights and switches late last week. I did not have to unlink/relink. I just verbally told Echo to find the new devices after I authorized them in ST and Alexa found them. Not sure what the difference is. Is there a delayed propagation of new components in ST sometimes? I don’t even know if that’s what happens in the ST hub. Anyway, I didn’t wait and mine worked. Not sure why.


(James) #15

If you go to the Smartthings app on your phone under “Convenience” there is an app called Amazon Echo. Inside that app you can decide which devices the Echo service has access to. After you do that you just say, “Alexa, discover devices.” and voila. No need to link/unlink. (I was doing it that way before.)

The same process works for IFTTT except it’s under “internal” instead.


(Bill Seymour) #16

There doesn’t seem to anything labeled ‘Convenience’ in my Smartthings app. If you go to ‘SmartApps’ there is an entry for Amazon Echo which has a device list. If you press the + button you get a list of the devices that have already been added (currently only the four bulbs; the two smoke alarms, the water leak sensor and the thermostat do not show up), but there’s no method for adding new devices. This is with the SmartThings Android app, version 2.0.7, build number 202276.


(Edward Pope) #17

Not sure on the thermostat but from what I understand Echo works with Switches and lights. The water sensor would not be listed.


#18

See step 10 in the first post in the Echo setup FAQ for adding additional devices:


(Bill Seymour) #19

Click on the on the “Amazon echo” tile, and you will see the list of devices you currently have authorized for Echo to use.

Click on the green plus sign in the lower right, and you will be able to add or remove devices from the authorized list.

But as I said, when I go there and click the plus sign I only have the four lights listed, none of my other devices.


(James) #20

Sorry that Convenience label is only in the Windows Phone version. Also, I believe it only list the devices the Echo can actually control, so switches and lights.