Old Devices Won't Pair with New Replacement Hub


(Rocky Olsen) #1

So ST sent me a new hub, because my old hub refused the latest firmware and in general stopped working…

Now the new hub refuses to pair with the old devices…hell it refuses to pair with devices that were still in their box.

Support ticket still hasn’t been responded to. Support chat says they are to swamped and to open a ticket…

Anyone know WTF?


(April Wong) #2

Hey @rocky_olsen , Sorry for the delay! Usually we’re super on top of this, and definitely not the experience we strive for. But we know the resolution times are longer than usual, and we are trying to rectify the situation as quickly as possible. However, we thank you for your patience, as we get everything sorted out.


(Calvin Robertson) #3

My initial guess is that you will need to reset your devices to factory default. The Zwave network ID is specific to the controller and a new hub would be a new controller in the zwave world.


#4

What Enitech said.

If your old hub is still around, you could try “excluding” each device from it first, then “including” to the new hub.

If your old hub is not still around, or not working at all, then you need to do a factory reset on the devices. Then include them.

In zwave, each device stores the network ID of the primary hub that is allowed to sent it commands. Since the new hub has a new network ID, the old devices are ignoring it, as they are supposed to. They know they “belong” to the old hub.

So you either have to have the old hub release them through the exclusion process, or reset each device to “no primary yet” and then let the new hub include them.

If you didn’t have to do this, then anyone could drive by with a working zwave hub and hijack your devices. So it’s just a security feature of zwave itself, nothing to do with SmartThings.


(Rocky Olsen) #5

Already reset all the plugs/motion sensors per the doc
plugs: holding down the button as i plugged it in (all lights are blinking)
motion sensor: opening it up and pushing the button for 6 seconds till it turns off

Though that was a good first thought, it doesn’t explain the new devices not working either.

Thanks for the responses! Just got frustrated with nothing working


#6

There’s a difference between getting a device ready to pair and resetting it so it erases an old hub’s “ownership.”

What are the model numbers of the devices you’re trying to pair?

p.s. I hear you that the brand new devices didn’t pair either, I’m not discounting that, but sometimes it’s two problems at once. Just eliminating one at a time. :blush:


(Jordan P.) #7

I don’t mean to hijack this thread but reading this made me wonder and so I’m asking. When the new ST hub is released (whenever that is) are all the devices in existing network going to have be excluded and then paired again to the new hub?

There should be a way for a smooth transition. Why would anyone upgrade their hub if you have to redo everything, seems like the old reformat of the HD.

Sorry for jacking the thread.


#8

We just don’t know yet. There is a way for one zwave controller to pass its control to another, but that wasn’t fully supported in the V1 hub so I don’t know if it’s even on the table for V1 to V2 transition. (That method requires that both hubs be in good working order, btw.) There’s also a completely different way that would involve something ST would do, not the customer. We’ll just have to wait and see what they announce.


(Rocky Olsen) #9

It’s all the OG kickstarter kit:

Smartplug Model 5010Q
Motion Sensor - STSS-IRM-001
Pres tag - STSS-PRES-001

How long should i wait on a support ticket - it’s been over 36 hours now with only a auto responder, no human interaction other than the forums


#10

There was a note in one of the other topics that they had a staffing issue with support for the last couple days, they’re going to change the auto message to reflect a longer than usual delay for a few more days.


(Rocky Olsen) #11

Ah must have missed it - thanks for at least trying to help me though! +1 Beer point for you


(Carlos Perez) #12

@rocky_olsen where you able to get the devices paired? I just got my replacement hub and I’m experiencing the same problem, reset all the devices and then went through the join process and none are joining. My last hub simply died so I can not do the exclude procedure


#13

You can do a force exclude (called “a general device exclusion”) for the zwave devices from the new hub, support can walk you through it. (It’s one of the zwave utilities in the IDE, I believe.) This is sometimes necessary even after a factory reset of the individual device.

Treat it like a device you bought from someone else and follow the “never paired” instructions.

For zigbee devices, the factory reset for each individual device should be enough.

It’s a pain, but you should be able to tell if it works with the first device you try.


(Carlos Perez) #14

even tried a brand new extra monoprice door/window open/close sensor and no luck it will just not add it. I followed what you mentioned and reseted the devices during the general exclusion. I tried to add again and even reset and no luck https://www.dropbox.com/s/fq20qc39sqhwj39/VID_20150331_112338.mp4?dl=0


#15

It was just a quick glimpse, but I didn’t see the light blinking on the back of the hub during the search. Might just have been the video angle, though. Does the hub indicator light change during the add process?

Also again it might just be the video angle, but I’m not seeing the blinking light on the door sensor, either. Just the solid light.

The monoprice manual says you should see its lights blink before you begin the include process. Then stop blinking and glow solid when the pairing is complete.

So at least for the time in the video, unless I just missed the blink, the sensor was already joined to another network and needs to be excluded before it can join your hub.


#16

this happened to me. i ended up putting the hub in ZWave exclude mode then doing the factory reset and then added the devices. it took a little time but i got all the devices on the new hub.


(Carlos Perez) #17

Seems my problem is my ISP, if I connect from it it has issues or does not connect while everything else at home has 0 issues. I connect from another ISP it works with no problem. if I use openssl s_client -connect dc.connect.smartthings.com:443 I see I can connect so it is not port being blocked. Getting a new modem from the ISP, lets see how it goes.


#18

Weird, but glad you found it!


(Carlos Perez) #19

Ok seems I identified that the problem is in the initial negotiation. If I connect using internet sharing to the neighbors I see I connect and it works, I change my wireless connection back home and it works without any problems (the for all purposes the hub does not know I changed ISPs since it is behind a NAT), I can add devices, control devices so the problem is in that initial handshake. Also something weird, seem Smartthings does not validate the cert of the TLS 1.2 connection, I see an error in the chain validation and it is ignored.