Zwave devices won’t pair even after move to new hub

The good news is I was able to successfully replace my old V2 hub with a new V3 hub with 109 devices and 35 drivers and my Sharptools dashboard remain fully functional with no changes needed.

The bad news is whatever is preventing me from pairing new zwave devices resulting in this hub replacement still persists on the new hub. Will try again sometime to cut power to all my existing zwave switches/repeaters like I did over the weekend but I’m pretty irked right now that I can’t get 2 zwave remote rockers, a zwave repeater, or a zwave keypad paired.


Since you’ve already tried cutting power once, that’s not going to be a permanent solution a second time around this close to the first time. There’s something going on with your Z wave network. It could be one bad device which is flooding the network. It could be some kind of local interference.

Rather than cutting all the power at once, personally, speaking as a former field tech, I would remove one device at a time, Do a Z wave repair after that until you get no errors. Then let it run for a day or two and see if the problem is either resolved or comes back. :thinking:

Also, have you already checked to see if you have any ghost devices?


Zwave repair completes in about 10 min with no ghost devices and no errors with the previous, what I thought might be problematic v2 hub and same with the new v3 hub. My existing zwave devices connect to the previous and new hub and operate just fine. I just can’t add new zwave devices anymore. Zigbee adds fine. I’ll try one by one cutting power to mains powered zwave devices, repairing, and adding these new devices with a single existing device isolated from the system at a time. But losing drive to continue with any zwave anymore with this fiasco.


I understand. I’ve had days like that even when I was being paid to do the work. It gets really tedious.

Also note that it is possible for a battery powered device to be the one spamming the network, even though it isn’t a repeater. So you need to check those as well, one at a time.


Also, this is something you’ve probably already ruled out, but how many devices do you have in total and how many Z wave devices do you have? :thinking:

I only have 8 operational zwave devices (2 battery/6 switches). I have 6 more I can’t connect (4 of which I have tried connecting). 2 of those have been previously connected (and have been excluded).

109 total devices, but many are virtual. 24 zigbee devices, some c2c, etc.

1 Like

Ok, so that’s not the issue. Hmmm….:thinking:

At this point, thinking as a field tech, I would be wondering either about a flawed SmartThings Z wave implementation, or some kind of local interference.

My own next step (and I realize this might be way too much work) Would be to get a Z wave hub of a different platform, probably the Zooz z-box just because it’s probably got the least friction in setting up, and try adding the problematic devices to that. If they add smooth and easy, The problem is either smartthings or an individual bad device still connected to the old network, which is spamming everything.

If they don’t add to the new platform either, it’s a local environmental issue. Baby monitor or drones or something. Maybe something on a pulse frequency that just happens to disrupt the exchange of encryption keys for the newer zwave devices. Or, you know, poltergeists. :ghost::ghost::ghost:

(an argument against the Z-box is that it won’t work as a secondary, so you might prefer doing this test with something like hubitat. Choice is good.)

So, let’s say they do add to the new network, smooth and easy. The next option to consider is what you were already thinking about doing: removing one device at a time from the old network to try and see if there’s one that’s gone bad.

Or you could go ahead and use real diagnostic tools like the zwave Toolbox. It typically costs $130 on sale and it’s pretty easy to use, and it can save you tons of time, but then you’re getting really deep into the technical stuff and I don’t know if that’s any interest or not.

Or, if the hub from a different brand that you got for the previous step can be added as a secondary, you could try adding it to your SmartThings set up and then using the new hub’s diagnostic tools. Instead of getting the toolbox. That could have the advantage of being a newer Z wave generation, so better able to diagnose possible issues with newer devices. Just fewer tools to use for the diagnosis, but Almost certainly way more than smartthings provides.

So it really comes down to you how much time and effort you want to spend on diagnosing the issue, or if you just want to give up on zwave with SmartThings. (And hope a similar problem doesn’t arise in the future with Zigbee or matter.)

There are some community members like @johnconstantelo Who have over time moved pretty much. Their whole smartthings setup to Zigbee and been pretty happy with that. :man_shrugging:t2: But of course, no guarantees.

1000% happier without a doubt! Thanks for tagging me @JDRoberts

@peeps , even though those devices were new, I’d recommend doing a general exclude just to be safe. In fact, I’d recommend that now since you’re tried multiple times and something could be wonky. Have you tried that already?


Its wierd. It al started suddenly when I was having trouble getting a good pairing with my ring keypad. So I got a repeater. It paired fine. Tried re-pairing ring keypad near repeater vs near hub. No dice. Watched some TV for a bit then tried again later that evening. Unpaired the repeater and excluded and haven’t been able to pair a single zwave device since.

My next step is to cut power one by one to mains powered devices (have already pulled batteries from battery devices or replaced a couple ones this weekend with zigbee devices). When I tried this previously, I had all mains powered devices unpowered but still had 4 battery operated devices operating and connected while attempting to pair new devices.

If that’s unsuccessful, I’ll likely just ditch z-wave as by the time I buy a hub, I’ll likely be in for the same cost as new devices (or similar), with a new hub learning curve and likely some roundabout implementation to get it integrated to my smart home automations/routines. I’d rather have it all in smartthings aside from the couple things that get handled by Homekit (location arrival/departure).

Are there any 3rd party z-wave hubs that have a direct, local connection to Smartthings available?

1 Like

@johnconstantelo I have tried exclude and factory reset multiple times over with each device with the same result with each pairing attempt. The devices time out of their pairing mode prior to ST timing out or pairing and then I can’t even attempt to re-pair them without excluding them again. Exact same result on the v2 hub I have used since my first 2 devices and the new v3 hub I just got as a test to see if it was my hub. Apparently, its not my hub…


Unfortunately, no. :disappointed_relieved:

From the beginning, smartthings had the design philosophy that they were going to make every device look just the same in their app, regardless of whether it used Zigbee or Z wave, or Wi-Fi, or whatever.

When they did that, they either hid or left unsupported a number of features which were protocol specific. This includes pretty much everything that has to do with adding a secondary Z wave hub. So there just isn’t any easy way to do it.

It’s not 100% impossible, but it’s not going to give you what you want.

There are people who run both a hubitat hub and a smartthings hub, and there are some community integrations specific to that configuration which work quite well, but they are also quite a bit of work to set up. If you’re interested, we can talk more about that. Usually people choose this approach because they like the SmartThings app better, but the hubitat engineering is designed to run as much as possible locally and also is a couple generations ahead on zwave.

1 Like

Well dang, I’m not sure what else to try except to try to pair literally right next to the hub, but I suspect you’ve exhausted that as well.

I apologize for not completely reading every post, but what are the devices you’re trying to join?

1 Like

I have tried pairing on top of the hub, next to the hub, 1 ft, 2, ft, 3 ft more, 4ft, 5 ft, 6 ft snore…I’ve tried on the shelf, I’ve tried on the floor, I even tried walking to the door. :wink:

Devices I have tried are Ring 2nd Gen Keypad (with custom driver loaded), Aeotec Extender 7 (stock driver), Zooz Zen34 (with Zooz Zen34 driver loaded…have only tried 2 of the 4 I have on hand).

Previous attempts, prior to this past Thursday or Friday, the keypad would pair (although poorly and would never load fully). Now it does nothing when attempting to pair other than as decribed above. Its like something in my zwave adding process got corrupted and carried over to the new hub in the process.

I guess, now that my V2 hub is factory reset, I could try adding devices to it with no other devices on it.

1 Like

That would be interesting information.

If one of the problematic devices pairs smooth and easy to the old V2 hub with no other devices on it, then the most likely explanation is a bad device among the others flooding the network. It’s rare, but it can happen.


Yep, like JD said, your approach with the reset v2 hub is a very good one. Please keep us posted.


Ok, so new V3 hub had a zwave repair completed when I went to bed last night and didn’t touch it until I got home today. I had batteries removed from my non-mains powered zwave devices since last night, but no other changes to my setup All mains powered devices on and connected.

ST Support needed me to send logs from a pairing attempt, so I attempted pairing a Zen34 to the new V3 hub. No dice, same behaviour.

So I added the V2 hub back to my location. Thankfully, I still had that old box sitting inside a storage area of a table with my welcome code :wink: Validation for my habit of saving electronics boxes forever :smiley:

Once the V2 was added and came online, I loaded the Zen34 driver and attempted to add the switch. SUCCESS, 1st try.

Next, I attempted to add the Aeotec Extender 7. SUCCESS, 1st try.

Then, I loaded the @RBoy Enhanced Keypad Driver and attempted to add the keypad. SUCCESS…or so I thought…it was the same “success” I was having before my zwave fiasco described in this thread. The device paired immediately with Model 0101-0301 and Manufacturer Code 0346-0101-0301, but still shows the message “This device hasn’t updated all of its status information yet…”, same as I was getting initially when loading the driver, but not with the hmorsti driver for this keypad.

So I excluded and re-added. Same result…device pairs but never loads status information.

3rd attempt, same result and that was 15 minutes ago…

So, I now have a working zwave addition process, but still can’t get the keypad working with the driver I want to use…

@JDRoberts @johnconstantelo

1 Like

If it’s pairing now, that’s a good sign. There may be something else going on with your account but with the device pairing we should be able to look at the logs to see what’s going on. I think @maddie had sent you some instructions on how to collect the logs. If you’re able to successfully pair it then try those instructions and send us the logs so we can see what’s going on. Are you using an Android or iOS mobile app?

1 Like

@RBoy @maddie Logs sent just a minute ago. I use iOS on an iPad and iPhone.

1 Like

Thanks for the logs. It looks like your hub is having trouble accessing the capabilities which is causing the driver to fail to load. We’ve submitted a to SmartThings to investigate it, they said it shouldn’t be happening. I remember this had happened a few years ago when they had just launched EDGE drivers. Will keep you posted.


Appreciate y’all digging into this!