Old automations work not new ones

Is something going on with Smart Lighting App or Automations? Last night I tried to create a simple … when door opens turn on light. I have done this in the past and it worked but last night it did not. The light did not come one. 1st I tried in smart lighting App. When that did not work I deleted that and tried to create in in automation. Nope. I have rebooted the hub ( v 3), last night . Try the door again today light did not come one. Deleted the automation and tried again this am. Nope
Using New app.

Old automations work, just not new ones.

Any idea what to check?

Can you post screenshots of the automation or smart lighting rule you are creating?

This is what I created in smart lighting app.

Exactly the same as the old one that works on the front door to turn on entry way light.

This is from when I tried it as an automation after I delete one in smart lighting. And I have
Tried it with different door lights combo.

Are you able to control and see the status of those devices in the new app?

Yes I could/can turn the light on and off in the new app and they both report correct status

And in the status in the app is correct when you manually control the light switch.

I just came back from my walk and the automation worked. I deleted it and retired to set it up in “smart lighting app” so all my lighting automations where in one place. But that does not work. So I put it back as an automation. Very strange.