Odd error message in IDE


(Wayne) #1

Not sure if this is unique to UK but I thought I’d post it here.

Tonight when republishing code which worked previously with no issues (just happens to be the nest DH)
I received the following error message:
“The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint. (Service: Amazon S3; Status Code: 301; Error Code: PermanentRedirect; Request ID: EE9C56275F812707)”

Not understanding the error at all and the code was unmodified from before. Ideas anyone?


[RESOLVED] TTS Not working (May 2016)
#2

I would ask this in the author’s thread for the device handler that you are using.


(Wayne) #3

No this is code which I’ve partially written and been using for months. As you can see the error message looks totally non groovy. It mentions Amazon??


#4

Sorry, I depend on text to speech and I can’t read code. But SmartThings uses AWS (Amazon Web services) to host its cloud, so you do sometime see their messages. Or it could be the same kind of message but coming from the Nest side as I think they also use AWS.

Tagging @slagle @jody.albritton


(Tim Slagle) #5

What is the line that is throwing this error trying to do?

Or is this happenig when you hit publish in the IDE?


(Wayne) #6

No line is indicated. Just happens when I hit publish.


(ValAiRian) #7

Hi,

I have the same issue today in UK … I have this message (with a different ID every time) when I hit the publish button. My Device Handlers worked fine yesterday
Is there any solution ?


(Wayne) #8

Good to know it’s not just me!!


#9

@slagle Is really disappointing to get so dumb replies to a so obvious problem here and from the technical support team too.
And this isn’t the first time when UK support proved they are useless, all they can do is tell you to ask the community. I don’t get what they are there for, it’s only a waste of money if they are paid.

This error has nothing to do with the code in editor, it is probably because the S3 regions SmartThings uses got mixed up (i.e. EU vs US).

Let me confirm that the error happens with any device handler I successfully published before and also with any new device handler I create from a SmartThings template without any modification.
It only affects my UK user account, the US account works correct. Yes, with the same code, not a byte difference.

It started after 11pm on 24 May 2016. Only applies to device handlers, smart apps can be published.

SmartThings monitoring should have picked up this error automatically long time ago and by now should have been fixed instead of blaming the 3rd party developers. Again.


#10

yep same here- also in the UK.


(Jason) #11

Customer service in any company generally doesn’t know technical details or what to do about issues like this. From what I understand, and please correct me if i’m wrong, ST would like us to Open a ticket with support about the issue, then tag tim or jody with the ticket number so they can investigate.

It’s really frustrating that ST doesn’t have a better bug tracker / status page, but Alex just said he wanted to make sure that the status page is a ‘trustworthy source’ so maybe that will get better-


(Wayne) #12

Also worth noting the last time we had a UK outage with all oauth smartapps including Sharptools that there was nothing in the status website. The issue lasted days and even when we spoke to support they admitted there were reported issues yet the site never acknowledged it!
I think there’s a reflectance to publish to the status page now in fear of putting the service in a bad light. That page is not what it used to be.


(Jason) #13

I don’t beleive this page has ever been more than marketing. You won’t hear me argue that the status page accurately reflects anything at the moment. On top of this please know that they have to Manually have a person update the status page, it is not automated.

But I do have renewed hope because of this:

So again, I think that the best thing you can do is open a ticket, tag tim/jody. Maybe @alex can tell us who to tag if we believe that the status page isn’t accurate?I’m assuming tim/jody, but I’m not positive. Also it would be helpful if he would tell us what the parameters are for something being posted to the status page. I.E. How many customers need to be affected for it to be posted.



#14

@schapper05 If that’s what they want why don’t they say so? UK support replied to me that it looks like a coding issue to them.

If they don’t know they should escalate the issue to someone who knows rather than asking the developer “to reach out to the community for help with the code you are using”.


(Jason) #15

My Hope and Suspicion is that they did raise it internally, and only offered the check with the community as a benefit to you that you may find the answer quicker than going through that specific channel.


(Wayne) #16

I’ve been told to write an email with screenshot of the problem and they will take a look. Apparently only one other person has raised so far. Not sure why someone internally hasn’t quickly just tried and publish some new device handlers on the UK IDE and see the error for themselves?!
Anyway, let’s see what happens now.


(Tim Slagle) #17

Thanks for the confirmation all, I have escalated this to engineering. :slight_smile:


(Nik Valiris) #18

As a UK user I’m getting the same error whilst editing a device handler and you re-publish it.


(Tim Slagle) #19

Incase you guys didn’t see it:

http://status.smartthings.com/ was updated with the latest info. Stay tuned there for updates.


(Nik Valiris) #20

Thanks Tim, very useful info. Fingers x it’s solved soon.