[OBSOLETE] Zooz Zen30

So, here is the handler for the zen30. I’ll loop back and put a little more detail but the important things are:

  • It’s a composite device with a child tile in the classic app as well as a separate child device.
  • In the new app, composite devices isn’t something I’ve mastered (apparently not many have!) yet and takes some trickery, so in the new app, it’s just 2 different devices
  • There are 21 available “scene” buttons on this device. I’ve documented the button mapping in the DTH itself, so I won’t do it here. However - I think 21 buttons may be more than the mobile app can handle. While things look okay, assigning things to any of the buttons seems to bomb out.

There is a LOT going on with this thing, so if I missed something or screwed it up…forgive me. :slight_smile: And let me know…


Thanks for all your hard work on this! I kinda figured you were working on it since you’ve done other great work with Zooz devices. Oh, and then I saw it pop up on GitHub :wink:

Anyway, I didn’t get a chance to try this last night, but as soon as I get home from work I’ll let you know how this goes for me. The only thing I can see from looking at the code would be to potentially move line 173 (childDeviceTiles) above line 170 (standardTile) from purely an aesthetics perspective for the Classic app?

Thanks for putting this together!

1 Like

Great Job! Just installed a couple of these and have a quick question. Is it possible to do the Paddle Association Groups to set it so that when you turn on the Paddle it also automatically turns on the Relay? I tried to set it up but I’m guessing it’s because my Child Switch (the relay) does not have a HEX value for the Device Network ID? Just for reference, my Paddle is 67 and the Child Switch is 67-ep1.

I’d like to have both turn on and off at the same time without using any type of WebCore, SmartLighting, etc.

Thanks in advance.

Edit: Also, I have tried to setup a SmartLighting automation but whenever I choose how I want my automation to work and choose the Paddle Button, the app goes to a blank screen and says there’s an error and never lets you finish setting up the automation. I think you mentioned this in your initial post, but what’s the work-around? I’m using the Classic app.

Well, there’s at least one way to do this (in theory), where I could add a parameter to have it flip the relay. Don’t think that would be all that difficult, to be honest. The child device is more of a logical construct, so I think it’s more about that than it is about the network ID as the actual parent controls that switch anyway.

This is exactly what I ran into as well and I’m not sure exactly yet. It needs more work, but I wanted to get this published so people could use the majority of the functionality. I’ll try and fine the time to look at this more closely this weekend.

If you could add a parameter to do this then that would be awesome! I basically just want both the paddle and the relay to turn on and off when the paddle is turned on and off.

Understood, and that’s what I figured. Definitely appreciate you getting this out quick and I know you’ll still be continuously working on it to fine tune it.

Works perfect @doncaruana, thanks a million for developing this DTH! Works in both mobile apps, in my automations, Smart Lighting, and Scenes.

@TheSmartestHouse, thanks for bringing this device to market, even if it’s only z-wave! :wink:

  1. I notice warning in logs during inclusion:

2:20:47 PM: warn couldn’t extract ep from rawDescription
2:20:47 PM: debug endpointDescList.size: 0
2:20:47 PM: debug endpointDescList:
2:20:47 PM: debug endpointCount: 1
2:20:47 PM: debug device.rawDescription: zw:L type:1101 mfr:027A prod:A000 model:A008 ver:1.03 zwv:5.03 lib:03 cc:5E,26,25,85,8E,59,55,86,72,5A,73,70,5B,60,9F,6C,7A role:05 ff:8600 ui:8604 epc:1
2:20:47 PM: debug zwInfo: [zw:L, type:1101, mfr:027A, prod:A000, model:A008, ver:1.03, zwv:5.03, lib:03, cc:[5E, 26, 25, 85, 8E, 59, 55, 86, 72, 5A, 73, 70, 5B, 60, 9F, 6C, 7A], role:05, ff:8600, ui:8604, epc:1, endpointCount:1, endpointInfo:]

  1. Setting the minBright(param 14) and maxBright(param 15) doesn’t seem to work (logs show configurationGet returns 1 and 99 no matter what value I have set in settings). Is this a bug in the hardware?

I need to pull that one out actually…early artifact. :slight_smile: Ignore it please.

I’ll have to check into this and get back to you.

@TonyFleisher - my bad. The length of the parameters got jumbled. I just tested the max/min brightness and fixed it here.

I updated the handler - that issue would have affected a few things.

I also removed the paddle control preference as this got dropped from the switch by Zooz, although I think they’re going to put it back in a firmware update down the road.


Just curious: is the ZEN30 usable without a custom DTH?

It will only recognize the dimmer paddle, but it won’t do anything with the relay switch.

Thanks! Thought that might be the case.

The ZEN30 is a solution to a problem I don’t have. Rooms in my house with ceiling or exhaust fans all have separate switches for lights and fan.

1 Like

Thanks for this!! Just installed it and working flawlessly in webCORE!

Confirmed resolved. Thanks for the fast response!

@philly33flyers Added that preference… It was kinda bugging me trying to get it work, hence the hour… :slight_smile:
So, to be clear, the way it works (last preference added) if you turn on the main switch (ie the paddle) either physically or logically (through the app), the relay will get turned on as well. Same goes for off.

For those curious…this switch always sends a scene command, whether you want it to or not. So I just leveraged that to distinguish the physical button press.

1 Like

Awesome! Thanks for the quick addition and great work.

Edit: Tested it out and it works exactly as I wanted. Thanks again.

1 Like

I thought it was a good suggestion, to be honest. I could see a scenario where someone would want that without going through the hassle of automation, etc

Thank you for posting this. Hopefully the SmartThings team can chime in on the buttons issue. I hope something can be figured out with that because at the moment, those are all useless through Smart Lighting.

Is there a different way to leverage those button presses?

@doncaruana So I noticed that there’s a decent 4-7 second delay when using the paddle to turn the relay on and off with the new parameter you created. Is this just a function of it acting as a scene controller or is there something that can make it closer to instant (1-2 seconds)?

For reference, I have Ramp Rate set to 0 and Zwave Ramp Type to Instant. I think one or both of these makes the switch act as an instant on/off instead of a dimmer.


@philly33flyers - That’s actually just the way the signals are bouncing through your home, to be honest. It takes about 3 seconds here for me for the app to update, but if I’m listening to the switch itself, I can hear the relay click pretty quickly.

You might want to do a zwave network repair or 3. Unless someone has some other advice to give…

Someone at work has some awful delays with one particular switch in his house (not sure what the switch is, not a zen30 though), but they are also inconsistent for him. And he doesn’t use any custom handlers at all.

BTW, those settings you mentioned are just about how long it takes to go from 0 to whatever, ie the fade in/out. It still will dim, but it goes instantly to whatever brightness you have set instead of slowly getting to it. It’s kinda fun to set the ramp rate to about 20 and watch it…lol