[OBSOLETE] Tado (Connect)

Good Point.
In the IDE, go to Locations.
Then click on Home.
In the url you should see your shard url.
Now click on SmartApps.
This is where you should have installed the SmartApp.

D*mn it I might be Alittle to much of a newbie. Wish I could pay someone lol and cheat.

This is what I have

Ok so looking at the url graph.api.smarthing.com that is the original US shard. I don’t know where you are located but I doubt that is the correct shard.

If you click on the my location it will probably ask you to log on again will repoint to another url then if you click on smartapps there will be nothing there. Take note of the url as that’s the one you will always need to use in future.

Then just install the smartapp again and you will be good to go

Just wanted to say thank you for your advise. It was the shard that was incorrect. Took me alittle while to understand the terms but I got it.

All up and running. Thanks again

1 Like

Hi,
I’ve got this installed as a SmartApp, but cannot see it as a Device or find it in Routines etc. It is showing up under “My SmartApps” as being in the “Home” location which is correct. But currently can’t do anything with the SmartApp or control the heating. Any ideas please?

@emiautomation ok soi take it you have gone into the smartapp and entered your tado username and password and selected the tado devices you wish to manage? If the devices don’t get created after that point then you will need to pm me your logs. But it sounds like you haven’t selected a device to manage. There won’t be any devices unless you select a device

Sorry, entirely my fault. I hadn’t installed the device handler. It’s all working now. Cheers for the quick reply.

Hi Stuart,

Do your presence device handlers still work for you? I had one setup for each of us on my Tado heating and it was working perfectly until 13th Jan being polled every 15 mins by pollster but hasn’t worked since with an error coming back from the Tado API call. I couldn’t find any documentation on it to know whether the v1.6 mobile API has been deprecated?

I had the same thing.
Uninstalled and reinstalled everything but still no joy.
Haven’t done any investigations though.
Be interested to see if you get this to work.

@sipuncher & @bobbles Thanks for bringing this to my attention, unfortunately i don’t use this solution anymore personally so i was not aware it had broken. I have now updated Tado (Connect) to v1.4 which includes the presence sensors in the app which uses the new v2 Tado API.

i hope you guys like the addition of presence in the main app. you need to delete the existing tado presence device type and add the newest presence device type from the link below or update from the Tado Repo. you will also need the updated v1.4 Tado (Connect) smartapp also and just save and choose Publish for Me.

then just run the smartapp and after the device selection page you can select your users if required, you also can leave this section blank if you don’t want your Tado users to have Smarthings Presence sensors, its not a requirement to select these.

you can only select tado users that have Geo Tracking enabled, any that dont wont appear in the selection

as always any bugs you notice please let me know.

Thanks for this.
I’ve updated everything and just need to test it.
Will keep you posted

Perfect - All back and working again, thanks Stuart. I’ve sent you a beer
for your troubles.

Simon

1 Like

@sipuncher Thanks, Beer currently being drunk :slight_smile:

Hmm.
Mine still doesn’t work.
Can you walk me through exactly that you did to get this to work again.
Thanks in advance.

@bobbles,

i take it you deleted your presence sensors and then deleted the old Device Handler which had a title of “Tado Heating User Presence”?

then you installed

And updated

then ran the Tado (Connect) smartapp? where if you had it already installed you wont need to enter your username and password, just click next which will show which tado devices you are managing, then the next screen allows you to select the users you wish to have Presence sensors created for. once you have ran through the smartapp settings and save you will have new presence sensors created for each of your users.

you cannot just switch to the new handler in the IDE under your exsiting presence sensor device, as that will not work as the device will not bee seen as a child device of the application.

Hope that helps.

if not as always just PM your log from the devices and smartapp, warning please sanitise your logs to remove password

Thanks.
I’d gotten my knickers in a twist with this so deleted everything and started again.
Everything installed okay. Just need to test it.
Thanks.

Things I did:

  1. Remove any devices based upon existing Tado User Presence Device Handler
  2. Update User Presence Device Handler with new version (and publish)
  3. Update Tado Connect Smart App with new version (and publish)
  4. Open the ST app and open the Tado Connect Smart App going through the
    setup
  5. You will be asked to select which Tado users you want to detect the
    presence of
  6. Complete the setup - A Device will be created for each of the users

As with the previous version you’ll want to have something which polls the
Tado User Presence devices if you want to use them to change the Home/Away
mode for example automatically. I use Pollster.

Simon

@sipuncher you shouldn’t need pollster any more for these devices as the smartapp is now scheduling the check every 5 minutes.

Thinking about it though I could reduce this to every 1 minute if people would prefer this

Are you sure?

Your poll() method iterates over each of the devices in settings.devices
calling .poll on each, but doesn’t do the same for each in settings.users.

I’ve turned off Pollster for these devices and I’m not seeing the Presence
update now…

@sipuncher yup you are correct, i did update the poll and other functions but before i saved my PC hung so i lost it, i thought i had already put it back in, but i am mistaken, i will update to v1.5 later today and do the user poll every 1 minute.